2022-08-11 11:36 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003277TVSportsFootball[All Projects] Generalpublic2018-06-26 11:31
Reportersheik 
Assigned ToStingRayProject InfoTV Sports Football (Cinemaware)
http://www.whdload.de/games/TVSportsFootball.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0003277: In-game gameplay runs too fast. i.e. running, passing etc. Cut scenes and menus
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: Latest pack from WHDDownload (grandis.nu FTP server)

In-game gameplay runs too fast. i.e. running, passing etc. Cut scenes and menus seem fine.
Tested on
- 68020 cycle exact WinUAE
- physical Amiga 1200 fitted with ACA 1230/40MHz + 128MB Fast
Tried various configs, eg NoCache Tooltype, disable CPU caches, OCS on boot etc.
To see what speed the game should run at please try stock A500 in WinUAE. Note the extra speed makes the game unplayable due to the mechanics of the game (it's OK if you are just running and dodging, but trying to complete a pass when it runs n% too fast is more luck than skill :-) )
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoft39 - Kick 3.0
WHDLoad18.1
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0004654

sheik (reporter)

Checked versions, I am testing with SPS #407, WHDLoad Slave v1.01 (2012-02-14)

note ~0005176

StingRay (developer)

Thanks for the report, game is indeed unplayable on fast machines. I have now added a timing fix which will slow down the game, the timing fix can be disabled with CUSTOM1. Have fun. :)

note ~0005179

sheik (reporter)

First of all, thank you so much for looking at this. Your new version is indeed more playable, especially in two-player mode.
However, I've just done side by side comparisons on my accelerated Amiga 1200 (stats on this ticket) running WHDLoad, compared to the disk version running on an A600. The WHDLoad version is still noticeably faster I'm afraid.
This affects things like moving players, passing (like I say, new version is better, so you can pass now) and also things like recovering from a fumble (in one player mode, this is very, very difficult, as you have to press your fire button before the computer responds, but with the timer running fast, you pretty much have no chance :-) ).

I don't know how I can quantify how fast the game runs, only that it is definitely faster compared to the OCS version that the game creators intended it to run on. If I had to guess, I'd say it was about 25% too fast when running on my 68030.

I'm in a PAL region by the way, I don't know if that is relevant. I have tried adding the PAL switch to the slave, but it made no difference, so I'm guessing I've always been running in PAL.

Any ideas on what can be done?

note ~0005180

sheik (reporter)

(trying to reopen)

note ~0005184

StingRay (developer)

Thanks for the fast response, appreciated! :) Please try the attached slaved, is the speed now correct?

note ~0005185

sheik (reporter)

This is superb! Thank you so much for making a new version so quickly!
I have just played two quarters and it is very playable indeed now. Subjectively, I still think it's a tiny bit faster than a 68K machine but it's no longer a problem as you have time to throw now.
I even won a fumble with this version :).

If you don't mind, could you post some details of your fix, as I for one would be interested to know how you tweak for consistent timings. Do you try and target 30 frames per second for example, or is it less precise than that?

Also, have you ever done a slave that allows the user to tweak the speed from the load options?

note ~0005187

StingRay (developer)

Thanks for testing, I will keep the timing fix like this then. As for your question, the game runs so slow on a500 that there was no sync with the raster beam, in the patch I have added a raster wait (using WaitTOF as the game is system-friendly) which will make the game run at the same speed on all machines.

I have also created patches with selectable slow-down fixes, i.e. using one of the CUSTOM tooltypes it is possible to change the slow-down factor. I can easily add an option like that for TV Sports Football too if that's reason for your question?

note ~0005188

sheik (reporter)

That's great, thank you.
I only asked about the config option as I'm conscious that other people may disagree with my opinion. Certainly, your previous version (the one with 3 WaitTOFs in the delay loop) ran smoother on my set up and would probably be more enjoyable in two player mode than the latest one.
But for single player mode, and for closest-to-original experience, the latest version is "best" :-).

note ~0005189

StingRay (developer)

Last edited: 2016-08-09 15:29

View 2 revisions

My pleasure. :) I think I will add the option to select the slow-down factor so people can choose what they like best. That way everyone can decide which speed the game should run at. Thanks for testing and the fast feedback, updated patch will be available this evening or tomorrow I think. :)

note ~0005190

sheik (reporter)

If it's any help, you could use something like this as the readme notes:
--
When playing on accelerated machines, the following timing fix options will affect game speed:

Standard - Very close to original OCS 68K speed. Recommended for single player mode.
Turbo - Faster player movement, recommended for two player mode. Note: if playing against the computer, recovering from fumbles will be harder.
Disabled - Disable timing fixes, run as fast as possible.

note ~0005191

StingRay (developer)

Excellent! I have added your info to the readme and updated the patch, 3 options to change the game speed are now available and can be selected with CUSTOM1. The updated patch is available on the WHDLoad site.

Thanks for great feedback! :)

note ~0005195

sheik (reporter)

Just tested both fixes, and they work brilliantly, thank you so much again!
(I also retested the "no timing fix" option. I'd forgotten how crazy fast it ran before :-) )

note ~0005196

sheik (reporter)

This bug should definitely be marked Resolved now!
+Notes

-Issue History
Date Modified Username Field Change
2015-08-02 21:36 administrator New Issue
2015-08-02 21:36 administrator Status new => assigned
2015-08-02 21:36 administrator Assigned To => StingRay
2015-08-02 21:49 sheik Note Added: 0004654
2016-08-08 15:12 StingRay Note Added: 0005176
2016-08-08 15:13 StingRay Status assigned => resolved
2016-08-08 15:13 StingRay Resolution open => fixed
2016-08-08 17:22 sheik Note Added: 0005179
2016-08-08 17:29 sheik Note Added: 0005180
2016-08-08 17:29 sheik Status resolved => feedback
2016-08-08 17:29 sheik Resolution fixed => reopened
2016-08-08 19:14 StingRay Note Added: 0005184
2016-08-08 19:14 StingRay File Added: TVSportsFootball.slave
2016-08-08 22:51 sheik Note Added: 0005185
2016-08-08 22:51 sheik Status feedback => assigned
2016-08-09 14:25 StingRay Note Added: 0005187
2016-08-09 14:45 sheik Note Added: 0005188
2016-08-09 15:29 StingRay Note Added: 0005189
2016-08-09 15:29 StingRay Note Edited: 0005189 View Revisions
2016-08-09 16:27 sheik Note Added: 0005190
2016-08-09 19:30 StingRay Note Added: 0005191
2016-08-10 12:46 sheik Note Added: 0005195
2016-08-10 12:46 sheik Note Added: 0005196
2016-08-10 14:20 StingRay Status assigned => resolved
2016-08-10 14:20 StingRay Resolution reopened => fixed
2018-06-26 11:31 StingRay Status resolved => closed
+Issue History