2024-07-19 17:20 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005334MegaBall[All Projects] Generalpublic2022-03-10 15:21
Reportermy_pc_is_amiga 
Assigned ToStingRayProject InfoMegaBall (Ed Mackey)
http://www.whdload.de/games/MegaBall.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Summary0005334: Original Megaball executable has tooltypes to map mod. music paths to various
DescriptionGameVersion: english,ntsc,3 disks
SlaveVersion: 1.0 from 20.05.2000

Original Megaball executable has tooltypes to map mod. music paths to various tooltype variables. How can this be done with the slave?
Turning music on/off during play with keyboard shortcut "m" is not working. Music is always off during play. I'm thinking this is because the tooltypes options are not enabled when Megaball is starting and so reason why no music is available.
When started with slave, Megaball notifies that 4/5 songs have been preloaded and so also showing that all songs are not getting loaded.
TagsNo tags attached.
MachineA4000
CPU68060
CPUSpeed66
ChipSetAGA
GFXCardZZ9000
ChipMem2 MB
FastMem656 MB
WorkbenchOS 3.2
KickROM46 - Kick 3.1.4
KickSoft47 - Kick 3.2
WHDLoad18.6
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0010980

StingRay (developer)

Thank you for reporting this problem, the tooltypes parsing required icon.library which is not included with the game. I have updated the patch and added tooltype parsing without icon.library which was an interesting coding exercise.

note ~0010981

Retroplay (reporter)

Text in v1.03 OCS slaves is messed up.
I copied diskfont.library from Workbench 1.3, as you can see in the two attached screenshots, it looks quite funky.

note ~0010982

Pascal De Maeseneire (reporter)

@Retroplay

It's strange... OCS slave 1.03 version tested on my both Amiga A500ACA500Plus and my A1200 and text is seems to be ok.

I downloaded both games (OCS & AGA) from WHDOwnload and just replace with the latest Slave version.
Best Regards,
Pascal

note ~0010983

Pascal De Maeseneire (reporter)

@StingRay

For AGA version maybe put a restriction about the chip into the AGA slave because it seems to start on my A500ACA500plus but a message error come.

Exception "Illegal Instruction" ($E010)
at$9F7994 (TRask Exec.library , Expmen $3D994) occured.

For myself Restriction = Do not start the AGA game without ACA Chip

Best regards,
Pascal

note ~0010986

Retroplay (reporter)

Yes, please disregard my "bug report".
I just realised I didn't test it in cycle-exact mode in UAE, that's what made OCS version look off.
All's well.
+Notes

-Issue History
Date Modified Username Field Change
2021-08-07 13:44 administrator New Issue
2021-08-07 13:44 administrator Status new => assigned
2021-08-07 13:44 administrator Assigned To => StingRay
2022-03-08 12:41 StingRay Note Added: 0010980
2022-03-08 12:42 StingRay Status assigned => resolved
2022-03-08 12:42 StingRay Resolution open => fixed
2022-03-08 19:07 Retroplay File Added: OCS-v1.01.png
2022-03-08 19:07 Retroplay File Added: OCS-v1.03.png
2022-03-08 19:10 Retroplay Note Added: 0010981
2022-03-09 22:37 Pascal De Maeseneire Note Added: 0010982
2022-03-09 22:47 Pascal De Maeseneire Note Added: 0010983
2022-03-10 15:21 Retroplay Note Added: 0010986
+Issue History