2022-08-11 09:59 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004896MaxRally[WHDLoad Installs Games] slavepublic2022-07-21 20:36
Reporterretrogamer 
Assigned ToPsygoreProject InfoMax Rally (Fortress)
http://www.whdload.de/games/MaxRally.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
Summary0004896: Please is it possible to remove the 68020 restriction?
DescriptionPlease is it possible to remove the 68020 restriction?
TagsNo tags attached.
MachineA600
CPU68000
CPUSpeed7
ChipSetECS
GFXCardNone
ChipMem2 MB
FastMem0 MB
WorkbenchOS 2.1
KickROM37 - Kick 2.0
KickSoftNone
WHDLoad18.6
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0011569

MrV2K (reporter)

Bumping This One.

The game doesn't go past the Please insert Disk 2 screen on either WinUAE with the A1200 config set at 68020, 2MB Chip, 8MB Fast Ram, Cycle Exact or the A500 Mini 68040 @ 14mhz 8mb chip 128mb Fast. Both have WHDLoad 18.8 and I'm using Retroplay's Max_Rally_v1.1.lha set.

I get the same behaviour on both setups. I've pressed every key and it just sits there.

note ~0011584

Psygore (developer)

Attached new slave with 68020 restriction removed.

note ~0011587

Pascal De Maeseneire (reporter)

@Psygore


Hello,

I just finished trying the 2 slaves.

ON my A1200 the 2 slaves are ok either in AGA mode or in DHW mode with the 2nd slave.

on the other hand its my A500 ACA500PLUS, I have the message "You need Chipmem up to $S150000 (1134 Kbyte) to run this program"

I know I only have an A500 rev.6 512k +512k in the trap door but with an Agnus 8372A.

Or precisely on the aca500plus in expert mode "F10" there is an option that emulates the 1MB RAM chip.

if I test the ADF files, in this expert mode with the chipmen option activated and a custom KS in this case the game starts and works correctly. I tested ADFs with KS 2.04, KS 2.05 (37.350) and KS 3.1 and it works.

On the other hand, still in this mode with KS 3.1.4, the game crashes.


Do you think you can stream there with an alternate slave for the ECS version. allowing options to launch the game correctly.

Here is the link of the EXPert mode (F10) of the ACA500 Plus:

http://wiki.icomp.de/wiki/ACA500plus

If you are a programmer or just interested in the inner workings of the ACA500plus, you can find lots of information here:

http://wiki.icomp.de/wiki/ACA500plus_registers

Many thanks for You attention,

Best regards,

Pascal

note ~0011588

Pascal De Maeseneire (reporter)

translate error sorry :

ON my A1200 the 2 slaves are ok either in AGA mode or in ECS mode with the 2nd slave.
+Notes

-Issue History
Date Modified Username Field Change
2020-12-08 16:55 retrogamer New Issue
2020-12-09 20:59 Psygore Assigned To => Psygore
2020-12-09 20:59 Psygore Status new => assigned
2022-07-16 23:09 MrV2K Note Added: 0011569
2022-07-21 00:43 Psygore File Added: MaxRally12.lha
2022-07-21 00:44 Psygore Note Added: 0011584
2022-07-21 19:49 Pascal De Maeseneire Note Added: 0011587
2022-07-21 19:57 Pascal De Maeseneire File Added: ACA500PLUS EXPERT MODE.png
2022-07-21 20:36 Pascal De Maeseneire Note Added: 0011588
+Issue History