2021-09-25 12:16 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002244Lotus2[WHDLoad Installs Games] slavepublic2010-03-21 12:23
ReporterRetroplay 
Assigned ToWeplProject InfoLotus 2 (Magnetic Fields/Gremlin)
http://www.whdload.de/games/Lotus2.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0002244: Lotus 2: Score saving alteres hiscore table
DescriptionI have CUSTOM2=1 tooltype enabled thus allowing highscores to be saved.

Now, the first time you start the game the highscore is 50000000 but after you get a hiscore and save it, the hiscore is reduced to 25000000.

See this thread at EAB where I discovered the "bug".
http://eab.abime.net/showthread.php?t=50698

This is not a major issue affecting gameplay in any way, just thought I'd let you know.

I'm using latest WHDLoad v17 beta (Dec. 10 2009)

Steps To Reproduce1. Start a game from a fresh install with CUSTOM2=1 enabled.
2. Play a game, get a score and save it.
TagsNo tags attached.
MachineA1200
CPU68EC020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 3.1
KickROM39 - Kick 3.0
KickSoftNone
WHDLoad16.9
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0001666

Wepl (manager)

Are you using the latest slave?
I have tested it even and it shows 25m without a previously saved score file.

note ~0001667

Retroplay (reporter)

Yes slave v1.9.

note ~0001683

Wepl (manager)

I assume you mean the behavior that the scores are not halfed if custom2 ist not set?
Because if custom2 is set the scores should be halfed also if there is not highs file yet.

note ~0001684

Retroplay (reporter)

Ah my bad.
You are absolutely right.

note ~0001689

Wepl (manager)

Last edited: 2010-02-19 22:13

fine.
can you please test if the attached slave fixes that issue?

note ~0001699

Retroplay (reporter)

It's fixed here.

note ~0001700

Wepl (manager)

thanks for testing, the new install package has been released
+Notes

-Issue History
Date Modified Username Field Change
2010-02-08 14:43 Retroplay New Issue
2010-02-08 14:43 Retroplay Machine => A1200
2010-02-08 14:43 Retroplay CPU => 68EC020
2010-02-08 14:43 Retroplay CPUSpeed => 14
2010-02-08 14:43 Retroplay ChipSet => AGA
2010-02-08 14:43 Retroplay GFXCard => None
2010-02-08 14:43 Retroplay ChipMem => 2 MB
2010-02-08 14:43 Retroplay FastMem => 8 MB
2010-02-08 14:43 Retroplay Workbench => OS 3.1
2010-02-08 14:43 Retroplay KickROM => 39 - Kick 3.0
2010-02-08 14:43 Retroplay KickSoft => None
2010-02-08 14:43 Retroplay WHDLoad => 16.9
2010-02-10 18:14 Wepl Status new => assigned
2010-02-10 18:14 Wepl Assigned To => Wepl
2010-02-10 18:27 Wepl Note Added: 0001666
2010-02-10 18:37 Wepl Status assigned => feedback
2010-02-10 18:38 Retroplay Note Added: 0001667
2010-02-17 23:20 Wepl Note Added: 0001683
2010-02-17 23:38 Retroplay Note Added: 0001684
2010-02-19 22:11 Wepl File Added: Lotus2.Slave
2010-02-19 22:12 Wepl Note Added: 0001689
2010-02-19 22:13 Wepl Note Edited: 0001689
2010-03-07 21:55 Retroplay Note Added: 0001699
2010-03-09 22:18 Wepl Note Added: 0001700
2010-03-09 22:18 Wepl Status feedback => resolved
2010-03-09 22:18 Wepl Resolution open => fixed
2010-03-21 12:23 Wepl Status resolved => closed
+Issue History