2021-09-18 00:03 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002239SideWinder[All Projects] Generalpublic2010-03-20 18:53
ReporterVikingex - Daniel 
Assigned ToWeplProject InfoSidewinder (Arcadia Software)
http://www.whdload.de/games/SideWinder.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
Summary0002239: I have an A600 with the standard 68000 cpu. I get the error "Needs 68020" when
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.0 from 20.05.2000

I have an A600 with the standard 68000 cpu. I get the error "Needs 68020" when trying to run Sidewinder.
I think there is an issue in the coding as this game shouldn't require this CPU. Any time to fix this?
Thanks
TagsNo tags attached.
MachineA600
CPU68000
CPUSpeed7
ChipSetOCS
GFXCardNone
ChipMem1 MB
FastMem4 MB
WorkbenchOS 2.05
KickROM37 - Kick 2.0
KickSoftNone
WHDLoad16.9
importedyes
Attached Files

-Relationships
duplicate of 0001842closedCFOU Sidewinder: I downloaded the KG packs to save time installing myself, and got 
+Relationships

-Notes

note ~0001668

haynor666 (reporter)

Might quitkey option need this.

note ~0001676

Wepl (manager)

please try attached slave, should work fine on 68000 now

note ~0001681

Wepl (manager)

a fixed install has been released today

note ~0001686

Vikingex - Daniel (reporter)

I have tried the new install, but I am now getting a graphical glitch as shown below:

http://img130.imageshack.us/img130/1404/errormq.jpg

You mention something about it only working on v3 of sidewinder? Where do I get this version? I used my own original disk to install but not sure if this is v1 etc and therefore causing the wrong graphics.

note ~0001687

Wepl (manager)

Yes that is one of the unsupported versions, sorry but I have no time to analyse/fix that.
You should be able to get the working version from http://www.whdownload.com/

note ~0001692

Vikingex - Daniel (reporter)

I have tried that also - installing the Sidewinder 1.0 from the pre-installed pack, then copying the new slave into place - that's correct way right?

That results in the intro coming up (afaik it says California on the title), but then crashing to blue screen + restarting once any key is pressed. I will now try on my real amiga, and try another sidewinder disk I have to see if that'll work.

note ~0001693

Vikingex - Daniel (reporter)

It definitely says California on the title using the whdownload version, and has corrupt graphics when playing it on real amiga :(

note ~0001698

Vikingex - Daniel (reporter)

Any news?

note ~0001701

Wepl (manager)

it seems I've found the reason for the gfx corruption, please try the attached slave

note ~0001704

Vikingex - Daniel (reporter)

Thanks, I tried the attached slave but I am still getting the same gfx corruption - can't take an image i'm afraid as it is on my real amiga, but it looks sortof like this

http://people.redhat.com/alexl/x31-gfx-corruption.png

I tried other games just to make sure my Amiga isn't dying, but they work fine.

How are you testing this btw, WinUAE? What are your settings? Also, please can you zip your working Sidewinder folder, to be completely sure I can replicate the issue with your data files also.

note ~0001709

Wepl (manager)

I tested only on real Amiga.
Your screenshot looks very strange.
Maybe you have a WinUAE problem?
The images from whdownload.com are made from the sps release and should work fine.

Please test it on real hardware.

note ~0001710

Vikingex - Daniel (reporter)

Yes sorry I think you misunderstand - I have been testing on my real Amiga, and this is where the problems are. I am testing on my Amiga 600 with 1MB trapdoor expansion and 4MB card ram. I get the graphics corruption as in the screenshot above, everything has strange lines in it.

I use the image from whdownload also.

note ~0001711

haynor666 (reporter)

Take camera and make photo straight from your TV ;)

note ~0001712

Vikingex - Daniel (reporter)

Yeah lol I will do that tonight then :]

note ~0001713

Vikingex - Daniel (reporter)

Sorry for delay, here are the images. I also now noticed that I get a crash to workbench if I don't press a button after the title screen within like 10 seconds. Happens each time. I got two different error messages as shown below.

Also note the startup image on the game - is this the same as yours?

http://img401.imageshack.us/img401/7075/40619878.jpg
http://img38.imageshack.us/img38/4917/50389078.jpg
http://img46.imageshack.us/img46/1561/38044646.jpg
http://img641.imageshack.us/img641/9060/80771710.jpg
http://img31.imageshack.us/img31/5089/70484356.jpg
http://img707.imageshack.us/img707/6260/73096306.jpg

note ~0001714

Wepl (manager)

Last edited: 2010-03-20 01:30

I do not understand why you wrote at 0002239:0001704 that you get the same gfx corruption, but the pictures are different (http://img130.imageshack.us/img130/1404/errormq.jpg against http://img641.imageshack.us/img641/9060/80771710.jpg )

was the same machine and the same game installation used?

note ~0001715

Vikingex - Daniel (reporter)

0002239:0001704 was just a random image from google, I was just trying to show you the type of corruption I am getting - I thought it looked similar to the problem I am getting.

Now though with haynors idea I took photos of my real Amiga, which I have been using all this time.

note ~0001716

Wepl (manager)

It seems you didn't understand what I mean and you didn't checked the pictures. They look very different to me.

note ~0001719

Vikingex - Daniel (reporter)

Ah ok sorry I just looked at post 1704. Yeah I have had 2 graphics problems, sorry I should have made that clear. The first is the "repeating graphics" problem which is now solved with your slave.

Then I have the problem of corruption in graphics as shown in my latest photos.
+Notes

-Issue History
Date Modified Username Field Change
2010-01-27 19:19 administrator New Issue
2010-01-27 19:19 administrator Status new => assigned
2010-01-27 19:19 administrator Assigned To => CFOU
2010-01-27 19:19 administrator Machine => A600
2010-01-27 19:19 administrator CPU => 68000
2010-01-27 19:19 administrator CPUSpeed => 7
2010-01-27 19:19 administrator ChipSet => OCS
2010-01-27 19:19 administrator GFXCard => None
2010-01-27 19:19 administrator ChipMem => 1 MB
2010-01-27 19:19 administrator FastMem => 4 MB
2010-01-27 19:19 administrator Workbench => OS 2.05
2010-01-27 19:19 administrator KickROM => 37 - Kick 2.0
2010-01-27 19:19 administrator KickSoft => None
2010-01-27 19:19 administrator WHDLoad => 16.9
2010-01-27 19:19 administrator imported => yes
2010-02-12 12:59 haynor666 Note Added: 0001668
2010-02-12 15:32 Wepl Relationship added duplicate of 0001842
2010-02-13 23:06 Wepl Assigned To CFOU => Wepl
2010-02-13 23:07 Wepl File Added: Sidewinder.Slave
2010-02-13 23:08 Wepl Note Added: 0001676
2010-02-17 22:48 Wepl Note Added: 0001681
2010-02-17 22:48 Wepl Status assigned => closed
2010-02-17 22:48 Wepl Resolution open => fixed
2010-02-19 15:58 Vikingex - Daniel Note Added: 0001686
2010-02-19 15:58 Vikingex - Daniel Status closed => feedback
2010-02-19 15:58 Vikingex - Daniel Resolution fixed => reopened
2010-02-19 21:44 Wepl Note Added: 0001687
2010-02-20 11:34 Vikingex - Daniel Note Added: 0001692
2010-02-20 14:44 Vikingex - Daniel Note Added: 0001693
2010-03-05 23:19 Vikingex - Daniel Note Added: 0001698
2010-03-11 23:50 Wepl File Deleted: Sidewinder.Slave
2010-03-11 23:50 Wepl File Added: Sidewinder.Slave
2010-03-11 23:52 Wepl Note Added: 0001701
2010-03-12 19:28 Vikingex - Daniel Note Added: 0001704
2010-03-15 09:23 Wepl Note Added: 0001709
2010-03-15 10:35 Vikingex - Daniel Note Added: 0001710
2010-03-15 11:31 haynor666 Note Added: 0001711
2010-03-15 11:44 Vikingex - Daniel Note Added: 0001712
2010-03-18 21:48 Vikingex - Daniel Note Added: 0001713
2010-03-19 23:32 Wepl Note Added: 0001714
2010-03-19 23:33 Wepl Note Edited: 0001714
2010-03-19 23:34 Wepl Note Edited: 0001714
2010-03-19 23:44 Vikingex - Daniel Note Added: 0001715
2010-03-20 01:30 Wepl Note Edited: 0001714
2010-03-20 01:31 Wepl Note Added: 0001716
2010-03-20 18:53 Vikingex - Daniel Note Added: 0001719
+Issue History