2024-02-26 05:15 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0006310Debut[All Projects] Generalpublic2024-02-04 20:01
ReporterVelociraptor5 
Assigned ToPsygoreProject InfoDébut: Planet Simulation (Pandora)
http://www.whdload.de/games/Debut.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0006310: Début: Planet Simulation - crashes in "Misc" options. If the game is launched
DescriptionGameVersion: english,pal,2 disks SPS2999
SlaveVersion: 1.1 from 05.12.2012

Début: Planet Simulation - crashes in "Misc" options.
                  
If the game is launched by key "F1 Tyme And Reality", so in "MISC" options you can see fist 4 options (icons).
If any of them is pressed, the game crashes with this error "Function 'resload_GetFile_Size' called with ilegal file specification '/PLAN.DIR'...." see the attached picture for whole message.
Also ".whdl_register" (at least) is attached.
TagsNo tags attached.
MachineUAE
CPU68020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem256 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.9
importedyes
Attached Files
  • png file icon Error message.png (14,637 bytes) 2023-11-24 15:18 -
    png file icon Error message.png (14,637 bytes) 2023-11-24 15:18 +
  • ? file icon .whdl_register (3,490 bytes) 2023-11-24 15:18 -
    ************************* 21-Nov-23 18:56:03 ************************18.9.6601***
    Slave='DebutPlanetSimulation.slave' (1808 bytes)
    Resload   4FFA3520 - 4FFA9EF4 (  27092) at 4FFA3520  GL=$4FFF6510
    Slave     4FFFF098 - 4FFFF784 (   1772) at 4FFFF098  BaseMemSize=$6B000
    ExpMem    4FFAA000 - 4FFF6000 ( 311296) at 4FFAA000
    attn=203(20) fc=-1 kn=0 zpt=-1 ep=0 ei=0
    setcpu=3D(SCB,ECB,BNC)
    
    Function 'resload_GetFileSize' called with illegal file specification
    '/PLAN.DIR'. Must not start/end with '/' and must not contain '//' or ':'.
    
    $4ffff3dc ori.b        #2,a3
    $4ffff3e0 dc.w         $35f6
    $4ffff3e2 ori.b        #3,d4
    $4ffff3e6 ori.b        #??$fa,d2
    $4ffff3ea andi.b       #0,d2
    $4ffff3ee movem.l      d0-d1/a0-a3,-(a7)              ;$4fff5dc0
    $4ffff3f2 lea          ($4ffff4d0,pc),a1
    $4ffff3f6 clr.l        (a1)                           ;$4ffff4d4
    $4ffff3f8 bsr.b        $4ffff418
    $4ffff3fa bsr.b        $4ffff436
    $4ffff3fc lea          ($4ffff4d4,pc),a1
    $4ffff400 move.l       a0,(a1)                        ;$4ffff4d4
    $4ffff402 move.l       ($4ffff77e,pc),a2
    $4ffff406 jsr          ($24,a2)                       ;$4ffa3544
    ›1m$4ffff40a lea          ($4ffff4d8,pc),a0
    ›22m$4ffff40e move.l       d0,(a0)                        ;$4ffb0fa4
    $4ffff410 move.l       d0,d2
    $4ffff412 movem.l      (a7)+,d0-d1/a0-a3              ;$4fff5dc0
    $4ffff416 rts
    $4ffff418 move.l       a1,-(a7)                       ;$4fff5dc0
    $4ffff41a move.l       a0,a1
    $4ffff41c move.b       (a0)+,d0                       ;$4ffb0fa4
    $4ffff41e beq.b        $4ffff432
    $4ffff420 cmpi.b       #$3a,d0
    $4ffff424 bne.b        $4ffff41c
    $4ffff426 cmpi.b       #$5c,(a0)                      ;$4ffb0fa4
    $4ffff42a bne.b        $4ffff42e
    $4ffff42c addq.l       #1,a0
    $4ffff42e move.l       (a7)+,a1                       ;$4fff5dc0
    
    regular stack:
    $4FFF5DC0 4FFFF40A 0000FFFF 0000002A 4FFB0FA4 4FFBA080 4FFE9686 4FFB07E6 4FFB105E
    $4FFF5DE0 4FFB381C 4FFB207C 00000000 4FFBBD94 4FFB2050 4FFE72FA 4FFE9F8A 4FFAB876
    $4FFF5E00 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
    $4FFF5E20 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
    $4FFF5E40 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx     FF00        2A        E4        E6      FF00      FF01      FFFF      FFFF
    Ax 4FFB0FA4  4FFFF4D4  4FFA3520  4FFB07E6  4FFB05B0  4FFB05B0  4FFB06D8
    
                     TTSM III   XNZVC
    PC=4FFFF40A›22m  SR=%0010000000000000  USP=4FFF5A00  ›1mISP=4FFF5DC0  MSP=6A800
    VBR=4FFF7510  SFC=5  DFC=5  CACR=0  CAAR=0
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%1100000111111100›22m dmacon=%›1m0000001111011111 adkcon=$1100
    intreq=%1000011000000000
    vposr....A300  vhposr...0907  joy0dat..E6E4  joy1dat..0000  clxdat...8000  
    pot0dat..0000  pot1dat..0000  potinp...5500  serdatr..3800  dskbytr..8000  
    deniseid.00F8  hhposr...00BB  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=00000000›22m  ta=21FF<21FF	   cra=›1m00000000  ta=FFFF<FFFF
    	    AII ROPS			    AII ROPS
    	crb=00000000›22m  tb=21FF<21FF	   crb=›1m00000000  tb=FFFF<FFFF
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=10111100›22m  prb=›1m11111111›22m      pra=›1m11111111›22m  prb=›1m11111111
           ddra=00000011›22m ddrb=›1m00000000›22m     ddra=›1m11000000›22m ddrb=›1m11111111
           event=0010E6  icr=00  sdr=5E    event=14A93D  icr=00  sdr=00
    
    ? file icon .whdl_register (3,490 bytes) 2023-11-24 15:18 +
  • ? file icon Debut12.lha (1,480 bytes) 2023-12-09 18:11

-Relationships
+Relationships

-Notes

note ~0013346

Velociraptor5 (reporter)

Yet more about versions....
Tested SPS 2999 (game version 1.05) and also Retroplay's version (game version 1.07).
Both of them the same problem.

note ~0013424

Psygore (developer)

Thanks for your bug report.

Attached a new slave 1.2 which will fix this issue.

note ~0013425

Velociraptor5 (reporter)

Seems to be working fine. Can be released.
Thanks

note ~0013533

Psygore (developer)

New install package available.
+Notes

-Issue History
Date Modified Username Field Change
2023-11-24 15:12 administrator New Issue
2023-11-24 15:12 administrator Status new => assigned
2023-11-24 15:12 administrator Assigned To => Psygore
2023-11-24 15:18 Velociraptor5 File Added: Error message.png
2023-11-24 15:18 Velociraptor5 File Added: .whdl_register
2023-11-24 16:06 Velociraptor5 Note Added: 0013346
2023-12-09 18:11 Psygore File Added: Debut12.lha
2023-12-09 18:12 Psygore Note Added: 0013424
2023-12-09 23:42 Velociraptor5 Note Added: 0013425
2024-01-22 17:48 Psygore Status assigned => resolved
2024-01-22 17:48 Psygore Resolution open => fixed
2024-01-22 17:48 Psygore Note Added: 0013533
2024-02-04 20:01 Psygore Status resolved => closed
+Issue History