WHDLoad MantisBT - WHDLoad
View Issue Details
0002172WHDLoad[All Projects] Generalpublic2009-09-29 14:172012-03-21 23:20
Reporterrjmacarthur 
Assigned ToWepl 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version16.9 
Target Version17.0Fixed in Version17.0 
MachineCD32
CPU68EC020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem0 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad16.9
Summary0002172: Hi, When I load Out Run Europa I get this error. Exception "Illegal
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.0 from 20.05.2000

Hi, When I load Out Run Europa I get this error.
Exception "Illegal instruction" ($10) at $204 occured.
and when I run it with Preload enabled I get.
DOS-Error #205 object not found on reading "Disk.1"
Which I believe is a memory problem. But it worked in previous versions.
I'm using WHDLoadCD32.
This error never occured with previous versions on the same Amiga setup.
Thanks
Rich.
TagsNo tags attached.
related to 0002154closed Wepl DOS-Error #205 when starting the game 
Attached Files? WHDLoadCD32 (34,525) 2009-09-29 22:29
https://mantis.whdload.de/file_download.php?file_id=46&type=bug

Notes
(0001475)
Wepl   
2009-09-29 22:31   
the DOS error #205 is a bug in WHDLoad, please try attached whdloadcd32 which should solve it

cannot say anything about the 'illegal instruction'...
(0001479)
rjmacarthur   
2009-09-30 01:50   
The updated version does accept the Preload and stops the DOS Error but it still returns the illegal exception.
(0001480)
Wepl   
2009-09-30 10:44   
and the 'illegal instruction' does not occure with whdloadcd32 16.8?
or which setup has worked?
(0001482)
rjmacarthur   
2009-10-01 02:12   
When using WHDLoadCD32 16.8 it get the same "Illegal Instruction" with Preload on or off.

The error "Illegal Instruction" doesn't happen with the regular WHDLoad.
(0001487)
Wepl   
2009-10-02 16:27   
I have tested it under WinUAE with CD32 emulation and it works fine. So without being able to reproduce it's hard to do anything.
Whats your setup? Have a iso?
(0001492)
rjmacarthur   
2009-10-04 20:31   
After more testing it seems the problem doesn't occur on the CD32 but still does on WinUAE.

Only when "Adjustable between CPU and chipset" is selected under CPU Emulation Speed.
(0001494)
Wepl   
2009-10-05 10:54   
so this is not a install problem anymore and whdloadcd32 problem is solved

Issue History
2009-09-29 22:03administratorNew Issue
2009-09-29 22:03administratorStatusnew => assigned
2009-09-29 22:03administratorAssigned To => Bored Seal
2009-09-29 22:03administratorMachine => CD32
2009-09-29 22:03administratorCPU => 68EC020
2009-09-29 22:03administratorCPUSpeed => 14
2009-09-29 22:03administratorChipSet => AGA
2009-09-29 22:03administratorGFXCard => None
2009-09-29 22:03administratorChipMem => 2 MB
2009-09-29 22:03administratorFastMem => 0 MB
2009-09-29 22:03administratorWorkbench => OS 3.1
2009-09-29 22:03administratorKickROM => 40 - Kick 3.1
2009-09-29 22:03administratorKickSoft => None
2009-09-29 22:03administratorWHDLoad => 16.9
2009-09-29 22:03administratorimported => yes
2009-09-29 22:21WeplRelationship addedrelated to 0002154
2009-09-29 22:29WeplFile Added: WHDLoadCD32
2009-09-29 22:31WeplNote Added: 0001475
2009-09-30 01:50rjmacarthurNote Added: 0001479
2009-09-30 10:44WeplNote Added: 0001480
2009-10-01 02:12rjmacarthurNote Added: 0001482
2009-10-02 16:27WeplNote Added: 0001487
2009-10-04 20:31rjmacarthurNote Added: 0001492
2009-10-05 10:52WeplAssigned ToBored Seal => Wepl
2009-10-05 10:52WeplProjectOutrunEurope => WHDLoad
2009-10-05 10:53WeplProduct Version => 16.9
2009-10-05 10:53WeplDescription Updated
2009-10-05 10:54WeplNote Added: 0001494
2009-10-05 10:54WeplStatusassigned => closed
2009-10-05 10:54WeplResolutionopen => fixed
2009-10-05 10:54WeplFixed in Version => 17.0
2012-03-21 23:20administratorTarget Version => 17.0