2020-10-24 02:22 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000064Beast3[All Projects] Generalpublic2016-06-15 20:31
Reporterhaynor666 
Assigned ToStingRayProject InfoShadow of the Beast 3 (Psygnosis)
http://www.whdload.de/games/Beast3.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Summary0000064: Shadow of the Beast 3: Intro still isn't work on lighting engine (PAL or NTSC -
DescriptionInstall: Shadow of the Beast 3 (Psygnosis) http://whdload.de/games/Beast3.html
GameVersion: english pal or ntsc ?
SlaveVersion: last one

Intro still isn't work on lighting engine (PAL or NTSC - it desn't matter)
Maybe you could fix it finally for 100 %
TagsNo tags attached.
MachineA1200
CPU68EC020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 3.0
KickROM39 - Kick 3.0
KickSoftNone
WHDLoad15
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0000357

haynor666 (reporter)

old bug and still not fixed :/

note ~0001584

GalahadFLT (developer)

This was fixed ages ago, but because of the stupid Psygnosis MFM system, the disk format for Disk 1 is the same as Beast and Beast 2 and it frequently doesn't image properly. At the time of me fixing the intro, I had it all working fine, you will need to probably install from the IPF image of Disk 1, as this particular protection format is known to be very buggy.

note ~0004945

StingRay (developer)

This wasn't fixed at all, there are disk accesses in the intro... Will be fixed in the next update!

note ~0004946

haynor666 (reporter)

Finally someone confirms this. I tried 2 days ago this game installed from my disks and from SPS images. In both PAL versions intro loops with graphical errors.

note ~0004948

StingRay (developer)

Last edited: 2016-06-13 19:21

View 2 revisions

Disk accesses in the intro have been fixed, Byte writes to volume register and Bplcon0 color bit problems fixed as well (all fixes done for NTSC and PAL versions). Now I have to find the reason for the graphics bugs in the intro in the PAL version and the replay problems (speed) in the NTSC version and the updated patch will be released.

note ~0004957

StingRay (developer)

Intro loader was buggy and responsible for the freezes in the PAL version, it only worked by coincidence for the NTSC version. I have completely recoded it, the PAL intro is now fully supported! I have also fixed byte writes to volume register, added an option to skip the intro with CUSTOM2 and some other things.

note ~0004962

haynor666 (reporter)

Thanks StingRay :)

note ~0004963

StingRay (developer)

Last edited: 2016-06-15 16:28

View 2 revisions

My pleasure! :) And just for future reference, this of course had nothing to do with the "stupid Psygnosis MFM system", the format is neither stupid nor buggy and supports checksums so "doesn't image properly" is not true either.

Problem was simply caused by a buggy loader patch, no more, no less!

note ~0004966

GalahadFLT (developer)

Haha, wrong chap. I love the sly digs at me, alas you're barking up the wrong tree.

Firstly, the Psygnosis MFM system is buggy, mastered with no verification hence why so many Psygnosis original titles fail over time.

Secondly, it took 8 different originals to get a working intro and that was from two separate disks to make one good version. This was in the days before SPS and handy IPF files.

Thirdly, I supported only one intro, pretty sure it was PAL.

Fourthly, as far as im aware, Bored Seal added support for the NTSC intro but did something wrong and had to re-release his update, it even says in the notes "PAL version works again (intro sequence patched for both versions).

Fifthly, Beast 3 was NOT my install, I simply added the loader to load the intro sequence, all other disk stuff was done by others, so any disk accesses remaining in there was ZERO to do with me.

Sixthly, my code was NOT buggy either, because the intro worked, it worked back in 2001, and lots of people were able to test it and it worked, it was my first ecer whdload work, dont you think people would have commented back then how it didnt work, or did they wait a long time to say something?

however i cannot comment on what people did with the code afterwards to support another version, and thats hardly my problem.

Whats up dude, I thought we were friends, but your comments dont seem friendly at all :(

note ~0004967

StingRay (developer)

Ok then, interesting how you keep posting wrong information instead of taking the time to actually fix the bugs reported here. Let's deal with your statements then:

"Firstly, the Psygnosis MFM system is buggy, mastered with no verification hence why so many Psygnosis original titles fail over time."

I wonder why I see checksum checks in the loader when there is "no verification".

"Thirdly, I supported only one intro, pretty sure it was PAL."

You supported the NTSC intro.

"Fourthly, as far as im aware, Bored Seal added support for the NTSC intro but did something wrong and had to re-release his update, it even says in the notes "PAL version works again (intro sequence patched for both versions)."

Bored added support for the intro of the PAL version using your loader code for the NTSC version which is why it never worked properly, hardly Bored's fault.

"Fifthly, Beast 3 was NOT my install, I simply added the loader to load the intro sequence, all other disk stuff was done by others, so any disk accesses remaining in there was ZERO to do with me."

You have "fixed" the intro and didn't disable all disk accesses in the loader for the intro(!) so "has ZERO to do" with you is not exactly correct.


"Sixthly, my code was NOT buggy either, because the intro worked, it worked back in 2001, and lots of people were able to test it and it worked, it was my first ecer whdload work, dont you think people would have commented back then how it didnt work, or did they wait a long time to say something?"

Your code didn't work correctly as you didn't handle the disk sides correctly and neither emulated the original loader properly. The only reason the PAL version intro bugged out was because of a wrong loader patch. Yes, it worked for the NTSC version but that still doesn't mean it wasn't buggy! I have one routine for both versions, no special case for either NTSC or PAL, how do you explain that if your code was 100% OK?


"Whats up dude, I thought we were friends, but your comments dont seem friendly at all :("

I just don't like wrong info spread and I think as adult you should be able to handle this. I only had a look at the Beast 3 patch because someone had problems with the music playing too slow (which, btw, was also one of the bug reports assigned to you!) and then, out of curiosity, checked why the intro in the PAL version didn't work correctly. Now, instead of writing all this text here because I dared to finally fix this (a bug that existed for 15 years!) you could have tried to fix it yourself. Instead, you closed the report claiming "it was fixed" which it wasn't. That (and to see if you bite which you did!) were the sole reasons for my comments here.

note ~0004968

GalahadFLT (developer)

You missed out the bit where I had to go through 8 disks before we could get a working intro, Psygnosis MFM format does have error checking, but NO verification was possible at the DUPLICATORS.....thats not a great disk format if it can't be verified as good, the end user shouldn't be the quality control lol.

Pal or ntsc, it was 15 years ago, i cant remember everything :)

Wrong. If the ntsc version worked, and Bored copied the code and didnt alter it to cater for the Pal version, that Im afraid is his fault not mine, otherwise if there were no differences between the pal and ntsc intros, the same exact code could load them both with using the same routine, and he would have no need to patch the pal intro.

The only intro code I touched was the loader used in the interrupt (having to remember now), I touched nothing else, all other disk code I assumed was dealt with by Mr.Larmer and Codetapper who were doing that install before me.

If there was disk code left in, it wasnt ever mentioned in 2001....kinda puts that 'problem' into perspective.

And I repeat, it was NOT my install, I supported the intro and thats it, nothing else, and over SIX people have touched that install overall, my contribution was only small.

If the intro patch worked for ntsc, great, then it worked. I didnt write it for the Pal version, so i can hardly be blamed for code not working properly for a version I didnt actively support. I presume the data on the other side of the disk for the pal version was in a different place.

However, I didnt release the Pal intro fix, im puzzled how it can be my fault it didnt work right when I didnt do it, and presumably Bored would have checked hia work before release?

So, to recap, the ntsc intro worked, which i patched, the pal one didnt, which i didnt patch?

Irrespective of a bug report being assigned to me, twas NEVER my install in the first place.

You should try and see if I will bite, why not just PM or email me in person and simply ask me?

Fact: ntsc intro worked back in 2001.
Fact: Bored did the pal one and it didnt
Fact: I fail to see how this is my problem.

You could just email me in future, we are supposed to be friends, adult friends at that ;)
+Notes

-Issue History
Date Modified Username Field Change
2009-04-10 00:10 administrator New Issue
2009-04-10 00:10 administrator Status new => assigned
2009-04-10 00:10 administrator Assigned To => GalahadFLT
2009-04-10 00:10 administrator Machine => A1200
2009-04-10 00:10 administrator CPU => 68EC020
2009-04-10 00:10 administrator CPUSpeed => 14
2009-04-10 00:10 administrator ChipSet => AGA
2009-04-10 00:10 administrator GFXCard => None
2009-04-10 00:10 administrator ChipMem => 2 MB
2009-04-10 00:10 administrator FastMem => 8 MB
2009-04-10 00:10 administrator Workbench => OS 3.0
2009-04-10 00:10 administrator KickROM => 39 - Kick 3.0
2009-04-10 00:10 administrator KickSoft => None
2009-04-10 00:10 administrator WHDLoad => 15
2009-04-10 00:10 administrator imported => yes
2009-04-22 13:01 haynor666 Note Added: 0000357
2009-12-14 19:10 GalahadFLT Note Added: 0001584
2009-12-14 19:10 GalahadFLT Status assigned => closed
2009-12-14 19:10 GalahadFLT Resolution open => fixed
2016-06-13 17:56 StingRay Assigned To GalahadFLT => StingRay
2016-06-13 17:56 StingRay Note Added: 0004945
2016-06-13 17:56 StingRay Status closed => feedback
2016-06-13 17:56 StingRay Resolution fixed => reopened
2016-06-13 18:13 haynor666 Note Added: 0004946
2016-06-13 18:13 haynor666 Status feedback => assigned
2016-06-13 19:21 StingRay Note Added: 0004948
2016-06-13 19:21 StingRay Note Edited: 0004948 View Revisions
2016-06-15 14:18 StingRay Note Added: 0004957
2016-06-15 14:18 StingRay Status assigned => resolved
2016-06-15 14:18 StingRay Resolution reopened => fixed
2016-06-15 15:24 haynor666 Note Added: 0004962
2016-06-15 16:27 StingRay Note Added: 0004963
2016-06-15 16:28 StingRay Note Edited: 0004963 View Revisions
2016-06-15 19:49 GalahadFLT Note Added: 0004966
2016-06-15 20:11 StingRay Note Added: 0004967
2016-06-15 20:31 GalahadFLT Note Added: 0004968
+Issue History