2024-06-16 08:26 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005880WHDLoad[All Projects] Generalpublic2023-10-14 23:27
ReporterPaul Head 
Assigned ToWeplProject InfoHD-Installer for OS-Killer
http://whdload.de/
 
PrioritylowSeveritytextReproducibilityN/A
StatusclosedResolutionfixed 
Product Version18.8 
Target Version18.9Fixed in Version18.9beta 
Summary0005880: Documentation issue with options 'ExecutePreDisk' and 'ExecutePostDisk'
DescriptionOptions 'ExecutePreDisk' and 'ExecutePostDisk' are not entirely clear to me. I have tested them and ExecutePostDisk seems to execute just before the Workbench disappears (just before the game appears), and ExecutePreDisk executes immediately after the game quits (as soon as Workbench appears again).

I understand that ExecutePreDisk and ExecutePostDisk are separate from ExecuteStartup (executes before Splash appears) and ExecuteCleanUp (executes even if the escape key was pressed, and of course after the game ends if loaded). I like all these 4 options, I find them useful. The docs on ExecutePreDisk and ExecutePostDisk are unclear to me however, and their descriptions appear to be reversed from what actually happens. I just find it confusing really. Also, those two options were introduced in version 17.0, and yet I can find no reference to them in the History.txt file or html history. The history docs needs fixing in that respect, and a little more explanation as to what those options actually do would be better. I read them and it leads me to believe that everytime WHDLoad goes back to the OS to load files (like if memory short and screen flashing occurs) that one of those two options will be executed, or when saving games, but it doesn't do that at all. Those two options just work at the beginning and at the end of actual game execution.
TagsNo tags attached.
MachineA1200
CPU68020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 3.0
KickROM39 - Kick 3.0
KickSoftNone
WHDLoad18.7
Attached Files

-Relationships
+Relationships

-Notes

note ~0012515

Wepl (manager)

Yes, it seems these functions do not work as intended/documented. I'll check this.

note ~0012520

Wepl (manager)

I've fixed the behavior.
The functions are now called as intended/documented, before/after switch between OS and installed program.
Please see new beta release https://whdload.de/whdload/whd189.lha
I also added a not to the docs regarding that these commands must not cause any gfx output as intuition base is locked. Otherwise system will hang!

note ~0012740

Paul Head (reporter)

I've only just spotted this! Excellent work, thanks for looking into it and taking the time to fix it.
+Notes

-Issue History
Date Modified Username Field Change
2022-11-21 14:13 Paul Head New Issue
2022-11-22 23:09 Wepl Assigned To => Wepl
2022-11-22 23:09 Wepl Status new => assigned
2023-03-16 12:05 Wepl Note Added: 0012515
2023-03-16 23:39 Wepl Note Added: 0012520
2023-03-16 23:39 Wepl Target Version => 18.9
2023-03-16 23:40 Wepl Status assigned => resolved
2023-03-16 23:40 Wepl Resolution open => fixed
2023-03-16 23:40 Wepl Fixed in Version => 18.9beta
2023-04-28 11:32 Paul Head Note Added: 0012740
2023-10-14 23:27 Wepl Status resolved => closed
+Issue History