2023-01-29 20:50 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005576LureOfTheTemptress[WHDLoad Installs Games] slavepublic2022-05-29 15:51
Reporterrobiza 
Assigned ToJOTDProject InfoLure of the Temptress (Virgin)
http://www.whdload.de/games/LureOfTheTemptress.html
 
PrioritynormalSeveritycrashReproducibilityalways
StatusconfirmedResolutionreopened 
Summary0005576: Lure of the tempress (italian version) hangs
DescriptionThe game carsh when you exit from the door of the dragon caverns after few minute.
Steps To ReproduceAfter your exit from the door of the dragon caverns, wait some minute and the game crash.
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.7
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0011113

robiza (reporter)

i have a save file

note ~0011140

JOTD (developer)

can you attach it here?

note ~0011148

robiza (reporter)

Ok, attacched (HxC Floppy Emulator version and only the file)
I have extracted only the save file #4
In 10 seconds the game hangs (Skurl speak with the bar man)

note ~0011152

JOTD (developer)

Last edited: 2022-04-16 00:09

View 2 revisions

good news, I fixed the crash. Now I have to adapt other versions too.

Check attached 2.2 slave in the meantime

note ~0011168

robiza (reporter)

I reopen because with this fix the skorl don't speak with Nellie e stand forever in the pub.
Unfortunatly, to continue the game, the Skorl have to talk in the shop in the market place. But the Skorl don't arrive in the shop because is forever in the pub.

note ~0011360

JOTD (developer)

Last edited: 2022-05-29 10:26

View 2 revisions

Okay, I have made some progress. It appears that the savegame is corrupt (saving a big chunk of data with some non-modifiable lookup tables, but one of those tables is corrupt).

So it's not possible to fix the issue starting from that savegame. Can you provide the previous savegames? If I can find a non-corrupt savegame, I can create a test slave where one would have to play until the game corrupts the memory and we'll find the root cause

(fixing the savegame isn't good enough, as the game would probably re-corrupt it, I have fixed it manually check attachment just to test and the Skohl talks all right)

note ~0011368

JOTD (developer)

I took the time to play the english version (sps 2031) to the point you saved your game. I didn't experience corruption in that area so I suppose that it's random. Problem is: once it's corrupt the savegame is corrupt.

I don't know which part of the code corrupts that zone. I could do a code that repairs the zone constantly, if that's the only corruption that the code can have. I know there were issues in that exact area already so that's definitely a game bug, not specific to the italian version.
+Notes

-Issue History
Date Modified Username Field Change
2022-04-10 20:41 robiza New Issue
2022-04-10 20:42 robiza Note Added: 0011113
2022-04-10 22:09 StingRay Assigned To => JOTD
2022-04-10 22:09 StingRay Status new => assigned
2022-04-14 23:38 JOTD Note Added: 0011140
2022-04-14 23:38 JOTD Status assigned => feedback
2022-04-15 07:51 robiza File Added: luresave.zip
2022-04-15 07:51 robiza File Added: LureOfTheTempressItSave.zip
2022-04-15 07:54 robiza Note Added: 0011148
2022-04-15 07:54 robiza Status feedback => assigned
2022-04-15 22:38 Pascal De Maeseneire File Added: LURESAVEDISKADF.zip
2022-04-16 00:06 JOTD Status assigned => confirmed
2022-04-16 00:06 JOTD Note Added: 0011152
2022-04-16 00:06 JOTD File Deleted: LureOfTheTempressItSave.zip
2022-04-16 00:06 JOTD File Deleted: LURESAVEDISKADF.zip
2022-04-16 00:08 JOTD File Added: LureOfTheTemptress.zip
2022-04-16 00:09 JOTD Note Edited: 0011152 View Revisions
2022-04-16 00:36 JOTD Status confirmed => closed
2022-04-16 00:36 JOTD Resolution open => fixed
2022-04-18 09:42 robiza Status closed => feedback
2022-04-18 09:42 robiza Resolution fixed => reopened
2022-04-18 09:42 robiza Note Added: 0011168
2022-04-18 09:45 JOTD Status feedback => confirmed
2022-05-29 10:08 JOTD Note Added: 0011360
2022-05-29 10:26 JOTD Note Edited: 0011360 View Revisions
2022-05-29 10:27 JOTD File Added: luresave_skohl_fix.zip
2022-05-29 15:51 JOTD Note Added: 0011368
2022-05-29 15:52 JOTD File Deleted: LureOfTheTemptress.zip
+Issue History