2023-02-03 21:17 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005505ManchesterUnitedPLC[All Projects] Generalpublic2022-03-05 19:58
ReporterIrek 
Assigned ToStingRayProject InfoManchester United: Premier League Champions (Krisalis)
http://www.whdload.de/games/ManchesterUnitedPLC.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
Summary0005505: Hello, I think I have an unsupported version of the game. The game crashes with
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.01 from 02.01.2016

Hello,
I think I have an unsupported version of the game.
The game crashes with an error right after the start.
Can you have a look at it? Thank you in advance!
TagsNo tags attached.
MachineA1200
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoft40 - Kick 3.1
WHDLoad18.7
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0010932

StingRay (developer)

Please send me your version of the game so I can add support for it.

note ~0010940

StingRay (developer)

Yours is version 1.0 of the game, the patch currently only supports V1.2 (SPS 1790) and will be updated to support your version too.

note ~0010941

StingRay (developer)

Your version of the game is now supported. :)

note ~0010942

Retroplay (reporter)

SPS 1790 Manchester United PLC v1.2 throws an unsupported or damaged file error with latest v1.02 slave (it is working with v1.01 slave).

note ~0010944

StingRay (developer)

SPS 1790 still works fine for me with the latest patch. Did you mix up the disks during installation and install the program disk as disk 2 and the data disk as disk 1 perhaps?

note ~0010945

Retroplay (reporter)

I installed this way:
Program disk as disk 1
Data disk as disk 2
Same way I did with v1.01 version.

note ~0010946

Retro-Nerd (reporter)

I can confirm this "unsupported/damaged" error with the SPS 1790 version using the latest slave.

note ~0010947

Irek (reporter)

Thank you StingRay for supporting my version.
Unfortunately, after the successful installation, I have the same problem as before. The SPS version doesn't seem to work anymore either.
Did you maybe upload a wrong slave to the WHDLoad site?

note ~0010949

StingRay (developer)

Last edited: 2022-03-05 12:21

View 2 revisions

I have an idea what my cause the problem, game is relocated to the destination area which may be different on each system and hence causes different checksums (which explains why I can't reproduce this problem on my system). I'll adapt the version check to only check parts that are the same no matter which destination area the game has been relocated to, this should fix this problem.

note ~0010951

StingRay (developer)

I have adapted the version check, the patch should now detect all versions correctly.

note ~0010952

Retroplay (reporter)

1790 v1.2 version works but if I tick "boot from data disk" it still throws an unsupported or damaged error (SPS 1789).

v1.01 slave can boot the data disk.

note ~0010954

Irek (reporter)

Version 1.0 works now too. (Thanks for that!)
However, it crashes often on my setup with this error.
Exception "Illegal Instruction" ($10) at $5BF5A9BA (ExpMem $689BA)

note ~0010962

StingRay (developer)

@Irek: Can you please attach the .whdl.register file? I can then check why the crash on your machine happens.

@Retroplay: thanks for mentioning, will be fixed in the next update (when I found the reason for the crashes Irek reported).

note ~0010964

StingRay (developer)

@Retroplay: I have attached a version of the slave which should support the data disk again. Can you please test it while I'm waiting for Irek's files to fix the crash? Thanks. :)

note ~0010965

Irek (reporter)

Of course, here is it :) :

************************* 26-Feb-22 17:13:16 ************************18.6.6128***
Slave='ManchesterUnited_PLC.Slave' (1872 bytes)
Resload 5BEE9000 - 5BEF0CF8 ( 31992) at 5BEE9000 GL=$5BF73000
Slave 5BFFE000 - 5BFFE72C ( 1836) at 5BFFE000 BaseMemSize=$80000
ExpMem 5BEF2000 - 5BF72000 ( 524288) at 5BEF2000
attn=7F(40,82) fc=-1 kn=10371 cs=DC00 rw=0 zpt=-1 ep=0 ei=0
setcpu=33D(DC,IC,SCB,ECB,BNC)

Exception "Illegal Instruction" ($10) at $5BF5A9BA (ExpMem $689BA) occured.

$5bf5a98a move.w d6,a6
$5bf5a98c bset d0,d0
$5bf5a98e move.b a1,d0
$5bf5a990 dc.w $883e
$5bf5a992 move.l (a4),(a2)+ ;$0002ec90 $00020cce
$5bf5a994 dc.w $27c8
$5bf5a996 dc.w $5bf5
$5bf5a998 line-a $a9ee
$5bf5a99a move.l (a0),a0 ;$5bef2024
$5bf5a99c move.l a0,($5bf5a9f2)
$5bf5a9a2 move.l #$5bf5d75e,($878,a0) ;$5bef289c
$5bf5a9aa move.b #3,($890,a0) ;$5bef28b4
$5bf5a9b0 move.b #1,($891,a0) ;$5bef28b5
$5bf5a9b6 lea ($5bf5a9ee,pc),a0
$5bf5a9ba moveq #0,d0
$5bf5a9bc rts
$5bf5a9be bra.w $5bf5b15c
$5bf5a9c2 bra.w $5bf5bc4e
$5bf5a9c6 bra.w $5bf5b060
$5bf5a9ca bra.w $5bf5b034
$5bf5a9ce bra.w $5bf5b018
$5bf5a9d2 bra.w $5bf5b058
$5bf5a9d6 bra.w $5bf5c460
$5bf5a9da bra.w $5bf5b19e
$5bf5a9de bra.w $5bf5aff4
$5bf5a9e2 bra.w $5bf5afca
$5bf5a9e6 bra.w $5bf5afb6
$5bf5a9ea bra.w $5bf5aebe
$5bf5a9ee smi (-$7e,a2,d2.l*8) ;$dfb0ced0

exception stackframe:
$5BEF4394 20005BF5 A9BA0010
regular stack:
$5BEF439C 5BF256F2 5BF2B602 5BF22DE6 00000000 00000000 00000000 00000000 00000000
$5BEF43BC 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$5BEF43DC 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$5BEF43FC 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$5BEF441C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx 2 0 5BF5D850 4D553341 0 22D50 920050 12
Ax 5BEF2024 5BF5A994 20CCE 3E738 2EC90 5BEF2A6C 5BEF29EE

                 TTSM III XNZVC
PC=5BF5A9BA SR %0010000000000000 USP=7FC00 ISP=5BEF4394 MSP=7F800
VBR=5BF74000 SFC=5 DFC=5 CACR=80008000 MMUSR=0
TC=8000 URP=5BEE7E00 SRP=5BEE7E00 DTT0=0 DTT1=0 ITT0=0 ITT1=0

         MEDRAAAABVCPSDT YZ PMRCBSDAAAA
intena=%0110000000001001 dmacon=%0000011111110000 adkcon=$1500
intreq=%0000000001100000
vposr....2300 vhposr...029E joy0dat..FCA7 joy1dat..0000 clxdat...8023
pot0dat..9039 pot1dat..6666 potinp...5500 serdatr..3BFF dskbytr..8000
deniseid.00F8 hhposr...FF08
   ciaa: PI ROPS ciab: PI ROPS
    cra=00001000 ta=21FF<21FF cra=00001000 ta= 64< 64
        AII ROPS AII ROPS
    crb=00001000 tb=C882<FFFF crb=00000000 tb=FFFF<FFFF
        10RTWCLO parallel DRCCDSOY M3210HDS
    pra=11111110 prb=11111111 pra=11111111 prb=11111111
       ddra=00000011 ddrb=00000000 ddra=11000000 ddrb=11111111
       event=0006BA icr=00 sdr=00 event=000143 icr=00 sdr=00

note ~0010966

StingRay (developer)

Unfortunately, that doesn't help as the executed instruction is perfectly valid. Is the crash always reproducible on your system? If so, what needs to be done to trigger it?

note ~0010967

Retroplay (reporter)

@StingRay
Data disk (SPS 1789) is working again with slave v1.04.

Thank you. :)

note ~0010968

Irek (reporter)

Well, they're rather random crashes. Sometimes this happens right after the intro, sometimes in the preparatory phase (picking players, formation and etc) and sometimes it happens in the game as well. The version 1.2 ran stable on my setup.(okay it was just two short friendlies ;))
+Notes

-Issue History
Date Modified Username Field Change
2022-02-13 20:43 administrator New Issue
2022-02-13 20:43 administrator Status new => assigned
2022-02-13 20:43 administrator Assigned To => StingRay
2022-02-15 21:06 StingRay Note Added: 0010932
2022-02-24 18:03 StingRay Note Added: 0010940
2022-02-24 19:28 StingRay Note Added: 0010941
2022-02-24 19:28 StingRay Status assigned => resolved
2022-02-24 19:28 StingRay Resolution open => fixed
2022-02-24 21:38 Retroplay Note Added: 0010942
2022-02-25 08:23 StingRay Note Added: 0010944
2022-02-25 17:51 Retroplay Note Added: 0010945
2022-02-25 18:55 Retro-Nerd Note Added: 0010946
2022-02-26 10:14 Irek Note Added: 0010947
2022-02-26 11:25 StingRay Note Added: 0010949
2022-02-26 13:17 StingRay Note Added: 0010951
2022-02-26 18:31 Retroplay Note Added: 0010952
2022-02-28 17:17 Irek Note Added: 0010954
2022-03-05 12:19 StingRay Note Added: 0010962
2022-03-05 12:20 StingRay Status resolved => feedback
2022-03-05 12:20 StingRay Resolution fixed => reopened
2022-03-05 12:21 StingRay Note Edited: 0010949 View Revisions
2022-03-05 12:42 StingRay File Added: ManchesterUnited_PLC.slave
2022-03-05 12:44 StingRay Note Added: 0010964
2022-03-05 15:33 Irek Note Added: 0010965
2022-03-05 15:33 Irek Status feedback => assigned
2022-03-05 15:56 StingRay Note Added: 0010966
2022-03-05 16:21 Retroplay Note Added: 0010967
2022-03-05 19:58 Irek Note Added: 0010968
+Issue History