2023-02-08 08:20 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005474Gloom[WHDLoad Installs Games] install scriptpublic2023-01-09 22:31
Reporterlordelessar 
Assigned ToPsygoreProject InfoGloom (Black Magic)
http://www.whdload.de/games/Gloom.html
 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Summary0005474: Gloom install script problem
DescriptionThe installer copies files from disk 1, then asks for disk 2 from which it does not copy anything and announces that the game has been successfully installed.
Only the game menu is launched, then there is a black screen. The same thing happens when installing Gloom Deluxe.
Steps To ReproduceJust install game.
TagsNo tags attached.
MachineUAE
CPU68040
CPUSpeed25
ChipSetAGA
GFXCardOther
ChipMem2 MB
FastMem256 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.7
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0010874

Retroplay (reporter)

Indeed, nothing is copied from disk 2 during install.
Copying files manually from disk 2 to data dir does make the game run.

note ~0010876

lordelessar (reporter)

I noticed one more bug in the installer.
When I try to install Gloom Deluxe, the same situation happens as I wrote about earlier. But that's not all because the installer does not install Gloom Deluxe but its basic version. The Gloom Deluxe menu should be yellow, not purple.

note ~0010878

Psygore (developer)

Install script fixed.

This install supports only classic version of Gloom.
Gloom Deluxe version needs to write complety a new slave (game uses RTG).

note ~0010879

elessar1984 (reporter)

@Psygore it's almost okay because install script forgets one file from data_disk - gloomgame. Without it, the game won't start and not everyone can know it.

note ~0010903

Psygore (developer)

New install package available, slave 1.4 supports the gloomgame file missing.
Install script will copy this file too.

note ~0010909

lordelessar (reporter)

@Psygore Thank you now everything is working perfectly.
+Notes

-Issue History
Date Modified Username Field Change
2022-01-13 16:03 lordelessar New Issue
2022-01-13 20:58 Retroplay Note Added: 0010874
2022-01-13 22:54 lordelessar Note Added: 0010876
2022-01-14 17:50 Psygore Assigned To => Psygore
2022-01-14 17:50 Psygore Status new => resolved
2022-01-14 17:50 Psygore Resolution open => fixed
2022-01-14 17:50 Psygore Note Added: 0010878
2022-01-14 19:55 elessar1984 Note Added: 0010879
2022-01-19 20:08 Psygore Note Added: 0010903
2022-01-20 16:08 lordelessar Note Added: 0010909
2023-01-09 22:31 Psygore Status resolved => closed
+Issue History