2021-04-18 22:59 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005043Carlos[All Projects] Generalpublic2021-04-04 01:39
ReporterPascal De Maeseneire 
Assigned ToCFOUProject InfoCarlos (Microïds)
http://www.whdload.de/games/Carlos.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
Summary0005043: HI JOTD, I have some problems about music on my A500 WITH MY ACA500PLUS @14 MHZ
DescriptionGameVersion: SPS IPF 2299 File
SlaveVersion: 1.0

HI JOTD,
I have some problems about music on my A500 WITH MY ACA500PLUS @14 MHZ with 7MB FAST RAM,
The speed of the music change ... sometime to quick and sometime to small..
I have tried an ADF directly in my Gotek drive and the sound is better... I have made the WHD Install with the IPF version.
I have tried the same WHDLOAD installed game on my A1200 and the sound is better than the A500 result.
I already tried some tooltype like NOCACHE, NOAUTOVEC and WITH ou Without Preload, but without Any succes.
The Graphic speed seems to be in late sometime too...
Please could You have a look ?
Many thanks,
Best Regards,
Pascal
TagsNo tags attached.
MachineA500
CPU68000
CPUSpeed14
ChipSetECS
GFXCardNone
ChipMem1 MB
FastMem7MB
WorkbenchOS 3.1.4
KickROM46 - Kick 3.1.4
KickSoftNone
WHDLoad18.6
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0009672

Pascal De Maeseneire (reporter)

An maybe add somes Trainers too if possible ... like this ADF version if You Can ?
https://www.planetemu.net/rom/commodore-amiga-games-adf/carlos-1994-microids-sp-cr-trsi-znt-t-20-god-2

note ~0009681

CFOU (developer)

try last patch soon released v1.1

completly rewritten
+ use files instead of disk image
+ Save game on HD in file HISCORE.DAT
+ trainer
+ second button
+ exitkey support for 68000
+ less fast memory needed

note ~0009686

Pascal De Maeseneire (reporter)

Hi CFOU,
I just tested the latest Slave 1.1 with a new install of the game. Thanks for Your work on the trainer and all the rest.
Unfortunately the sound problems are still present on my A500 and my A1200.
I compared the rhythm of the music with the ADF version of the game on my A500. With ADF the rhythm of the music is constant without change of rhythm while under WHDload the sound constantly changes speed ... the music is faster and then suddenly the music becomes slower and constantly changes in rhythm.
Please could you have a look?
Many thanks,
Best regards,
Pascal

note ~0009687

CFOU (developer)

Last edited: 2021-03-08 16:41

View 2 revisions

curious i am not this problem on winuae.
i will test on real amiga soon to verify i can reproduct it

note ~0009811

CFOU (developer)

can you try without VBR hack option of Aca500plus ?

perhaps it's cause trouble because i can not reproduct it (on winuae) not A500 to test...

Have another person same problem with different configuration?

Ps:
i will test soon on real 1200+060 but i dont think to have contasted that with last testes)

note ~0009814

CFOU (developer)

confirmed on real 060 too

perhaps music player not call in vbl interrupt (to verify)

note ~0009815

Pascal De Maeseneire (reporter)

Hi,
I tried it again on my ACA500PLUS
1) without VBR & Aca Resource and of course without ToolType NoVBRMove
2) with VBR & Aca Resource but with ToolType NoVBRMove.
The result is the same problem abourt music and sometime Graphic Glitch (l'image clignote)

It tried it too on my A1200 GVP A1230Turbo+II @ 40Mhz
with and without ToolType NoVBRMove
The result is the same problem about music and sometime Graphic Glitch (l'image clignote)

But with my Both Amiga it better with Slave 1.1 on compared to the first Slave 1.0

Many Thanks,
Best Regards,

note ~0009839

CFOU (developer)

Last edited: 2021-04-03 02:23

View 2 revisions

i found the problem
it was caused by cia modification calling second button code.
on my 060 it's fixed.

Can you test attached V1.2 beta please?
(with second button option enabled)

note ~0009842

CFOU (developer)

crash on 68000 with levek select fixed (68020 instruciton : BSR.L xxxxxxxx) was used...

note ~0009843

CFOU (developer)

crash on 68000 with levek select fixed (68020 instruciton : BSR.L xxxxxxxx) was used...
+Notes

-Issue History
Date Modified Username Field Change
2021-03-01 22:15 administrator New Issue
2021-03-01 22:15 administrator Status new => assigned
2021-03-01 22:15 administrator Assigned To => CFOU
2021-03-01 23:20 Pascal De Maeseneire Note Added: 0009672
2021-03-07 05:21 CFOU Status assigned => closed
2021-03-07 05:21 CFOU Resolution open => fixed
2021-03-07 05:21 CFOU Note Added: 0009681
2021-03-08 00:23 Pascal De Maeseneire Status closed => feedback
2021-03-08 00:23 Pascal De Maeseneire Resolution fixed => reopened
2021-03-08 00:23 Pascal De Maeseneire Note Added: 0009686
2021-03-08 16:40 CFOU Note Added: 0009687
2021-03-08 16:41 CFOU Note Edited: 0009687 View Revisions
2021-03-30 17:16 CFOU Note Added: 0009811
2021-03-30 21:00 CFOU Status feedback => confirmed
2021-03-30 21:00 CFOU Note Added: 0009814
2021-03-30 21:31 Pascal De Maeseneire Note Added: 0009815
2021-04-03 02:22 CFOU File Added: carlos-v12b.lha
2021-04-03 02:22 CFOU Note Added: 0009839
2021-04-03 02:23 CFOU Note Edited: 0009839 View Revisions
2021-04-04 01:39 CFOU Note Added: 0009842
2021-04-04 01:39 CFOU Status confirmed => closed
2021-04-04 01:39 CFOU Note Added: 0009843
+Issue History