2020-05-30 15:01 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004648Lionheart[All Projects] Generalpublic2020-05-18 20:39
Reporterapex 
Assigned ToPsygoreProject InfoLionheart (Thalion)
http://www.whdload.de/games/Lionheart.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
Summary0004648: Very strange bug. I cannot play it with my Competition Pro. Intro and
DescriptionGameVersion: english,pal,4 disks
SlaveVersion: 2.2

Very strange bug. I cannot play it with my Competition Pro. Intro and everything is working fine.
But in the game the characters seems to try to grab his back, which makes it unmovable.
No rapid fire active. Tested several Competition Pro.
Connecting a CD32 pad and this behaviour stops, game is now playable.
Connecting a Competition Pro (single fire) and it is no more working or let me say the character is trying to grab his back, looks funny.
TagsNo tags attached.
MachineA2000
CPU68030
CPUSpeed50
ChipSetECS
GFXCardPicasso II+
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.1.4
KickROM45 - Kick 3.1.4
KickSoftNone
WHDLoad18.6beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0008711

Psygore (developer)

Could you pls try the attached slave 2.3 ?

note ~0008729

apex (reporter)

Working perfect now! :-)

note ~0008741

Psygore (developer)

The CD32 buttons are disabled in the latest slave.

Could you test pls the attached slave2.3a ? CD32 buttons are enabled again.

note ~0008749

apex (reporter)

All 4 buttons are now working again on the pad, but the Competition Pro has again the same problem like in release 2.2.

Maybe a selection via custom tooltypes would make sense: One for Competition Pro and one for CD32 Joypad.

note ~0008751

Psygore (developer)

Thanks for your feedback.

Could you test your Competition Pro with this tool http://aminet.net/driver/input/JoyPortTest.lha with ‘lowlevel.library not used’ option ?

note ~0008777

apex (reporter)

If I connect my Competition to your tool, it is recognised and working.
The last two values in the line POT1DAT: $68xx are changing the whole time.

note ~0008778

apex (reporter)

If I connect my CD32 pad to your tool, it is recognised and working.
The last four values in the line POT1DAT: $xxxx are changing VERY FAST the whole time.

note ~0008779

apex (reporter)

>with ‘lowlevel.library not used’ option

Working.
+Notes

-Issue History
Date Modified Username Field Change
2020-05-12 17:06 administrator New Issue
2020-05-12 17:06 administrator Status new => assigned
2020-05-12 17:06 administrator Assigned To => Psygore
2020-05-15 01:06 Psygore File Added: Lionheart23.lha
2020-05-15 01:07 Psygore Note Added: 0008711
2020-05-15 17:44 apex Note Added: 0008729
2020-05-17 01:32 Psygore File Added: Lionheart23a.lha
2020-05-17 01:34 Psygore Note Added: 0008741
2020-05-17 11:23 apex Note Added: 0008749
2020-05-17 12:27 Psygore Note Added: 0008751
2020-05-18 20:36 apex File Added: IMG_3046.jpg
2020-05-18 20:36 apex Note Added: 0008777
2020-05-18 20:37 apex File Added: IMG_3045.jpg
2020-05-18 20:37 apex Note Added: 0008778
2020-05-18 20:39 apex Note Added: 0008779
+Issue History