2020-08-03 20:04 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004504Starquake[All Projects] Generalpublic2020-04-18 12:58
ReporterIrek 
Assigned ToCFOUProject InfoStarquake (Stephen Crow/TOS Brothers)
http://www.whdload.de/games/Starquake.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
Summary0004504: Hi, the game freezes after the black and white picture in the intro. I tried it
DescriptionGameVersion: english,pal,1disks
SlaveVersion: 1.0 from 04.02.20.

Hi,
the game freezes after the black and white picture in the intro. I tried it on two different Amigas (1xBlizzard and 1xApollo both 040 CPU).
With the Apollo card the NOCACHE option can help (otherwise a black screen) With the Blizzard I get this error message:
************************* 09-Mär-20 20:26:17 ************************18.4.5936***
Slave='Starquake.slave' (1256 bytes)
Resload   5BEE9000 - 5BEF0D2C (  32044) at 5BEE9000  GL=$5BF73000
Slave     5BFFE000 - 5BFFE4C4 (   1220) at 5BFFE000  BaseMemSize=$80000
ExpMem    5BEF2000 - 5BF72000 ( 524288) at 5BEF2000
attn=7F(40,82) fc=-1 kn=10371 cs=19C8 rw=0 zpt=-1 ep=0 ei=0
setcpu=33D(DC,IC,SCB,ECB,BNC)
Exception "Access Fault" ($7008) PC = $5BF12000 (ExpMem $20000) Long Read from
$DFF000 (custom.bltddat)
$5bf11fe4 adda.l       (a5)+,a6                       ;$00dff000
$5bf11fe6 adda.l       (a5)+,a6                       ;$00dff000
$5bf11fe8 adda.l       (a5)+,a6                       ;$00dff000
$5bf11fea adda.l       (a5)+,a6                       ;$00dff000
$5bf11fec adda.l       (a5)+,a6                       ;$00dff000
$5bf11fee adda.l       (a5)+,a6                       ;$00dff000
$5bf11ff0 adda.l       (a5)+,a6                       ;$00dff000
$5bf11ff2 adda.l       (a5)+,a6                       ;$00dff000
$5bf11ff4 adda.l       (a5)+,a6                       ;$00dff000
$5bf11ff6 adda.l       (a5)+,a6                       ;$00dff000
$5bf11ff8 adda.l       (a5)+,a6                       ;$00dff000
$5bf11ffa adda.l       (a5)+,a6                       ;$00dff000
$5bf11ffc adda.l       (a5)+,a6                       ;$00dff000
$5bf11ffe adda.l       (a5)+,a6                       ;$00dff000
$5bf12000 lea          ($5bf12086,pc),a1
$5bf12004 lea          ($2000).w,a0
$5bf12008 move.l       ($5bf12078,pc),a2
$5bf1200c move.l       #$4c4f4144,d7
$5bf12012 jsr          (a2)                           ;$5bf12000
$5bf12014 moveq        #0,d7
$5bf12016 lea          ($5bf12080,pc),a1
$5bf1201a suba.l       a0,a0
$5bf1201c move.l       (a0),a0                        ;$000201f8
$5bf1201e move.l       ($5bf12078,pc),a2
$5bf12022 jsr          (a2)                           ;$5bf12000
$5bf12024 lea          ($48428),a0
$5bf1202a move.w       #$a000,d0
$5bf1202e moveq        #0,d1
$5bf12030 move.l       d1,(a0)+                       ;$000201f8
exception stackframe:
$0007FF88 20005BF1 20007008 0007FF80 05050025 00050025 00DFF000 5BF12171 00000075
$0007FFA8 00000058 00000050 000006CC 00DFF000 00DFF000 0002011A 0002006A
regular stack:
$0007FFC4 0000FFFF 00000000 D2D2D2D2 D3D3D3D3 D4D4D4D4 D5D5D5D5 D6D6D6D6 D7D7D7D7
$0007FFE4 00020000 000001AE 0000046E 00000000 000006CC 00DFF000 00DFF000
  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx     FFFF         0  D2D2D2D2        10  D4D4D4D4  D5D5D5D5  D6D6D6D6  D7D7D7D7
Ax    201F8  5BF12172  5BF12000        50       6CC    DFF000    DFF000
                 TTSM III   XNZVC
PC=5BF12000  SR %0010000000000000  USP=7FC00  ISP=7FF88  MSP=7F800
VBR=5BF74000  SFC=5  DFC=5  CACR=80008000  MMUSR=0
TC=8000  URP=5BEE7000  SRP=5BEE7000  DTT0=0  DTT1=0  ITT0=0  ITT1=0
         MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
intena=%0100000000010000 dmacon=%0010011111010000 adkcon=$1100
intreq=%0010000000100000
vposr....A300  vhposr...1030  joy0dat..281A  joy1dat..0000  clxdat...8001  
pot0dat..3439  pot1dat..4141  potinp...5500  serdatr..3BFF  dskbytr..8000  
vposw....A300  bltafwm..FFFF  bltalwm..FFFF  deniseid.00F8  cop1lc...0002  
cop1lcl..0378  cop2lc...0000  cop2lcl..1000  diwstrt..2C81  diwstop..2CC1  
ddfstrt..0038  ddfstop..00D8  aud0pt...0005  aud0ptl..8EF2  aud0len..0008  
aud0per..0140  aud0vol..0000  aud1pt...0005  aud1ptl..6746  aud1len..0020  
aud1per..0140  aud1vol..0000  aud2pt...0005  aud2ptl..6746  aud2len..0020  
aud2per..0140  aud2vol..0000  aud3pt...0005  aud3ptl..8EF2  aud3len..0008  
aud3per..0140  aud3vol..0000  bpl1pt...0002  bpl1ptl..0428  bpl2pt...0002  
bpl2ptl..A428  bpl3pt...0003  bpl3ptl..4428  bpl4pt...0003  bpl4ptl..E428  
bpl5pt...0000  bpl5ptl..0000  bpl6pt...0000  bpl6ptl..0000  bpl7pt...0000  
bpl7ptl..0000  bpl8pt...0000  bpl8ptl..0000  bplcon0..C204  bplcon1..0000  
bplcon2..0000  bplcon3..0000  bpl1mod..004C  bpl2mod..004C  spr0pt...0000  
spr0ptl..0000  spr1pt...0000  spr1ptl..0000  spr2pt...0000  spr2ptl..0000  
spr3pt...0000  spr3ptl..0000  spr4pt...0000  spr4ptl..0000  spr5pt...0000  
spr5ptl..0000  spr6pt...0000  spr6ptl..0000  spr7pt...0000  spr7ptl..0000  
spr0ctl..0000  spr0data.0000  spr0datb.0000  spr1ctl..0000  spr1data.0000  
spr1datb.0000  spr2ctl..0000  spr2data.0000  spr2datb.0000  spr3ctl..0000  
spr3data.0000  spr3datb.0000  spr4ctl..0000  spr4data.0000  spr4datb.0000  
spr5ctl..0000  spr5data.0000  spr5datb.0000  spr6ctl..0000  spr6data.0000  
spr6datb.0000  spr7ctl..0000  spr7data.0000  spr7datb.0000  color00..0000  
color01..0344  color02..0456  color03..0234  color04..0012  color05..0123  
color06..0123  color07..0788  color08..0000  color09..0001  color10..0788  
color11..09AA  color12..0667  color13..0566  color14..0BCC  color15..0FFF  
color16..0000  color17..0000  color18..0000  color19..0000  color20..0000  
color21..0000  color22..0000  color23..0000  color24..0000  color25..0000  
color26..0000  color27..0000  color28..0000  color29..0000  color30..0000  
color31..0000  hhposr...FF3A  beamcon0.0020  fmode....0000  
   ciaa:     PI ROPS           ciab:     PI ROPS
    cra=00000000  ta=21FF<21FF       cra=00000001  ta=29BB<376B
        AII ROPS                AII ROPS
    crb=00000000  tb=21FF<21FF       crb=00000000  tb= 1F0< 1F0
        10RTWCLO      parallel        DRCCDSOY      M3210HDS
    pra=11111110  prb=11111111      pra=11111111  prb=11111111
       ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
       event=000513  icr=00  sdr=00    event=06340D  icr=81  sdr=00

       alarm=FFFFFF icm=88 alarm=0AD303 icm=83
TagsNo tags attached.
MachineA1200
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.5
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0008247

CFOU (developer)

Last edited: 2020-04-17 20:58

View 2 revisions

try to remove all SNOOP tooltype and attached slave:

error message is caused by SNOOP but it's false positive..

note ~0008255

Irek (reporter)

I already tried this slave yesterday.
With NOCACHE option, the game works on my two Amigas with 040 CPU. But the whole intro is not shown. I tried to start the game without the NOCACHE option and the game freezes with a black screen after the end of intro.

Yes that's right, the error message occurs with the SNOOPOCS option.
I was hoping this could do something help.:(

note ~0008256

CFOU (developer)

can you test this version before release?

- your icons included
- SMC which cause you crash fixed (i hope there are not anothers after...)

note ~0008261

CFOU (developer)

fixed

note ~0008280

Irek (reporter)

Thanks a lot! :)
+Notes

-Issue History
Date Modified Username Field Change
2020-04-17 15:09 administrator New Issue
2020-04-17 15:09 administrator Status new => assigned
2020-04-17 15:09 administrator Assigned To => CFOU
2020-04-17 20:00 CFOU File Added: Starquake11.lha
2020-04-17 20:00 CFOU Note Added: 0008247
2020-04-17 20:58 CFOU Note Edited: 0008247 View Revisions
2020-04-17 21:39 Irek Note Added: 0008255
2020-04-17 22:03 CFOU File Added: StarQuakev11-beta2.lha
2020-04-17 22:03 CFOU Note Added: 0008256
2020-04-17 22:44 CFOU Status assigned => closed
2020-04-17 22:44 CFOU Resolution open => fixed
2020-04-17 22:44 CFOU Note Added: 0008261
2020-04-18 09:43 Irek Status closed => feedback
2020-04-18 09:43 Irek Resolution fixed => reopened
2020-04-18 09:43 Irek Note Added: 0008280
2020-04-18 12:58 CFOU Status feedback => closed
+Issue History