2020-10-25 08:31 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004472Alcatraz_Megademo2[WHDLoad Installs Demos] OCSpublic2020-04-15 20:05
ReporterDrag0nFly 
Assigned ToStingRayProject InfoMegademo 2 (Alcatraz)
http://www.whdload.de/demos/Alcatraz_Megademo2.html
 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionreopened 
Summary0004472: [Slave] Alcatraz Megademo II does not load correctly on ACA 1233n 030 40Mhz
DescriptionWhen launching the slave for this demo, it instantly blanks the video output. The Amiga is still running and responds to a Ctrl+L_Amiga+R_Amiga
Steps To ReproduceReproducible every time I have attempted to launch it: it shows the Whdload (18.5) splash screen, executes the slave, and the video output then goes dead.

No issues with other Whdload-installs, so this one is rather weird.
TagsNo tags attached.
MachineA1200
CPU68020
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem0 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.5
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0008118

StingRay (developer)

Can you please try attached slave and tell me if it fixes the problem, thanks.

note ~0008136

StingRay (developer)

I have updated the patch and fixed a few problems, if it still doesn't work properly on your system, reopen this ticket.

note ~0008137

Drag0nFly (reporter)

Thanks for your quick replies @StingRay. (And sorry I could not check your fixes yet, but I have been away from my Amiga.)

I'll let you know how this worked and reopen the ticket if necessary.

note ~0008151

Drag0nFly (reporter)

Tried the updated slave, unfortunately though it does not make a difference. The demo still immediately blanks the video output once started (loss of signal). No audio is heard, and the A1200 only responds to a reset.

note ~0008154

StingRay (developer)

I have attached a new slave, please try this one and tell me what happens (you should see a red screen, if so, press left mouse button, WHDLoad should then quit with "Illegal instruction at $3a3f6").

note ~0008168

Drag0nFly (reporter)

Tested the updated slave. It behaves as you correctly describe above: starts with a red screen, then upon pressing LMB WHDLoad quits with an Illegal Instruction ($10) at the same address ($3a3f6) you mentioned.

btw – I tried to get it to produce a coredump, it starts writing to the hdd and then the same "illegal instruction" pops back up again with no corecump created (that is, unless I am looking in the wrong place as I am assuming it would be in cwd)

note ~0008170

StingRay (developer)

Last edited: 2020-04-15 18:11

View 2 revisions

Cored dumps are saved in C: but the core dump is not needed. I made the slave crash on purpose as I need to find the part of the code which causes the problem on your machine (and I bet it's the ACA's fault, wouldn't be the first time).

I have attached 4 new slaves, please try them and tell me if the problem still occurs with all of them, thanks.

note ~0008171

Drag0nFly (reporter)

Just tried the first slave – it shows a red screen and continues with the demo upon pressing LMB. Going to let it run a bit to see if any other display issues occur.

btw - I hear you wrt. to the ACAs, this is my second one as the first one actually had a cpu-fault which was diagnosed by me and by AmigaStore (after quite a bit of haggling w/ Jens who claimed everything else as the culprit – from PSUs, FPU-libs and cellphone interference) ;)

I came a bit late to the A1200 game, as I obviously would have preferred a Blizzard card but not at the extortionate prices they are at now. (And I would suspect the Vampire cards would introduce a whole lot of incompatility issues on their own..)

Anyway, back on topic. The demo seems to run ok with the "No136" slave (red screen in between every section, so to mousepresses needed to advance). I'll try the others as well to compare.

note ~0008172

Drag0nFly (reporter)

Hmm. The 136 slave has slight gfx-glitches (vertical bars in both scrollers) at the end w/ the Madness soundtrack (with the three skulls)

note ~0008173

Drag0nFly (reporter)

Ok, preliminary summary: ;)

- 136 runs but has gfx-issues in the Madness/3x skulls section.

- 13a shows the problematic section correctly (no vertical bars in scrollers) w/ no other issues I could detect.

- 13e does not have any sound during the first intro part(!) (w/ the Alcatraz logo). No gfx-issues with the Madness segment here though, it runs perfect.

- 142 appears to be identical to 13a wrt. the way it behaves. All sections run properly w/ no vertical bar or sound issues.

All show red screens between the demo segments, needing two LMB presses. (But that probably comes as no surprise.)

note ~0008174

StingRay (developer)

Last edited: 2020-04-15 19:05

View 2 revisions

Very strange as I expected at least 1 of the "No1xx" slaves to trigger the problem on your config (I have just disabled all interrupt routines one by one in part 1). Somehow this doesn't make it any easier.

I have attached a new slave, what happens when you try the "NoVBI" slave?

note ~0008175

Drag0nFly (reporter)

The vertical bars issue appears to be intermittent, as it now showed on both 13a & 142 slaves when I was comparing the two.

Did a soft reboot and tested the sections again with 13a, 142 & 136 and it works properly. Seems WHDLoad does not completely clear the memory after each run.

EDIT: just saw you replied right before I was going to submit this. I will try the NoVBI slave as well.

note ~0008176

Drag0nFly (reporter)

The NoVBI slave appears to work fine. It did show vertical bar issues in the skulls section, but I haven't tried rebooting the A1200 yet to make sure it is a "clean" test.

note ~0008177

Drag0nFly (reporter)

Did a soft-reboot, but the glitches in the skulls section persisted. Launched the demo with the 142 slave (w/o rebooting) and it runs it ok.

Could be that this is triggered due to some other part of the demo running for a longer amount of time, as I obviously tested the NoVBI slave for longer.

note ~0008178

Drag0nFly (reporter)

Confirmed – when skipping through the parts directly to the "skulls-section" both text scrollers now look ok with the NoVBI slave.

Ah, the weirdness.

note ~0008179

Drag0nFly (reporter)

Left the problematic section running after I wrote the last comment, and it still runs perfect.

Wish I had not recently sold my Typhoon 030 card w/ SCSI & FPU, as it would have been quite interesting to compare its functionality with the ACA on this 1d board!

note ~0008180

StingRay (developer)

OK, so it definitely is interrupt related. Try one last slave, does this one work OK on your machine?

note ~0008181

Drag0nFly (reporter)

The UserMode slave works properly; even with the two scrollers in the Madness/skulls section (although that might be random). However, I left some sections running a bit longer and didn't reboot the Amiga in between testing this slave and the NoVBI one.

note ~0008182

StingRay (developer)

OK, switching to user mode did the trick then, this will then be version 1.03 of the patch which will be available on the WHDLoad site shortly. Thanks for testing and fast replies.

note ~0008184

Drag0nFly (reporter)

Thanks the same and for your blazing fast replies. I was a bit worried at first that this was some weird hw-defect with the old 1d board, since the way it crashed with the original slave - killing the video signal (& WHDLoad) - was not very reassuring.

At least now this true classic of a demo can be properly enjoyed; even on ACA boards. ;)

note ~0008186

StingRay (developer)

Luckily all is fine now and you can enjoy this classic on your machine too. :)

The updated patch is available on the WHDLoad site so I'll close this ticket.
+Notes

-Issue History
Date Modified Username Field Change
2020-04-11 22:26 Drag0nFly New Issue
2020-04-12 22:20 StingRay Assigned To => StingRay
2020-04-12 22:20 StingRay Status new => assigned
2020-04-12 23:42 StingRay File Added: Megademo2.slave
2020-04-12 23:42 StingRay Note Added: 0008118
2020-04-14 10:59 StingRay Note Added: 0008136
2020-04-14 10:59 StingRay Status assigned => resolved
2020-04-14 10:59 StingRay Resolution open => fixed
2020-04-14 11:55 Drag0nFly Note Added: 0008137
2020-04-15 00:37 Drag0nFly Status resolved => feedback
2020-04-15 00:37 Drag0nFly Resolution fixed => reopened
2020-04-15 00:37 Drag0nFly Note Added: 0008151
2020-04-15 08:37 StingRay File Deleted: Megademo2.slave
2020-04-15 08:37 StingRay File Added: Megademo2.slave
2020-04-15 08:39 StingRay Note Added: 0008154
2020-04-15 17:55 Drag0nFly Note Added: 0008168
2020-04-15 17:55 Drag0nFly Status feedback => assigned
2020-04-15 18:10 StingRay Note Added: 0008170
2020-04-15 18:10 StingRay File Added: Megademo2_No136.slave
2020-04-15 18:10 StingRay File Added: Megademo2_No13a.slave
2020-04-15 18:10 StingRay File Added: Megademo2_No13e.slave
2020-04-15 18:11 StingRay File Added: Megademo2_No142.slave
2020-04-15 18:11 StingRay Note Edited: 0008170 View Revisions
2020-04-15 18:22 Drag0nFly Note Added: 0008171
2020-04-15 18:25 Drag0nFly Note Added: 0008172
2020-04-15 18:49 Drag0nFly Note Added: 0008173
2020-04-15 19:05 StingRay Note Added: 0008174
2020-04-15 19:05 StingRay File Added: Megademo2_NoVBI.slave
2020-04-15 19:05 StingRay Note Edited: 0008174 View Revisions
2020-04-15 19:06 Drag0nFly Note Added: 0008175
2020-04-15 19:12 Drag0nFly Note Added: 0008176
2020-04-15 19:22 Drag0nFly Note Added: 0008177
2020-04-15 19:25 Drag0nFly Note Added: 0008178
2020-04-15 19:33 Drag0nFly Note Added: 0008179
2020-04-15 19:34 StingRay Note Added: 0008180
2020-04-15 19:34 StingRay File Added: Megademo2_UserMode.slave
2020-04-15 19:40 Drag0nFly Note Added: 0008181
2020-04-15 19:55 StingRay Note Added: 0008182
2020-04-15 19:58 Drag0nFly Note Added: 0008184
2020-04-15 20:05 StingRay Note Added: 0008186
2020-04-15 20:05 StingRay Status assigned => resolved
+Issue History