2020-04-10 15:01 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004307Deliverance[All Projects] Generalpublic2020-04-08 23:35
Reporterfunkazzista 
Assigned ToJOTDProject InfoDeliverance (21st Century)
http://www.whdload.de/games/Deliverance.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
Summary0004307: Buttons of my PS2 joypad seem to be not correctly detected, in that I cannot
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.5 from 26.05.2019

Buttons of my PS2 joypad seem to be not correctly detected, in that I cannot even start a new game: tried flagging both on and off "blue/2nd button act like UP" option in the splash screen, outcome was unfortunately the same.
TagsNo tags attached.
MachineA1200
CPU68060 + PPC
CPUSpeed50
ChipSetAGA
GFXCardVoodoo3/Mediator
ChipMem256 KB
FastMem256MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftSelfmade
WHDLoad18.6beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0008054

funkazzista (reporter)

Hey JOTD!
I'm sorry for being this late, but my Amiga finally got fixed and I finally was able to test both v1.4 and v1.5 of your slave.
I can confirm to you that v1.4 works just fine with my joypad and I can play the game (even if with only 1 one button), while with v1.5 no button seems to be recognized when pressed, either with "blue/2nd button act like UP" option on or off.

note ~0008055

JOTD (developer)

Last edited: 2020-04-05 18:20

View 2 revisions

at this point I suggest that you use JoyTest program from aminet to test your joypad: http://aminet.net/package/driver/input/JoyPortTest.lha

That's how I found out that my joypad wasn't working except for the red button (no kidding!). I picked a new joypad and everything worked.

This PS2 joypad comes with an adapter I suppose? are you sure CD32 protocol is supported?

note ~0008063

funkazzista (reporter)

Jeff, I tested that JoyTest program both with lowlevel.library checked and unchecked, and all of my PS2 controller buttons are detected just fine.
Please notice that my PS2 controller works with all the other WHDLoad slaves supporting at least 2 buttons I tested, for example all the recent ones released by CFOU! work without any problem.
It's only v1.5 of your Deliverance slave that doesn't detect buttons at all: even weirder, I've just tried playing it with a Honeybee controller and that just works instead (except for the UP direction that still makes the character jump, but maybe that's on purpose?)!
So, should this problem be too hard/weird to look into, I guess I can always change controller only for this particular game.

note ~0008086

JOTD (developer)

Last edited: 2020-04-08 23:35

View 2 revisions

strange. The code I use is very standard. Maybe timers are off, going to check.

Honeybee controller is very similar to standard joypad. And yes, up has been left in because it was too difficult to handle all the moves/ladder/fight if disabled.

In the meanwhile, it would help if you tested my recent releases with joypad support too.

+Notes

-Issue History
Date Modified Username Field Change
2019-12-05 14:51 administrator New Issue
2019-12-05 14:51 administrator Status new => assigned
2019-12-05 14:51 administrator Assigned To => JOTD
2020-02-15 17:28 JOTD Status assigned => feedback
2020-02-17 09:33 funkazzista Status feedback => assigned
2020-03-03 07:10 JOTD Status assigned => feedback
2020-04-05 18:14 funkazzista Note Added: 0008054
2020-04-05 18:14 funkazzista Status feedback => assigned
2020-04-05 18:19 JOTD Note Added: 0008055
2020-04-05 18:20 JOTD Note Edited: 0008055 View Revisions
2020-04-06 10:37 funkazzista Note Added: 0008063
2020-04-08 23:32 JOTD Note Added: 0008086
2020-04-08 23:35 JOTD Note Edited: 0008086 View Revisions
+Issue History