2020-08-12 20:09 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004283CurseOfRa[All Projects] Generalpublic2020-04-05 23:28
Reporterchristoph gleisberg 
Assigned ToJOTDProject InfoCurse of Ra (Rainbow Arts)
http://www.whdload.de/games/CurseOfRa.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
Summary0004283: After strarting I see the Raindow Arts logo. A few seconds after that I get an
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.0 from 20.05.2000

After strarting I see the Raindow Arts logo. A few seconds after that I get an "Access fault" Message.
TagsNo tags attached.
MachineA4000
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem16 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoft40 - Kick 3.1
WHDLoad18.2
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0007719

JOTD (developer)

can you share your version?

note ~0007749

christoph gleisberg (reporter)

No problem, here is the image:
http://www.kabel-helpdesk.de/downloads/curse_of_ra.wwp

note ~0008027

JOTD (developer)

your version seems corrupt. It lacks a lot of files.

this link contains the proper version (same files as yours, but more data files)

https://www.dropbox.com/s/3kc3zsk4elohzsl/curseofra%21floppy.zip?dl=0

can you test that?

note ~0008028

christoph gleisberg (reporter)

You version works, but you have another. My version is 1.4b and that seems to be unsupported. The disc is 100% correct and works. May there is a problem with my image when I transfer it from Amiga to PC.

I made a coredump and a new DIC Image, this time not wwp. May there you can see it.

This access fault has sureley to do with an unsupported version.

http://www.kabel-helpdesk.de/amiga_images/curse_of_ra.lha
http://www.kabel-helpdesk.de/amiga_images/coredump.lha

note ~0008029

JOTD (developer)

Last edited: 2020-04-02 11:03

View 2 revisions

This adf file is reported "corrupt" when I extract it with some adf tool on the amiga side:

!!! The archive file has some corrupt data. !!!

Same as old wwp. No directories. It's like your version has been corrupted (virus? wrong write?). The game has a bunch of dirs like "GAMES", "GFX", "LEVELS"... that are missing on your disk.

Can you zip your installed version (the "data" directory) instead ?

note ~0008030

christoph gleisberg (reporter)

I don't understand cause on my systems everything runs perfect.
Here is the installed version:
http://kabel-helpdesk.de/amiga_images/curse_of_ra.zip

note ~0008032

JOTD (developer)

the archive you made contains the directories (I'm going to be able to analyse the issue now). The adf was corrupt, so was the wwp files.

note ~0008033

JOTD (developer)

you didn't use the install script but you copied the files directly (that's why there are others dirs like "s" and all)

The install script decrunches the files and copies only what's needed.

When the files aren't decrunched the game crashes.

note ~0008034

StingRay (developer)

Last edited: 2020-04-02 23:00

View 2 revisions

I have checked and the patch needs to be updated! There is a read from $def004 at offset $2762 in the decrunched executable which needs to be corrected to $dff004. The DIC disk image in the archive is also 100% OK, if your ADF tool reports corrupted file you might want to change to a more reliable one! :)

note ~0008035

JOTD (developer)

Last edited: 2020-04-03 00:09

View 4 revisions

strange that whdload didn't detect that def004 read.

@StingRay specially because I had setup a patchlist that corrects the issues:

pl_floppy
    PL_START
    ; fix access faults $DEF00x => $DFF00x
    PL_B $2762+3,$DF
    PL_B $2800+3,$DF
    PL_B $29d0+3,$DF
        ...

User issue origin is bad installation procedure anyway. Access fault is not at DEFxxx.

note ~0008053

JOTD (developer)

it's not a bug, installation mishap

note ~0008056

JOTD (developer)

@Stingray the game works perfectly. No need to check the issue. And the access faults are already fixed (check the slave in the install)

note ~0008057

StingRay (developer)

I have installed it using the install script and the access fault happened. I have now checked again and the problem is that file "ra" is NOT decrunched during installation hence no fixes are applied at the correct offsets either. The install script has to be fixed to decrunch "ra", patch works then.

note ~0008058

JOTD (developer)

I understand. I wonder how many people really tried to install that game... Unless it fails silently in some cases.

I checked the install script and xfddecrunch is called. I'll try again.
+Notes

-Issue History
Date Modified Username Field Change
2019-11-18 10:45 administrator New Issue
2019-11-18 10:45 administrator Status new => assigned
2019-11-18 10:45 administrator Assigned To => JOTD
2020-02-15 17:21 JOTD Note Added: 0007719
2020-02-15 17:23 JOTD Status assigned => feedback
2020-02-16 14:35 christoph gleisberg Note Added: 0007749
2020-02-16 14:35 christoph gleisberg Status feedback => assigned
2020-04-02 09:31 JOTD Note Added: 0008027
2020-04-02 10:31 christoph gleisberg Note Added: 0008028
2020-04-02 11:00 JOTD Note Added: 0008029
2020-04-02 11:03 JOTD Note Edited: 0008029 View Revisions
2020-04-02 12:11 christoph gleisberg Note Added: 0008030
2020-04-02 20:53 JOTD Note Added: 0008032
2020-04-02 20:56 JOTD Note Added: 0008033
2020-04-02 20:56 JOTD Status assigned => closed
2020-04-02 20:56 JOTD Resolution open => no change required
2020-04-02 23:00 StingRay Status closed => feedback
2020-04-02 23:00 StingRay Resolution no change required => reopened
2020-04-02 23:00 StingRay Note Added: 0008034
2020-04-02 23:00 StingRay Note Edited: 0008034 View Revisions
2020-04-03 00:02 JOTD Note Added: 0008035
2020-04-03 00:05 JOTD Note Edited: 0008035 View Revisions
2020-04-03 00:09 JOTD Note Edited: 0008035 View Revisions
2020-04-03 00:09 JOTD Note Edited: 0008035 View Revisions
2020-04-05 15:40 JOTD Status feedback => closed
2020-04-05 15:40 JOTD Note Added: 0008053
2020-04-05 20:48 StingRay Assigned To JOTD => StingRay
2020-04-05 20:58 JOTD Note Added: 0008056
2020-04-05 21:04 StingRay Assigned To StingRay => JOTD
2020-04-05 21:04 StingRay Status closed => feedback
2020-04-05 21:04 StingRay Note Added: 0008057
2020-04-05 21:53 JOTD Note Added: 0008058
2020-04-05 23:28 JOTD Status feedback => closed
+Issue History