2023-01-29 19:34 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004215TheSettlers[All Projects] Generalpublic2022-12-08 23:20
Reporterjonathan 
Assigned ToJOTDProject InfoThe Settlers / Die Siedler (Blue Byte)
http://www.whdload.de/games/TheSettlers.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionopen 
Summary0004215: Good day to your sir, I have an issue to report on the latest Whdload build of
DescriptionGameVersion: Whdload The settlers 1.5
SlaveVersion: not sure

Good day to your sir, I have an issue to report on the latest Whdload build of The Settlers.
After clicking all the symbols at the copy protection screen,
the borders of the screen goes red and the game hangs.
The previous version 1.5 doesn't have this problem.
I am using a ACA1233n.
I tried praying, but it didnt help =(
Cheers!
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.1
KickROM45 - Kick 3.1.4
KickSoftNone
WHDLoad18.5
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0007846

arnljot (reporter)

I have the same problem.

Amiga 500, ks 3.1.4. MC68000. 2MB Chip, 8MB Fast.
Settlers 1.6
WHDLOAD 18.5.4958

Always been like this for me on any machine. Havent tried other WhdLoad maybe... Will look for.

note ~0012055

Superman (reporter)

I have the same red border issue on my A1200 but if I press the right mouse button it takes me into the game just fine. Does the right mouse button not work for you guys?

note ~0012056

JOTD (developer)

red border is not really a problem.

Don't use 1.5 as it's missing checksums. Stingray rewrote it, but seemed to have missed plain 68000 support (happens!)

Also the intro is a blackscreen for me (I think it happened before too). Seems badly coded.

We're not giving up on that one.

note ~0012057

StingRay (developer)

Red borders are not a 68000 problem at all (1.6 works fine on 68000 machines), it's just debug code I have accidentally left in the slave when I developed a generic approach to disable the protection checks and accompanying checksums. Once you press right mouse button, the game will start normally. It is not obvious that right mouse button has to be used, so I guess a lot of people thought the game simply hangs.

note ~0012060

JOTD (developer)

the OS seems to expect RMB when exiting intro, which sucks...

I have fixed the remaining intro blitter errors that crashed it.

note ~0012088

JOTD (developer)

released a new version, does it solve the issue?
+Notes

-Issue History
Date Modified Username Field Change
2019-09-21 10:13 administrator New Issue
2019-09-21 10:13 administrator Status new => assigned
2019-09-21 10:13 administrator Assigned To => StingRay
2020-03-10 22:51 arnljot Note Added: 0007846
2022-12-01 23:35 JOTD Assigned To StingRay => JOTD
2022-12-01 23:46 JOTD Assigned To JOTD =>
2022-12-01 23:47 JOTD Assigned To => JOTD
2022-12-03 22:42 Superman Note Added: 0012055
2022-12-03 23:56 JOTD Note Added: 0012056
2022-12-05 00:39 StingRay Note Added: 0012057
2022-12-05 23:10 JOTD Note Added: 0012060
2022-12-05 23:11 JOTD File Added: TheSettlersBetaSlave.zip
2022-12-08 23:20 JOTD Note Added: 0012088
2022-12-08 23:20 JOTD Status assigned => feedback
+Issue History