2019-10-15 10:32 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004184Network_Synthesis[All Projects] Generalpublic2019-08-17 20:44
ReporterDrag0nFly 
Assigned ToJOTDProject InfoSynthesis (Network)
http://www.whdload.de/demos/Network_Synthesis.html
 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionopen 
Summary0004184: [Slave] Synthesis/Network v1.0: crash (Line 1111 Emulator Error) when running on 030 CPU (real or emulated)
DescriptionWHDload (18.3 & 18.5, possibly other versions) crashes right after the intro sequence with the above message when using the A1200 slave.

I have reproduced the issue on two Amiga 1200s, one w/ an 1d board rev. and another with 1d4, as well as two accelerator cards:

- Typhoon 030 w/SCSI @42Mhz w/64Mb RAM
- ACA 1233n @40Mhz w/128Mb RAM

Full error message:

Line 1111 Emulator ($2C) at $475B3B96 (Task 'Initial Cli', ExpMem $41B96) occured.

The ExpMem address is identical on all crashes. The first part is similar (e.g $6F7B6B96 $475B3B96)

The error is also reproducible when emulating the A1200 using FS-UAE - tested with WHDLoad 18.3 & 18.5, as well as compared the official slave online.

WHDLoad options tried:

- NOVBRMOVE (proceeds into the second part with only music playing)
- NOMEMREVERSE (no change)
- NOAUTOVEC (no change)
- MMU on/off (behaves identically)

The demo works fine on both cards, and under FS-UAE, when running it directly without WHDLoad.

It also works in WHDLoad under FS-UAE when using the Blizzard 1240 option, possibly indicating some issues with the 040 patches when not running on said CPU.
Steps To ReproduceStart the Network/Synthesis demo using either a real Blizzard 1230 (tested w/ UAE - assuming it will behave identical in real-life), a Typhoon 1230 MkII @42Mhz, or an ACA 1233n @40Mhz.

-Or- select the 'Blizzard 1230' expansion option in FS-UAE (https://fs-uae.net/download) when running via HDF.

Start the demo as usual, and skip the intro sequence w/ LMB. The crash should occur right after the music for the next part starts playing.
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.5
imported
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2019-08-13 18:00 Drag0nFly New Issue
2019-08-13 18:00 Drag0nFly File Added: amiga1200hdf-full-1908131727-01.png
2019-08-17 20:43 Wepl Project WHDLoad => Network_Synthesis
2019-08-17 20:44 Wepl Assigned To => JOTD
2019-08-17 20:44 Wepl Status new => assigned
+Issue History