2019-06-19 18:42 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003967JohnMaddenFootball[All Projects] Generalpublic2018-12-23 21:15
ReporterHexaae 
Assigned ToStingRayProject InfoJohn Madden Football (Electronic Arts)
http://www.whdload.de/games/JohnMaddenFootball.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionwon't fix 
Summary0003967: 2 MINOR PROBLEMS Gfx glitch: ----------- unaligned green field copperlist
DescriptionGameVersion: english,pal
SlaveVersion: 1.4 (18.02.2018)

2 MINOR PROBLEMS
Gfx glitch:
-----------
unaligned green field copperlist column on the right border (~10pixels wide), on AGA machines
Sound glitch:
-------------
when action starts after a down, sometimes randomly voice samples are truncated. E.g. when calling "Fortytwo!" sometimes is truncated to "Fort..." and cpu kicks the ball, at least on fast cpus like emulated 040 and 060. Wonder if a small delay could be added to be sure samples are fully played or fix sample audio routines timing.
TagsNo tags attached.
MachineA1200
CPU68060
CPUSpeed75
ChipSetAGA
GFXCardOther
ChipMem2 MB
FastMem256 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.4beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0006569

StingRay (developer)

Last edited: 2018-12-23 21:13

View 2 revisions

The "gfx glitch" is caused by your emulator settings! The other problem happens way to less to be easily reproducable and after spending a few hours looking at the code without spotting anything obvious which might cause this I will, at least for now, not look into this any longer.

note ~0006571

Hexaae (reporter)

Yep, I confirm the first wasn't a issue but a problem with borders were caused by default WinUAE's overscan settings (not the best for ANY game, e.g. too wide also for 'Treasure Trap')…

The second bug about truncated voice samples at kick off or field goals is still there though. It seems the sound routines are very sensitive to cpu timing (probably, but you're the expert! ;)) so it's hard to play the game at decent, fast speed, but with correctly playing voice samples.

note ~0006572

Hexaae (reporter)

Read above ;)

note ~0006573

StingRay (developer)

Read above! I will not look into this for the foreseeable future as this is not easy to fix and there is nothing obviously wrong in the sample playing code.
+Notes

-Issue History
Date Modified Username Field Change
2018-09-24 00:54 administrator New Issue
2018-09-24 00:54 administrator Status new => assigned
2018-09-24 00:54 administrator Assigned To => StingRay
2018-12-23 18:10 StingRay Note Added: 0006569
2018-12-23 18:10 StingRay Status assigned => resolved
2018-12-23 18:10 StingRay Resolution open => won't fix
2018-12-23 20:21 Hexaae Note Added: 0006571
2018-12-23 20:22 Hexaae Status resolved => feedback
2018-12-23 20:22 Hexaae Resolution won't fix => reopened
2018-12-23 20:22 Hexaae Note Added: 0006572
2018-12-23 21:13 StingRay Note Edited: 0006569 View Revisions
2018-12-23 21:15 StingRay Note Added: 0006573
2018-12-23 21:15 StingRay Status feedback => resolved
2018-12-23 21:15 StingRay Resolution reopened => won't fix
+Issue History