2019-12-09 22:44 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003920Gunship[All Projects] Generalpublic2018-12-30 18:36
ReporterMarkus Klotzberg 
Assigned ToJOTDProject InfoGunship (Microprose)
http://www.whdload.de/games/Gunship.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
Summary0003920: When i try to start the Helicopter with Keys 1 and 2 for Engine the first
DescriptionGameVersion: German, Pal, 1 Disk
SlaveVersion: 1.0 from 20.05.2000

When i try to start the Helicopter with Keys 1 and 2 for Engine the first starts but without Sound. Then the Game freezes. Sometimes i am able to start the second Engine and i can take off. But after some seconds the Screen gets scrambled.
This happens on the descibed A3000 and on A4000 with Cyberstorm MK2 (68060/50Mhz) and A2000 with Vampire V2+.
On all that Machines the same issue.
When i use "exp24bit" the Sound Comes and i can Fly, after some seconds the Game crashes to Workbench wir Exception Error.
On an CDTV equipped with "Matzes" a1k 68010 14mhz it runs fine.
Same on an A1200 with Blizzard 1230 MK IV here it runs fine too.
The three Machines where the Problem exists have 16Mb Fast on Board (A3000 / A4000) and 128MB on Turbocard (A4000 / A2000). The A2000 has only 1 MB of Chipram.
Could it be a Problem with the Adress from the Memory ?
Greets Markus (German would be easier to write)
TagsNo tags attached.
MachineA3000
CPU68030
CPUSpeed25
ChipSetECS
GFXCardCyberVision 64
ChipMem2 MB
FastMem16 MB
WorkbenchOS 3.1
KickROMOther
KickSoft40 - Kick 3.1
WHDLoad18.3
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0006320

JOTD (developer)

can you attach your game files (compressed)? there are many versions out there.

I just need the "titlmule", "gamemule" and "scrnmule" files.

note ~0006612

Markus Klotzberg (reporter)

Hello, just attached 2 Versions of the Game.

The Preinstalled is a preinstalled version which has the above discribed issue.
Meanwhile i bought the German version of the game. This one won´t start at all on my machines. All do the same -
"Exception "Illegal Instruction" ($10) at $F857694 (ExpMem $2A694) occured"

Possible other adress but all the same error message.
On CDTV it doesn´t work too, boots to the Intro but crashes when it starts in whdload and reboots. It doesn´t crash the complete CDTV, only the whdload.
+Notes

-Issue History
Date Modified Username Field Change
2018-08-07 14:47 administrator New Issue
2018-08-07 14:47 administrator Status new => assigned
2018-08-07 14:47 administrator Assigned To => JOTD
2018-08-18 19:33 JOTD Note Added: 0006320
2018-12-28 23:39 JOTD Status assigned => feedback
2018-12-30 18:29 Markus Klotzberg File Added: Gunship_Preinstalled.zip
2018-12-30 18:29 Markus Klotzberg File Added: Gunship_German.zip
2018-12-30 18:33 Markus Klotzberg Note Added: 0006612
2018-12-30 18:33 Markus Klotzberg Status feedback => assigned
2018-12-30 18:36 JOTD Status assigned => acknowledged
+Issue History