2018-11-13 16:36 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003893RiskyWoods[All Projects] Generalpublic2018-09-22 18:52
ReporterHexaae 
Assigned ToStingRayProject InfoRisky Woods (Electronic Arts/Dinamic)
http://www.whdload.de/games/RiskyWoods.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
Summary0003893: Correct music and sound effects OR micro stuttering. Even using this with
DescriptionGameVersion: english,pal
SlaveVersion: 1.1 (07.12.2017)

Correct music and sound effects OR micro stuttering.
Even using this with WinUAE 4.0.0beta:
ExecutePostDisk=uae-configuration cachesize 0 immediate_blits false cpu_cycle_exact true cpu_multiplier 8
...the game will not be perfect and will show micro stuttering (start to play and move from left to right). Removing "cpu_cycle_exact true" will solve this and the game will have always smooth scrolling even with a lot of sprites on screen, but at this point music and sound will not be ok...
Is it possible to improve this slave a bit for perfect speed and music/audio routines? :)
TagsNo tags attached.
MachineUAE
CPU68040
CPUSpeed75
ChipSetAGA
GFXCardPicasso IV
ChipMem2 MB
FastMem256MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftOther
WHDLoad18.4beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0006225

Hexaae (reporter)

Another thing: on WinUAE 040 requires also NOCACHE

note ~0006306

StingRay (developer)

I can't reproduce this at all and if this only happens on UAE I won't spend time looking into it.

Same for the NOCACHE thing, I've tried it on UAE with full cache emulation and it worked. What's your config?

note ~0006308

StingRay (developer)

That config has JIT enabled, cycle exact and cache emulation are disabled however so there bound to be problems! However, patch still works for me with these settings, I don't have to use NOCACHE at all.

What happens on your system, does the game crash?

note ~0006309

Hexaae (reporter)

No no, the "real cfg" is in the icon tooltypes changing WinUAE parameters through the C:uaeconfiguration...

The problem with this game for me is that: or music runs too fast, or there is no audio if you enable some fast emulation options. I'm talking about WinUAE in 040 or 060 mode...

note ~0006382

Hexaae (reporter)

Seems I've finally found good settings with no micro-stutterings using WinUAE 4.x.x:

ExecutePostDisk=uae-configuration cachesize 0 cpu_compatible true blitter_cycle_exact true cpu_throttle -900 immediate_blits true
+Notes

-Issue History
Date Modified Username Field Change
2018-06-17 14:19 administrator New Issue
2018-06-17 14:19 administrator Status new => assigned
2018-06-17 14:19 administrator Assigned To => StingRay
2018-06-17 15:05 Hexaae Note Added: 0006225
2018-07-31 09:17 StingRay Note Added: 0006306
2018-08-01 09:11 StingRay Note Added: 0006308
2018-08-01 23:12 Hexaae Note Added: 0006309
2018-09-22 18:52 Hexaae Note Added: 0006382
+Issue History