2023-09-30 02:35 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003808NipponSafesInc[All Projects] Generalpublic2021-11-28 16:40
ReporterHexaae 
Assigned ToWeplProject InfoNippon Safes Inc (Dynabyte)
http://www.whdload.de/games/NipponSafesInc.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionno change required 
Summary0003808: Please, add Italian support.
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: version 1.2 (4.1.2017)

Please, add Italian support.
TagsNo tags attached.
MachineUAE
CPU68040
CPUSpeed75
ChipSetAGA
GFXCardOther
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftOther
WHDLoad18.4beta
importedyes
Attached Files
  • jpg file icon 20180214225307_1.jpg (99,095 bytes) 2018-02-14 22:57 -
    jpg file icon 20180214225307_1.jpg (99,095 bytes) 2018-02-14 22:57 +
  • jpg file icon 20180214225307_1-2.jpg (99,095 bytes) 2018-02-14 22:58 -
    jpg file icon 20180214225307_1-2.jpg (99,095 bytes) 2018-02-14 22:58 +
  • jpg file icon 20180214225312_1.jpg (101,044 bytes) 2018-02-14 23:00 -
    jpg file icon 20180214225312_1.jpg (101,044 bytes) 2018-02-14 23:00 +
  • ? file icon NipponSafesInc.Slave (5,468 bytes) 2018-02-15 12:53
  • ? file icon .whdl_register_NSafes_ita (3,567 bytes) 2018-02-15 14:16
  • ? file icon .whdl_log_02 (13,512 bytes) 2018-02-15 21:38
  • ? file icon .whdl_register_02 (3,567 bytes) 2018-02-15 21:39
  • ? file icon .whdl_register (3,617 bytes) 2021-11-28 16:40 -
    ************************* 28-Nov-21 16:39:04 ************************18.7.6366***
    Slave='NipponSafesInc2.Slave' (5468 bytes)
    Resload   6FFCC000 - 6FFD479C (  34716) at 6FFCC000  GL=$6FFD6000
    Slave     6FFDF000 - 6FFE0538 (   5432) at 6FFDF000  BaseMemSize=$80000
    ExpMem      72F000 -   7FF000 ( 851968) at 72F000
    attn=2FF(UAE,60,82) fc=-1 kn=10336 cs=EE94 rw=0 zpt=-1 ep=0 ei=0
    setcpu=0(SNCS,ENCS,BNCS) DbgSeg(FirstHunkStart)=777D28
    
    Exception "Illegal Instruction" ($10) at $A occurred.
    
    $ffffffd2 move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffd6 move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffda move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffde move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffe2 move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffe6 move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffea move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $ffffffee move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $fffffff2 move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $fffffff6 move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $fffffffa move.l       ($2a2a,a2),d5                  ;$0077a4ba
    $fffffffe move.l       (0,a2),d5                      ;$00777a90
    $00000002 ori.b        #0,d0
    $00000006 ori.b        #??$cc,d0
    1m$0000000a mulu         a4,d6
    22m$0000000c mulu         a4,d6
    $0000000e mulu         a4,d6
    $00000010 mulu         a4,d6
    $00000012 mulu         a4,d6
    $00000014 mulu         a4,d6
    $00000016 mulu         a4,d6
    $00000018 mulu         a4,d6
    $0000001a mulu         a4,d6
    $0000001c mulu         a4,d6
    $0000001e mulu         a3,d6
    $00000020 ori.w        #$f90e,(-$34,a2,a4.l*4)        ;$02542eec
    $00000026 mulu         a4,d6
    $00000028 mulu         a4,d6
    $0000002a mulu         a4,d6
    
    exception stackframe:
    $007FEFF0 00180000 000A0010
    regular stack:
    $00777430 00742C60 00770E1E 0073E400 00775D80 00000010 0073EA74 00775D80 00777888
    $00777450 0074F1F0 0073EA92 00777A90 00770001 007352E2 00777A90 00752D4E 0077296E
    $00777470 00751816 00777A90 00770001 00777888 0074F1F0 007517F2 00777888 00777570
    $00777490 0074FAE8 00777888 0074F840 00772D24 0074BE72 00000000 00777888 00770FA0
    $007774B0 00000000 00777570 0077759C 00772D46 00777570 00000FA8 00000000 0000003E
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx       DC         0    777A90       FA8    772D24       140         5    7741D4
    Ax   775D80    775D80    777A90         0    772D24    7774E4         0
    
                     TTSM III   XNZVC
    PC=       A22m  SR=%00000000000110001m  USP=777430  SSP=7FEFF0
    VBR=6FFD7000  SFC=5  DFC=5  CACR=0  PCR=4300602  BUSCR=0
    TC=8000  URP=6FFCAE00  SRP=6FFCAE00  DTT0=0  DTT1=0  ITT0=0  ITT1=0
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%111000000010110022m dmacon=%1m0010001111110000 adkcon=$1100
    intreq=%1000010001000000
    vposr....A300  vhposr...0146  joy0dat..2AFD  joy1dat..0000  clxdat...8023  
    pot0dat..59F1  pot1dat..0000  potinp...5500  serdatr..3800  dskbytr..2000  
    deniseid.00F8  hhposr...001C  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=0000000022m  ta=21FF<21FF	   cra=1m00000000  ta=FFFF<FFFF
    	    AII ROPS			    AII ROPS
    	crb=0000100022m  tb=C5AE<C5AE	   crb=1m10000000  tb=FFFF<FFFF
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=1111110022m  prb=1m1111111122m      pra=1m1111111122m  prb=1m11111111
           ddra=0000001122m ddrb=1m0000000022m     ddra=1m1100000022m ddrb=1m11111111
           event=00029B  icr=00  sdr=7E    event=000139  icr=00  sdr=00
    
    ? file icon .whdl_register (3,617 bytes) 2021-11-28 16:40 +

-Relationships
duplicate of 0005242assignedWepl Nippon Safe Inc. ITA version 
+Relationships

-Notes

note ~0005999

Wepl (manager)

What's the problem, italian is supported?

note ~0006000

Hexaae (reporter)

Can't click on Italian in the language selection screen.

note ~0006001

Retroplay (reporter)

It's not a WHDLoad issue, see this:
http://eab.abime.net/showthread.php?t=88293

note ~0006002

Wepl (manager)

Correct, you need the italian disks. Italian language is not part of the multilanguage version.

note ~0006028

Wepl (manager)

Exactly these images are supported.
What 'objects description'?
Please describe and maybe make an picture.

note ~0006031

Hexaae (reporter)

This is "piccone"

note ~0006032

Hexaae (reporter)

This is "cassetta per gli attrezzi" [20180214225312_1.jpg]

Looks like the WHD installer doesn't use correct fonts for the italian version, exceeding length...

note ~0006034

Wepl (manager)

please try attached new slave

note ~0006038

Hexaae (reporter)

Doug intro now works fine and texts are correctly displayed, but it crashes right after the newspaper with "Say 'Cheese', Doug!"

note ~0006039

Hexaae (reporter)

Error #205. Object not found on reading "".

note ~0006040

Hexaae (reporter)

Attached .whdl_register

note ~0006048

Wepl (manager)

Last edited: 2018-02-15 20:46

View 2 revisions

set option FILELOG
I need a full dump and .whdl_log
and please describe how to reproduce and provide savegame if possible

note ~0006049

Hexaae (reporter)

Here are the logs (..._02).
I have installed the game with latest installer.

I don't use a savegame.
I start the game, and select Nuovo Gioco (New Game), complete the Doug intro, then after the newspaper the game quits to WB with #205 error.

note ~0010420

Wepl (manager)

Last edited: 2021-06-21 23:22

View 3 revisions

How do I complete the Doug intro?
Ok I managed it.
I could reproduce it somehow. Getting an Access Fault instead.
Using option ExpChip seems to avoid this problem. Can you try?

note ~0010802

Hexaae (reporter)

Ok I managed to restore Ita version and beta slave works fine with EXPCHIP tooltype (language selection UI is useless of course)!

There's a bug: in-game default QUIT key is CTRL+Q for the International version, and SPACE for the Italian version. In both cases game crashes back to Workbench with instruction error (attached .whdl_register)
+Notes

-Issue History
Date Modified Username Field Change
2018-01-29 13:27 administrator New Issue
2018-01-29 13:27 administrator Status new => assigned
2018-01-29 13:27 administrator Assigned To => Wepl
2018-01-29 13:28 Wepl Note Added: 0005999
2018-01-29 14:06 Hexaae Note Added: 0006000
2018-01-29 16:25 Retroplay Note Added: 0006001
2018-01-29 16:45 Wepl Note Added: 0006002
2018-01-29 16:45 Wepl Status assigned => resolved
2018-01-29 16:45 Wepl Resolution open => no change required
2018-02-14 21:55 Wepl Note Added: 0006028
2018-02-14 22:57 Hexaae File Added: 20180214225307_1.jpg
2018-02-14 22:58 Hexaae File Added: 20180214225307_1-2.jpg
2018-02-14 22:58 Hexaae Note Added: 0006031
2018-02-14 23:00 Hexaae File Added: 20180214225312_1.jpg
2018-02-14 23:00 Hexaae Note Added: 0006032
2018-02-15 12:53 Wepl File Added: NipponSafesInc.Slave
2018-02-15 12:53 Wepl Note Added: 0006034
2018-02-15 14:14 Hexaae Note Added: 0006038
2018-02-15 14:14 Hexaae Note Added: 0006039
2018-02-15 14:16 Hexaae File Added: .whdl_register_NSafes_ita
2018-02-15 14:16 Hexaae Note Added: 0006040
2018-02-15 20:27 Wepl Status resolved => assigned
2018-02-15 20:45 Wepl Note Added: 0006048
2018-02-15 20:46 Wepl Note Edited: 0006048 View Revisions
2018-02-15 21:38 Hexaae File Added: .whdl_log_02
2018-02-15 21:38 Hexaae Note Added: 0006049
2018-02-15 21:39 Hexaae File Added: .whdl_register_02
2021-05-31 17:21 CFOU Relationship added duplicate of 0005242
2021-06-21 22:50 Wepl Note Added: 0010420
2021-06-21 22:54 Wepl Note Edited: 0010420 View Revisions
2021-06-21 23:22 Wepl Note Edited: 0010420 View Revisions
2021-11-28 16:40 Hexaae File Added: .whdl_register
2021-11-28 16:40 Hexaae Note Added: 0010802
+Issue History