2020-10-26 20:08 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003455IK+[WHDLoad Installs Games] slavepublic2016-08-14 20:53
ReporterHexaae 
Assigned ToStingRayProject InfoIK+ (Archer MacLean)
http://www.whdload.de/games/IK+.html
 
PrioritynormalSeveritytweakReproducibilityalways
StatusresolvedResolutionfixed 
Summary0003455: Music speed fix in NTSC mode
DescriptionFirst of all: this game MUST be played in NTSC mode!

In PAL, timings will be too slow and laggy. In NTSC gfx proportions are correct, NORMAL speed is perfect and all moves timings are optimal, try yourself...
Playability is much better in NTSC.

Now... the problem is: music gets too fast in NTSC mode and should be patched to run at the same speed of PAL mode (VBLANK timing?)

I offer a gift on Steam for the brave slave coder able to add this patch...
TagsNo tags attached.
MachineA1200
CPU68040
CPUSpeed75
ChipSetAGA
GFXCardPicasso II
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.2
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0005026

StingRay (developer)

No Steam gift needed (couldn't care less), full NTSC support added, all timing related routines adapted so game runs at the same speed on PAL and NTSC.

note ~0005028

Hexaae (reporter)

Last edited: 2016-06-27 23:33

View 3 revisions

...but the problem was the exact opposite: NTSC speed is the correct speed, except music being too fast.
As far as I can understand you made the whole game run always at PAL speed, not just the music which was desync'ed?

Sprites flicker like hell on WinUAE now... mmmh...

EDIT: Custom1 ON seems uneffective

note ~0005032

StingRay (developer)

CUSTOM1 works as intended! And the sprites flickered on UAE before already which was the sole reason for adding the timing fix.

note ~0005033

Hexaae (reporter)

Last edited: 2016-06-28 10:49

View 2 revisions

https://www.youtube.com/watch?v=0k5ekHEDKdM

Old version was ok: no flickering and correct timing in NTSC. Music was too fast.

New version: flickering sprites with a "ghost" effect and slow unnatural moves (PAL timings). Music is ok.

The perfect thing would be as in the old NTSC version and no flickering but with fixed (=slowed down) music.

note ~0005040

Hexaae (reporter)

Last edited: 2016-07-03 09:13

View 2 revisions

Changes didn't fix the issue properly: only music had to be fixed in NTSC mode, timing was already perfect and also gfx proportions. It's PAL timing, now applied to NTSC mode too, that was wrong (but music was ok).
Introduced new flickering issues in NTSC mode.

note ~0005047

Hexaae (reporter)

Is there any hope to see the NTSC mode properly fixed (i.e. music slow-down only)?

note ~0005217

StingRay (developer)

Please check attached slave, it should now do exactly what you want in NTSC mode.

note ~0005218

Hexaae (reporter)

P E R F E C T !!
You're my HERO StingRay!

note ~0005219

StingRay (developer)

Excellent, have fun then. :)
+Notes

-Issue History
Date Modified Username Field Change
2016-06-25 11:15 Hexaae New Issue
2016-06-27 18:33 StingRay Note Added: 0005026
2016-06-27 18:33 StingRay Status new => resolved
2016-06-27 18:33 StingRay Resolution open => fixed
2016-06-27 18:33 StingRay Assigned To => StingRay
2016-06-27 22:15 Hexaae Note Added: 0005028
2016-06-27 23:19 Hexaae Note Edited: 0005028 View Revisions
2016-06-27 23:33 Hexaae Note Edited: 0005028 View Revisions
2016-06-28 00:21 StingRay Note Added: 0005032
2016-06-28 09:01 Hexaae Note Added: 0005033
2016-06-28 10:49 Hexaae Note Edited: 0005033 View Revisions
2016-06-28 23:23 Hexaae Note Added: 0005040
2016-06-28 23:23 Hexaae Status resolved => feedback
2016-06-28 23:23 Hexaae Resolution fixed => reopened
2016-07-03 09:13 Hexaae Note Edited: 0005040 View Revisions
2016-07-03 09:17 Hexaae Note Added: 0005047
2016-07-03 09:17 Hexaae Status feedback => assigned
2016-08-14 18:29 StingRay Note Added: 0005217
2016-08-14 18:30 StingRay File Added: IK+.slave
2016-08-14 18:53 Hexaae Note Added: 0005218
2016-08-14 20:53 StingRay Note Added: 0005219
2016-08-14 20:53 StingRay Status assigned => resolved
2016-08-14 20:53 StingRay Resolution reopened => fixed
+Issue History