2019-09-23 08:48 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003225Genesia[All Projects] Generalpublic2019-08-24 11:31
Reportertripper 
Assigned ToJOTDProject InfoGenesia (Microïds)
http://www.whdload.de/games/Genesia.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
Summary0003225: I tried to install from both the originals disks and through a readymade
DescriptionGameVersion: english,pal,3 disks (configuration, disk1 and disk2)
SlaveVersion: latest

I tried to install from both the originals disks and through a readymade packet. Followed instructions (running the config first, saying 'no' and all). After the config is finished (checking system speed and saying configuration finished, please wait game will start etc). It just stops playing music and that's all (screen stays, no key will return to wb, so I need to reset). Then when I start the game from the game icon, after the difficulty selection -screen it always just asks for disk 1. (I do have disk 1, but of course it will not even check that as this is a whdload installation). Anyways, can't continue. Been waiting to play this for a long time.
What I later found is that when I change world other than default '1', it actually saves something to the CF... after which music stops and no key does anything (have to reset, so otherwise the same problem here). After the reset when I try to open the program/loader it actually loads much more than before, but hangs with a message about function 'resload_savefileoffset' with unacceptable arguments.
downloaded the packet from whdownload . com
(also I installed from my original disks... same thing)
tried nocache, noautovec, novbrmove.. doubled the stack.
picture: cubicle.fi/~tripper/AMIGA/TEMP/SDC17495.JPG
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.1
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0005582

Solo Kazuki (reporter)

I have also the same problem. Running on WinUAE as AGA/040 config.

note ~0005583

Solo Kazuki (reporter)

I just found solution. You must quit configuration just before it suspends (when you have info about "game will start...").

But game runs much too fast. Switches like "NOCACHE" or "NOVBRMOVE" doesn't help. Additionally fonts are wrong (too big on map, black on "flag" people management). Probably some fonts from game are missin or wrong fonts are used.

Config: UAE, AGA/040, 2MB chip + 128MB fast. Used WHDLoad v18.2, when v18.3 is used game back to WB just before loading/info (BUTTONWAIT) screen (game) or after copy protection check (config).

note ~0005626

JOTD (developer)

This game has always been painful to fix. I know the slave isn't working too well.

note ~0005717

haynor666 (reporter)

Fonts are too big because game originally rely on system-configuration font size which on original disk was set to 80 signs per line. Under WHDLoad this file seems to be ignored so we has 60 sings per line.

note ~0005718

JOTD (developer)

that's not an issue. I can fix that font problem.

note ~0005719

retrogamer (reporter)

If you are going to update the slave please can you change the release year for the game in the splash screen to 1993?

note ~0007010

Solo Kazuki (reporter)

Hello

How is going with fixing slave? At least font problem.
+Notes

-Issue History
Date Modified Username Field Change
2015-04-24 17:40 administrator New Issue
2015-04-24 17:40 administrator Status new => assigned
2015-04-24 17:40 administrator Assigned To => JOTD
2017-05-20 15:44 Solo Kazuki Note Added: 0005582
2017-05-23 15:27 Solo Kazuki Note Added: 0005583
2017-07-14 18:24 JOTD Note Added: 0005626
2017-08-19 21:18 haynor666 Note Added: 0005717
2017-08-20 21:41 JOTD Note Added: 0005718
2017-08-21 23:03 retrogamer Note Added: 0005719
2019-08-24 11:31 Solo Kazuki Note Added: 0007010
+Issue History