2020-11-24 02:13 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003167Turrican[WHDLoad Installs Games] OCSpublic2016-02-09 22:04
ReporterDanyPPC 
Assigned ToWeplProject InfoTurrican (Factor 5/Rainbow Arts)
http://www.whdload.de/games/Turrican.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
Summary0003167: Turrican: second button does not work on A1200 with a Blizzard 1230 Turbo Board
Descriptionsecond button does not work on A1200 with a Blizzard 1230 Turbo Board
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.0
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0004237

DanyPPC (reporter)

The problem is present only on a Rev 2B A1200 motherboard.

note ~0004242

Wepl (manager)

probably user failure...

note ~0004308

DanyPPC (reporter)

It is not a problem of my own motherboard.
All revisions A1200 2B have trouble recognizing the PAD CD32 through lowlevel.library.

Just make a test with the special tool on any motherboard REV 2B
http://aminet.net/package/util/misc/JoyPortTest [^]

Tests also confirmed by another user with the same motherboard 2B.
Thank you very much for your attention

note ~0004352

DanyPPC (reporter)

For all those who have compatibility issues with CD32 PAD use this tool

http://aminet.net/package/game/patch/SetJoyPort

to be included in the Startup-Sequence after the Setpatch

C: SetPatch QUIET
C: SetJoyPort PORT1 = JOYPAD

Now the lowlevel.library correctly reads the PAD.
Please let close this alert
+Notes

-Issue History
Date Modified Username Field Change
2015-01-05 13:39 DanyPPC New Issue
2015-01-20 22:14 DanyPPC Note Added: 0004237
2015-01-21 00:14 Wepl Note Added: 0004242
2015-01-21 00:14 Wepl Status new => closed
2015-01-22 09:02 DanyPPC Note Added: 0004308
2015-01-22 09:02 DanyPPC Status closed => feedback
2015-01-22 09:02 DanyPPC Resolution open => reopened
2015-02-03 20:57 DanyPPC Note Added: 0004352
2015-02-03 20:57 DanyPPC Status feedback => new
2015-02-12 23:49 Wepl Status new => closed
2015-02-12 23:49 Wepl Assigned To => Wepl
2015-02-12 23:49 Wepl Resolution reopened => won't fix
2016-02-09 22:04 Wepl Status closed => resolved
2016-02-09 22:04 Wepl Resolution won't fix => no change required
+Issue History