2019-11-17 16:35 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003031Obliterator[All Projects] Generalpublic2014-08-21 21:24
ReporterSal 
Assigned ToWeplProject InfoObliterator (Psygnosis)
http://www.whdload.de/games/Obliterator.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0003031: as I'm sure you know, Obliterator is a very slow running game. playing it on my
DescriptionGameVersion: english,NTSC,1 disk
SlaveVersion: 1.0 from 20.05.2000

as I'm sure you know, Obliterator is a very slow running game. playing it on my amiga 1200 is awesome, but I have to play it from the original disk. playing it on the A2000 using the CACHE Setting make the game even more playable, but the keyboard stops functioning. I can't select the control panel to change weapons. the only thing I can do with the keyboard is press Ctrl+Amiga+Amiga to reset. It even locks out the quit key for the game in WHDLoad.
How you can help with this. it's one of my favorite games.
-Sal
TagsNo tags attached.
MachineA2000
CPU68030
CPUSpeed25
ChipSetECS
GFXCardNone
ChipMem1 MB
FastMem8 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad17.2
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0004013

Wepl (manager)

please try if the attached slave fixes the keyboard problem

note ~0004014

Sal (reporter)

Worked Great.

note ~0004015

Wepl (manager)

I created a new imager too. But don't understand how saving works in that game.
Can you explain me how to save and load a game?

note ~0004016

Sal (reporter)

Last edited: 2014-07-16 22:08

View 3 revisions

you can save to a blank disk or to the game disk.

After starting a game, you can press the HELP Key to get into the Load/Save Menu.

Only one game can be saved per "save disk" or on the "game disk".

note ~0004017

Wepl (manager)

I see the load item after pressing Help. But where to save?

note ~0004018

Sal (reporter)

you can only save at re-charge stations or when you take one of the 4 pieces of the ship you're supposed to find to destroy the ship.

Example Here:

https://www.youtube.com/watch?v=nG80rfxGTuo#t=10m45s

note ~0004019

Wepl (manager)

I have changed the savegame handling a bit to make the diskimages smaller.
Could you test if saving still works with the new Slave attached?

note ~0004020

Sal (reporter)

Saving is still working with the new slave.

It's a lot more fun with the DCACHE enabled.

=)

note ~0004023

Wepl (manager)

thanks, have released the updated install package

note ~0004024

Sal (reporter)

Very Cool. I just tried to load in the new release, and it looks like my original disk of Obliterator is damaged now. (I probably Wore it out) I used to play this one non stop back in the day.

I guess the disk did pretty well considering that it is over 30 years old.

Let me know if you know someone that will sell me an extra copy of the game. =)

Thanks for the Fix.
=)

note ~0004025

Wepl (manager)

does your disk make problems at the start or in the middle? not that the imager has a problem...

note ~0004026

Sal (reporter)

In the first few tracks. I tried booking the game normally on my Amiga 500 (OS1.3) And the beginning Graphics are corrupted and the game won't finish loading anymore. Like I said, I Probably just wore out my disk. =(

note ~0004027

Wepl (manager)

ok, sounds really like a weak disk.
+Notes

-Issue History
Date Modified Username Field Change
2014-07-13 15:56 administrator New Issue
2014-07-13 15:56 administrator Status new => assigned
2014-07-13 15:56 administrator Assigned To => Wepl
2014-07-15 23:21 Wepl File Added: Obliterator.Slave
2014-07-15 23:21 Wepl Note Added: 0004013
2014-07-16 04:38 Sal Note Added: 0004014
2014-07-16 21:36 Wepl Note Added: 0004015
2014-07-16 22:07 Sal Note Added: 0004016
2014-07-16 22:07 Sal Note Edited: 0004016 View Revisions
2014-07-16 22:08 Sal Note Edited: 0004016 View Revisions
2014-07-16 22:19 Wepl Note Added: 0004017
2014-07-16 23:16 Sal Note Added: 0004018
2014-07-16 23:21 Wepl File Deleted: Obliterator.Slave
2014-07-16 23:21 Wepl File Added: Obliterator.Slave
2014-07-16 23:23 Wepl Note Added: 0004019
2014-07-16 23:47 Sal Note Added: 0004020
2014-07-22 21:43 Wepl Note Added: 0004023
2014-07-22 21:43 Wepl Status assigned => resolved
2014-07-22 21:43 Wepl Resolution open => fixed
2014-07-22 22:11 Sal Note Added: 0004024
2014-07-22 22:21 Wepl Note Added: 0004025
2014-07-22 23:45 Sal Note Added: 0004026
2014-07-23 00:01 Wepl Note Added: 0004027
2014-08-21 21:24 Wepl Status resolved => closed
+Issue History