2020-10-26 19:48 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002980Pushover[All Projects] Generalpublic2017-11-27 10:25
ReporterStellan 
Assigned ToStingRayProject InfoPushover (Red Rat Software/Ocean)
http://www.whdload.de/games/Pushover.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Summary0002980: If I start the game it switch to game screen (black screen) and then this
DescriptionGameVersion: Pre-install (Retroplay)
SlaveVersion: Slave: Version 1.21 (24.03.2014)

If I start the game it switch to game screen (black screen) and then this access fault happens:
************************* 25-Mär-14 12:24:19 ************************17.2.5386***
Slave='PushOver.Slave' (5944 bytes)
ShadowMem  1A8D5D8 -  1AE65D8 ( 364544) AbsolutMem    59000 -   200000 (1732608)
Resload    2EF3000 -  2EFA950 (  31056) at 2EF3000  GL=$2FBD000
Slave      2FC7000 -  2FC8714 (   5908) at 2FC7000  BaseMemSize=$80000
ExpMem     2EFC000 -  2FBC000 ( 786432) at 2EFC000
attn=7F(40,82) fc=-1 kn=11032 cs=2AA2 rw=0 zpt=-1 ep=0 ei=0
setcpu=3B3D(SS,BC,SB,DC,IC,SCB,ECB,BNC)
Exception "Access Fault" ($7008) PC = $4 Word Read from $ECC2AF0
$ffffffcc move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffd0 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffd4 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffd8 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffdc move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffe0 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffe4 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffe8 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$ffffffec move.l       ($2a2a,a2),d5                  ;$02fcac0d
$fffffff0 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$fffffff4 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$fffffff8 move.l       ($2a2a,a2),d5                  ;$02fcac0d
$fffffffc move.l       ($2a2a,a2),d5                  ;$02fcac0d
$00000000 ori.b        #0,d0
$00000004 cmp2.w       (-$34,a3,a4.l*4),a4            ;$0ecc2af0
$0000000a mulu         a4,d6
$0000000c mulu         a4,d6
$0000000e mulu         a4,d6
$00000010 mulu         a4,d6
$00000012 mulu         a4,d6
$00000014 mulu         a4,d6
$00000016 mulu         a4,d6
$00000018 mulu         a4,d6
$0000001a mulu         a4,d6
$0000001c mulu         a4,d6
$0000001e mulu         a4,d6
$00000020 chk2.w       (-$3334,a7),a4                 ;$02fb8c88
$00000026 mulu         a4,d6
$00000028 mulu         a4,d6
exception stackframe:
$02FBBFBC 23040000 00047008 02FBBFBC 05450005 00450005 0ECC2AF0 02F4B464 00000001
$02FBBFDC 02F44648 02FC81E3 02F5BD84 02F59B68 02F44C9A 02F40CC0 0000A300
regular stack:
$02FBBFF8 000802F4 8D0E006C
  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx     A300    BD1351       3ED      1778         3        3E    BD0D7D   2F40009
Ax  2F3DE50   2F44648   2FC81E3   2F5BD84   2F59B68   2F44C9A   2F40CC0
                 TTSM III   XNZVC
PC=       4  SR %0010001100000100  USP=2F44C4E  ISP=2FBBFBC  MSP=7F800
VBR=2FBE000  SFC=5  DFC=5  CACR=80008000  
TC=8000  URP=02EF1000  SRP=02EF1000  MMUSR=00000000
DTT0=00000000  DTT1=00000000  ITT0=00000000  ITT1=00000000
         MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
intena=%0110000001101100 dmacon=%0010001111010000 adkcon=$1100
intreq=%0000000000100000
vposr....A300  vhposr...0284  joy0dat..0700  joy1dat..0000  clxdat...8023  
pot0dat..0000  pot1dat..0000  potinp...5500  serdatr..3800  dskbytr..A000  
deniseid.00F8  hhposr...FF4F  
   ciaa:     PI ROPS     ciab:     PI ROPS
 cra=00000000  ta=21FF<21FF    cra=00000000  ta=FFFF<FFFF
     AII ROPS       AII ROPS
 crb=00001000  tb=C87A<FFFF    crb=10000000  tb=FFFF<FFFF
     10RTWCLO   parallel     DRCCDSOY      M3210HDS
 pra=11111100  prb=10011001      pra=11111111  prb=11111111
       ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
       event=000045  icr=00  sdr=00    event=000273  icr=04  sdr=00
TagsNo tags attached.
MachineA1200
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftSelfmade
WHDLoad17.2
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0003804

StingRay (developer)

Please use WHDLoad's "Filelog" option and attach the file ".whdl_filelog" here, my guess is that the problem is on your end (correct MaxTransfer settings?) and has nothing to do with the patch.

note ~0003810

Stellan (reporter)

I`m using (since >10 years) a IDE HD at FastATA controller with SFS. MaxTransfer = 0xfffe00 and Mask = 0x7ffffffc. There shouldn`t any problem with this settings. Copy large files works fine. The old slave by Harry works (with timing issues). Here the filelog:

***** 26-Mär-14 14:26:09 ***** PushOver.Slave ***** 17.2.5386 *****
[Examine] buf=$2F35B20 type= 2 size=$ 0= 0 rc=0 name=
[Examine] buf=$2F35C78 type= 0 size=$ 0= 0 rc=205 name=LIBS
[Examine] buf=$2F35CB8 type= 0 size=$ 0= 0 rc=205 name=DEVS
[Examine] buf=$2F35CF8 type= 0 size=$ 0= 0 rc=205 name=FONTS
[Examine] buf=$2F35D28 type= 0 size=$ 0= 0 rc=205 name=C
[Examine] buf=$2F35D60 type= 0 size=$ 0= 0 rc=205 name=L
[Examine] buf=$2F35D98 type= 0 size=$ 0= 0 rc=205 name=S
[Examine] buf=$2F3AC98 type= 0 size=$ 0= 0 rc=205 name=system-configuration
[Examine] buf=$2F3DF20 type=-3 size=$19AC0=105152 rc=0 name=ant
[ReadOff] crc=1A64 dest=$2F3E010 size=$ 1000= 4096 name=ant offset=$ 0
[ReadOff] crc=8F78 dest=$2F3FFF4 size=$12B6C= 76652 name=ant offset=$ 1000
[ReadOff] crc=BC06 dest=$2F3E010 size=$ 1000= 4096 name=ant offset=$13B6C
[ReadOff] crc=C1DC dest=$2F3E010 size=$ 1000= 4096 name=ant offset=$14B6C
[ReadOff] crc=2695 dest=$2F5A014 size=$ 13B0= 5040 name=ant offset=$15B6C
[ReadOff] crc=E200 dest=$2F3E010 size=$ 1000= 4096 name=ant offset=$16F1C
[ReadOff] crc=7331 dest=$2F53B58 size=$ 11E4= 4580 name=ant offset=$17F1C
[ReadOff] crc=5E1A dest=$2F3E010 size=$ 9C0= 2496 name=ant offset=$19100

note ~0003826

StingRay (developer)

Checkums are OK but I still suspect a problem at your end as you're the only one who has such problems. Please send me your complete installed game and I will have (a short!) look.

note ~0003827

Denis (reporter)

@Stellan : Correct MaxTransfer when using SFS is = 0x1fe00 ;

You use MaxTransfer (as you stated above) = 0xFFFE00 which is wrong, SFS can't work out correctly.

note ~0003829

Stellan (reporter)

I downloaded PushOver_v1.21_1267.lha again (Retroplays pre-install) from ftp in hope that my first download was corrupt. Unfortunately the problem stays. Further, I replaced all files from Retroplays pre-install with the old install by Harry. Result is the game works. So the files seems to be ok. Makes it still sense to send you my install?

Does the game unpack propacked file itself or does whdload the unpack? I ask because I noticed to unpack it need a 16bit key. So XAD/XFD fail unpacking. On the other hand the old slave (Harry) work. Seems not the problem.

Btw your install is new. How many have tried it. So it is possible the I`m not alone with the problem.

@Denis:
MaxTransfer is independant from used filesystem. The device has to support this. My HD support the value and copy large files works fine. The people say that CF have problems with to high MaxTransfer.

note ~0003830

StingRay (developer)

Last edited: 2014-04-03 17:22

View 3 revisions

As I have no other way to check what's going on you will have to send me your installed game! And the new patch has been tested by quite a few people meanwhile, no one encountered such a problem so I still suspect a problem at your end.

Also, as for MaxTransfer, not the hardware but the device driver has to handle it correctly and the standard scsi.device doesn't! And it's also not true that only CF cards are affected by wrong MaxTransfer settings!

note ~0003831

Denis (reporter)

@stellan : I have a real 2.5 inch hard drive into my A1230, and not a CF card. the maxtransfer value you gave is the one untouched in the menu when you install the SFS filesystem. If i use this value, most of my whdload games or standard installed games will crash or won't behave correctly. 0x1FE00 is the only known good value. The other one doesn't work, believe me, i had the same problem as yours when i used SFS on my hard-drive. 0xFFFE00 is a value NOT to be USED ! Check on EAB forum about the problems recurrent about it.

I have tested Stingray's push over install from A to Z, no errors shows up (aside the level 100 not showing, but it's not tied to the file system).

note : You can't decrunch the push-over files because those were key-locked by the programmer, only the internal decrunch routines can do that.

Around 10 peoples me included have tested the new slave, and it works better than the old one.

note ~0003834

Irek (reporter)

@Stellan: Have you tried it with NOCACHE option?
Without NOCACHE opt. the game crashes after the start with a similar error on my setup A-1200/40/25.( see below)

************************* 04-Apr-14 17:59:46
************************17.2.5386***
Slave='PushOver.Slave' (5944 bytes)
ShadowMem 68549008 - 685AE008 ( 413696) AbsolutMem 65000 - 80000 (
110592)
Resload 6BF29000 - 6BF30950 ( 31056) at 6BF29000 GL=$6BFF3000
Slave 6BFFC000 - 6BFFD714 ( 5908) at 6BFFC000 BaseMemSize=$80000
ExpMem 6BF32000 - 6BFF2000 ( 786432) at 6BF32000
attn=7F(40,82) fc=-1 kn=10371 cs=2AA2 rw=0 zpt=-1 ep=0 ei=0
setcpu=3B3D(SS,BC,SB,DC,IC,SCB,ECB,BNC)

Exception "Address Error" ($200C) at $4 occured.

$ffffffcc move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffd0 move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffd4 move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffd8 move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffdc move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffe0 move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffe4 move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffe8 move.l ($2a2a,a2),d5 ;$6bfffc0d
$ffffffec move.l ($2a2a,a2),d5 ;$6bfffc0d
$fffffff0 move.l ($2a2a,a2),d5 ;$6bfffc0d
$fffffff4 move.l ($2a2a,a2),d5 ;$6bfffc0d
$fffffff8 move.l ($2a2a,a2),d5 ;$6bfffc0d
$fffffffc move.l ($2a2a,a2),d5 ;$6bfffc0d
$00000000 ori.b #0,d0
$00000004 bmi.b $fffffffd
$00000006 move.l (-$34,a6,a4.l*4),a1 ;$1bdb5a2c
$0000000a mulu a4,d6
$0000000c mulu a4,d6
$0000000e mulu a4,d6
$00000010 mulu a4,d6
$00000012 mulu a4,d6
$00000014 mulu a4,d6
$00000016 mulu a4,d6
$00000018 mulu a4,d6
$0000001a mulu a4,d6
$0000001c mulu a4,d6
$0000001e mulu a4,d6
$00000020 bmi.b $15
$00000022 move.l a6,-(a4) ;$6bf8fb68

exception stackframe:
$6BFF1FEC 23080000 0004200C FFFFFFFC
regular stack:
$6BFF1FF8 00006BF7 ED02006C

----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6----
----7----
Dx 196 1AFDEB51 3ED 1778 3 3E 1AFDE57D
6BF70009
Ax 6BF73E50 6BF7A648 6BFFD1E3 6BF91D84 6BF8FB68 6BF7AC9A 6BF76CC0

TTSM III XNZVC
PC= 4 SR %0010001100001000 USP=6BF7AC4E ISP=6BFF1FEC
MSP=7F800
VBR=6BFF4000 SFC=5 DFC=5 CACR=80008000
TC=8000 URP=6BF27000 SRP=6BF27000 MMUSR=00000000
DTT0=00000000 DTT1=00000000 ITT0=00000000 ITT1=00000000

MEDRAAAABVCPSDT YZ PMRCBSDAAAA
intena=%0110000001101100 dmacon=%0010001111010000 adkcon=$1100
intreq=%0000000000100000
vposr....A300 vhposr...02A5 joy0dat..0302 joy1dat..0000 clxdat...8023
pot0dat..7700 pot1dat..0000 potinp...5500 serdatr..3BFF dskbytr..A000
deniseid.00F8 hhposr...FF34
ciaa: PI ROPS ciab: PI ROPS
cra=00000000 ta=21FF<21FF cra=00000000 ta=FFFF<FFFF
AII ROPS AII ROPS
crb=00001000 tb=C882<FFFF crb=10000000 tb=FFFF<FFFF
10RTWCLO parallel DRCCDSOY M3210HDS
pra=11111100 prb=11111111 pra=11111111
prb=11111111
ddra=00000011 ddrb=00000000 ddra=11000000
ddrb=11111111
event=000049 icr=00 sdr=00 event=00013A icr=04 sdr=00

note ~0003835

Stellan (reporter)

Thanks for the hint Irek! I tried it already with NOCACHE and other tooltypes but maybe I did a typo. However, with NOCACHE the game works. Does this happen only on 040 systems? Denis, have some of the tester a 040 system?

The install by Harry works with NOCACHE and without but don`t use V1.3 kickstart and only chipram. So I guess some difference in the slaves cause the "Access Fault" but only StingRay can say/know it.

Offtopic:
I know the MaxTransfer problem. You can read it everywhere in the forums (what poped up suddenly years ago). Especially in conjunction with WHDLoad it comes popular. My system is save (FastATA controller with ata3.driver, SFS and HD). Never had any problems and also tested ok with MaxTransTest by Thomas Rapp. I never used the onboard IDE and original scsi.device what was always very limited.

note ~0003850

StingRay (developer)

I have reproduced this problem on one of my 060 A4000's now, not sure why it happens yet but once I find the reason the patch will be updated.

note ~0003853

StingRay (developer)

Fixed... Problem was caused by self-modifying code in the interrupt setup.

note ~0003855

StingRay (developer)

Updated patch which fixes the problem is now available on the WHDLoad site.

note ~0003858

Stellan (reporter)

Strange behaviour with Version 1.22 here. With NOCACHE it works like the previous version. Without NOCACHE it random start the game or the attached access fault happens. Further, the title music (not intro music. Is skipped here) playback is wrong. It seems some samples aren`t played or not ever or too short. E.g. the bass sample at the beginning isn`t played always (maybe low note problem?). Sorry, it`s difficult to explain. I never noticed such music faults.

ps: I guess it isn`t important but with skip intro tooltype, the first sample from the intro music is played for about 0,3 seconds just before the language menu appears.

note ~0003859

StingRay (developer)

Try attached slave and see if it fixes these problems.

note ~0003862

Stellan (reporter)

Unfortunately, the new slave don`t fix it.

note ~0003863

StingRay (developer)

I have found the culprit, there is a buggy DMA wait routine in the game and I also detected two other CPU dependent delay loops. Update will be available in the next days.

note ~0004887

Stellan (reporter)

Do you have already finished the update and forgot to release or you still need to do the fix? However, I would like to test a new slave. :-)

note ~0005335

StingRay (developer)

Please try the attached slave, I have fixed 3 CPU dependent delay loops in the sample players.

note ~0005336

retrogamer (reporter)

I have attached the game manual to Push Over. If you are going to update the patch please can you include it to the install package?
+Notes

-Issue History
Date Modified Username Field Change
2014-03-25 20:21 administrator New Issue
2014-03-25 20:21 administrator Status new => assigned
2014-03-25 20:21 administrator Assigned To => StingRay
2014-03-26 08:34 StingRay Note Added: 0003804
2014-03-26 14:51 Stellan Note Added: 0003810
2014-04-01 20:37 StingRay Note Added: 0003826
2014-04-03 12:25 Denis Note Added: 0003827
2014-04-03 16:34 Stellan Note Added: 0003829
2014-04-03 17:16 StingRay Note Added: 0003830
2014-04-03 17:21 StingRay Note Edited: 0003830 View Revisions
2014-04-03 17:22 StingRay Note Edited: 0003830 View Revisions
2014-04-03 17:54 Denis Note Added: 0003831
2014-04-05 13:33 Irek Note Added: 0003834
2014-04-05 16:41 Stellan Note Added: 0003835
2014-04-11 19:34 StingRay Note Added: 0003850
2014-04-11 19:34 StingRay Status assigned => confirmed
2014-04-11 20:41 StingRay Note Added: 0003853
2014-04-11 23:02 StingRay Note Added: 0003855
2014-04-11 23:02 StingRay Status confirmed => resolved
2014-04-11 23:02 StingRay Resolution open => fixed
2014-04-12 13:02 Stellan File Added: .whdl_register_new
2014-04-12 13:05 Stellan Note Added: 0003858
2014-04-12 13:20 StingRay File Added: PushOver.slave
2014-04-12 13:21 StingRay Note Added: 0003859
2014-04-13 18:04 Stellan Note Added: 0003862
2014-04-13 22:30 StingRay Note Added: 0003863
2015-01-24 19:46 Wepl Status resolved => acknowledged
2016-02-23 14:52 Stellan Note Added: 0004887
2016-09-05 17:59 StingRay Note Added: 0005335
2016-09-05 17:59 StingRay File Deleted: PushOver.slave
2016-09-05 18:00 StingRay File Added: PushOver.slave
2016-09-05 22:58 retrogamer File Added: Manual.zip
2016-09-05 23:01 retrogamer Note Added: 0005336
2017-11-27 10:25 StingRay Status acknowledged => resolved
+Issue History