2020-02-22 01:03 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002923RickDangerous[All Projects] Generalpublic2015-04-11 12:08
ReporterTroelsDk 
Assigned ToWeplProject InfoRick Dangerous (Core Design)
http://www.whdload.de/games/RickDangerous.html
 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Summary0002923: Rick Dangerous doesn't save highscores
DescriptionAs title.

Latest version used 1.2
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem65
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad17.1
imported
Attached Files
  • png file icon 2014-04-14_2046.png (7,523 bytes) 2014-04-14 20:46 -
    png file icon 2014-04-14_2046.png (7,523 bytes) 2014-04-14 20:46 +
  • ? file icon .whdl_log (724 bytes) 2015-02-02 21:19 -
    ******* 02-Feb-15 17:23:12 ******* RickDangerous.Slave ******* 18.0.5614 *******
    [0000] [ReadDec] crc=1A3D  dest=$  152E0  size=$4C000=311296  packed=311296  name=RickDangerous
    [0001] [GetLen]  size=$   F2=   242  name=RickDangerous.hi
    [0002] [Read]    crc=6A13  dest=$  423F4  size=$   F2=   242  name=RickDangerous.hi
    [0003] [Write]   crc=5568   src=$  423F4  size=$   F2=   242  name=RickDangerous.hi
    ******* 02-Feb-15 17:30:09 ******* RickDangerous.Slave ******* 18.0.5614 *******
    [0000] [ReadDec] crc=1A3D  dest=$  152E0  size=$4C000=311296  packed=311296  name=RickDangerous
    [0001] [GetLen]  size=$   F2=   242  name=RickDangerous.hi
    [0002] [Read]    crc=5568  dest=$  423F4  size=$   F2=   242  name=RickDangerous.hi
    ? file icon .whdl_log (724 bytes) 2015-02-02 21:19 +
  • ? file icon RickDangerous.Slave (656 bytes) 2015-02-11 22:57

-Relationships
+Relationships

-Notes

note ~0003802

Lucas (reporter)

Hmmm, RickDangerous.hi file saving properly, but loading doesn't work.
Maybe unsupported "SavePath/SaveDir" ?

note ~0003806

StingRay (developer)

There is a check for the length of the hiscore file in the source, it needs to be $f2 (242) bytes long, if the file has any other length it won't be loaded. Also, why is this a major error? It's not like the game is unplayable just because the highscore can't be loaded...

note ~0003809

Lucas (reporter)

Last edited: 2014-03-26 11:51

View 6 revisions

> There is a check for the length of the hiscore file in the source, it needs to be $f2 (242) bytes long, if the file has any other length it won't be loaded.
it is the size of my file :)

> Also, why is this a major error
Imvho if game has a score counter - saving it is important.

note ~0003865

Lucas (reporter)

Last edited: 2014-04-14 21:10

View 4 revisions

UPDATE: Highscore are loading, but just the score without nick (2014-04-14_2046.png)

note ~0003867

Codetapper (developer)

I'll see if I have time tonight to look into it. I did a quick test with one version and was able to replicate the problem, so hopefully it's a simple fix.

note ~0004135

TroelsDk (reporter)

Any chance for a fix? :D

note ~0004341

Wepl (manager)

Please set option FileLog and play game with entering a score. Please attach the created .whdl_log file here.

note ~0004342

TroelsDk (reporter)

I set the tooltype "FileLog", but where is the file .whdl_log?

note ~0004343

Wepl (manager)

See http://whdload.de/docs/en/dump.html#FileLog
On pre 18.0 version it's called .whdl_filelog.

note ~0004344

TroelsDk (reporter)

Okay, found it in C:, now attached.

note ~0004408

Wepl (manager)

Please try the attached Slave. It should work now. Previously it saved before the name was copied to the high score table.

note ~0004409

TroelsDk (reporter)

Tested, and the highscore survived a reboot :)

Thanks for the fix! :D

note ~0004415

Wepl (manager)

New install package has been released.
+Notes

-Issue History
Date Modified Username Field Change
2014-01-17 02:47 TroelsDk New Issue
2014-01-17 20:33 Wepl Project WHDLoad => RickDangerous
2014-01-17 20:35 Wepl Assigned To => Codetapper
2014-01-17 20:35 Wepl Status new => assigned
2014-03-25 02:23 Lucas Note Added: 0003802
2014-03-26 08:50 StingRay Note Added: 0003806
2014-03-26 11:18 Lucas Note Added: 0003809
2014-03-26 11:31 Lucas Note Edited: 0003809 View Revisions
2014-03-26 11:31 Lucas Note Edited: 0003809 View Revisions
2014-03-26 11:45 Lucas Note Edited: 0003809 View Revisions
2014-03-26 11:46 Lucas Note Edited: 0003809 View Revisions
2014-03-26 11:51 Lucas Note Edited: 0003809 View Revisions
2014-04-14 20:46 Lucas File Added: 2014-04-14_2046.png
2014-04-14 20:47 Lucas Note Added: 0003865
2014-04-14 21:05 Lucas Note Edited: 0003865 View Revisions
2014-04-14 21:10 Lucas Note Edited: 0003865 View Revisions
2014-04-14 21:10 Lucas Note Edited: 0003865 View Revisions
2014-04-16 03:50 Codetapper Note Added: 0003867
2014-12-21 11:33 TroelsDk Note Added: 0004135
2015-02-01 23:44 Wepl Note Added: 0004341
2015-02-02 17:32 TroelsDk Note Added: 0004342
2015-02-02 20:17 Wepl Note Added: 0004343
2015-02-02 21:19 TroelsDk File Added: .whdl_log
2015-02-02 21:20 TroelsDk Note Added: 0004344
2015-02-06 12:26 Wepl Assigned To Codetapper => Wepl
2015-02-11 22:57 Wepl File Added: RickDangerous.Slave
2015-02-11 22:59 Wepl Note Added: 0004408
2015-02-12 11:19 TroelsDk Note Added: 0004409
2015-02-13 18:59 Wepl Note Added: 0004415
2015-02-13 18:59 Wepl Status assigned => resolved
2015-02-13 18:59 Wepl Resolution open => fixed
2015-04-11 12:08 Wepl Status resolved => closed
+Issue History