2019-12-13 10:54 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002605WingsOfFury[All Projects] Generalpublic2019-11-09 18:08
ReporterStellan 
Assigned ToCFOUProject InfoWings of Fury (Brøderbund)
http://www.whdload.de/games/WingsOfFury.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0002605: In Captain Mission 3 the game exit to its own WB OS screen (yellow and black
DescriptionGameVersion: pre-install
SlaveVersion: Version 1.0 (22.11.2001)

In Captain Mission 3 the game exit to its own WB OS screen (yellow and black with the plane mouse pointer) when I lose a live (plane crash). If I finish mission 2 and mission 3 should load the same happend. I also got an access fault but only once (see below).

I`ve a savegame position of this situation. So it could be easy reproduce. I can upload it if wisched. If my disk image is faulty I would also test a working version.

************************* 15-Jun-12 15:57:46 ************************17.1.5163***
Slave='WingsOfFury.slave' (1332 bytes)
ShadowMem  1AEAD20 -  1B31D20 ( 290816) AbsolutMem    47000 -    80000 ( 233472)
Resload    2F87000 -  2F8E630 (  30256) at 2F87000  GL=$2FD1000
Slave      2FDA000 -  2FDA510 (   1296) at 2FDA000  BaseMemSize=$80000
ExpMem     2F90000 -  2FD0000 ( 262144) at 2F90000
attn=7F(40,82) fc=-1 kn=11032 cs=4AD7 rw=0 zpt=-1 ep=1 ei=0
setcpu=0(SNCS,ENCS,BNCS)

Exception "Access Fault" ($7008) PC = $2F92DF4 (Task 'CON', ExpMem $2DF4) Word
Read from $4CCC2D20

$02f92dc6 beq.b        $2f92db8
$02f92dc8 move.l       d0,a1
$02f92dca jsr          (-$17a,a6)                     ;$000004fc
$02f92dce bra.b        $2f92db8
$02f92dd0 lea          ($10,a0),a1                    ;$4ccc2d04
$02f92dd4 move.l       a1,(a1)                        ;$0000f710
$02f92dd6 addq.l       #4,(a1)                        ;$0000f710
$02f92dd8 clr.l        (4,a1)                         ;$0000f714
$02f92ddc move.l       a1,(8,a1)                      ;$0000f718
$02f92de0 clr.l        ($28,a0)                       ;$4ccc2d1c
$02f92de4 clr.w        ($e,a0)                        ;$4ccc2d02
$02f92de8 move.w       #$ffff,($2c,a0)                ;$4ccc2d20
$02f92dee rts
$02f92df0 addq.b       #1,($127,a6)                   ;$0000079d
$02f92df4 addq.w       #1,($2c,a0)                    ;$4ccc2d20
$02f92df8 bne.b        $2f92e02
$02f92dfa move.l       ($114,a6),($28,a0)             ;$0000078a $4ccc2d1c
$02f92e00 bra.b        $2f92e36
$02f92e02 movem.l      d0-d1/a0-a1,-(a7)              ;$0000cfb0
$02f92e06 move.l       ($114,a6),a1                   ;$0000078a
$02f92e0a cmpa.l       ($28,a0),a1                    ;$4ccc2d1c
$02f92e0e beq.b        $2f92e32
$02f92e10 lea          (-$c,a7),a7                    ;$0000cfa4
$02f92e14 move.l       a1,(8,a7)                      ;$0000cfb8
$02f92e18 bclr         #4,($1d,a1)                    ;$0000f72d
$02f92e1e lea          ($10,a0),a0                    ;$4ccc2d04
$02f92e22 move.l       a7,a1
$02f92e24 bsr.w        $2f91624
$02f92e28 moveq        #$10,d0

exception stackframe:
$0007FFC4 001502F9 2DF47008 0000CFE8 054100A1 00410021 4CCC2D20 0000079D 00000600
$0007FFE4 00000005 0000080C 0000C470 00000676 02FC4134 001002F9 08F40064
regular stack:
$0000CFB0 02F9639C 0000221E 02FB7368 02FB62CA 00004628 02FC4134 02FB737A 0000000C
$0000CFD0 0000C19C 00000005 00000052 00000057 0000A620 0000C750 02FC4520 02FB4D0A
$0000CFF0 0000C704 02FCA6B6 02F90714 00000676 02FC453A 00000000 0000C820 02FC4134
$0000D010 02FC4128 02FC446E 434F4E00 00000000 00016AE0 00009A38 4EF90001 75304EF9
$0000D030 00017536 4EF90001 773E4EF9 0001773E 4EF90001 78D64EF9 00017D50 4EF90001

  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx      2D4      C750         C      C19C         5        52        57      C4CC
Ax 4CCC2CF4      F710     17020      C750   2FC4520  4CCC2CAC       676

                 TTSM III   XNZVC
PC= 2F92DF4  SR %0000000000010101  USP=CFB0  ISP=7FFC4  MSP=7F800
VBR=2FD2000  SFC=5  DFC=1  CACR=0  
TC=8000  URP=02F85000  SRP=02F85000  MMUSR=00000000
DTT0=00000000  DTT1=00000000  ITT0=00000000  ITT1=00000000

         MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
intena=%0110000001101100 dmacon=%0000001111110000 adkcon=$1100
intreq=%0000000000000001
vposr....A300  vhposr...0297  joy0dat..0203  joy1dat..0000  clxdat...8023  
pot0dat..0B00  pot1dat..0000  potinp...5500  serdatr..3800  dskbytr..A000  
deniseid.00F8  hhposr...FFE2  
   ciaa:     PI ROPS		   ciab:     PI ROPS
    cra=00000001  ta= 249<38FF	   cra=00000000  ta=FFFF<FFFF
        AII ROPS			    AII ROPS
    crb=00001000  tb=17A7<17A7	   crb=10000000  tb=FFFF<FFFF
        10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    pra=11111100  prb=11111000      pra=11111111  prb=11111111
       ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
       event=00222D  icr=00  sdr=98    event=00013A  icr=00  sdr=00
TagsNo tags attached.
MachineA1200
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftSelfmade
WHDLoad17.1beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0006173

Stellan (reporter)

Another oldi.

note ~0007250

CFOU (developer)

Can you test new version (RNC encrypted version supported)?

 version 1.x beta (31.10.18) done by C-Fou!:
 - Another version encrypted by RNC supported (SPS 599)
 - slave rewritten for last Kick13
 - files installation instead of disk image
   (Warning, you need re-install game)
 - new install script


PS: you game crash again, can you send to me tour save game? and dump files?

note ~0007255

CFOU (developer)

new beta with trainer
 - Custom1=1 used to actived cheat mode at start
    In Game Cheat keys:",10
    ------------------",10
    P: Add plane | M: Add weapons
    C: Change weapon | D: add Oil/Damage
    F: Add Fuel | Q: Quit game
    Spc: Memory info | Help: Isle info
    I: restore weapons
        Change physic keys:
    2-4: -/+ wind | 6-8: -/+ gravity
                       (bomb can flight!)

note ~0007257

CFOU (developer)

missing slave

note ~0007273

CFOU (developer)

slave completly rewritten to test

note ~0007329

Stellan (reporter)

This issue can be closed. At least the described access fault I couldn't reproduce. If I get another problem I'll open a new bug report.

Thanks for fixing this oldie!

note ~0007330

CFOU (developer)

fixed
+Notes

-Issue History
Date Modified Username Field Change
2012-07-14 22:11 administrator New Issue
2012-07-14 22:11 administrator Status new => assigned
2012-07-14 22:11 administrator Assigned To => CFOU
2018-04-29 02:32 Stellan Note Added: 0006173
2019-10-31 18:32 CFOU File Added: WingsOfFuryBeta.lha
2019-10-31 18:32 CFOU Note Added: 0007250
2019-11-01 18:50 CFOU File Added: WingsOfFuryBeta2.lha
2019-11-01 18:50 CFOU Note Added: 0007255
2019-11-01 19:08 CFOU File Added: WingsOffuryBeta3.lha
2019-11-01 19:08 CFOU Note Added: 0007257
2019-11-03 21:49 CFOU Status assigned => resolved
2019-11-03 21:49 CFOU Resolution open => fixed
2019-11-03 21:49 CFOU Note Added: 0007273
2019-11-09 18:03 Stellan Note Added: 0007329
2019-11-09 18:08 CFOU Status resolved => closed
2019-11-09 18:08 CFOU Note Added: 0007330
+Issue History