2019-12-09 21:34 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002574Flashback[WHDLoad Installs Games] slavepublic2013-12-23 16:48
ReporterRetroplay 
Assigned ToPsygoreProject InfoFlashback (Delphine Software)
http://www.whdload.de/games/Flashback.html
 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
Summary0002574: Flashback level 2 exception error
DescriptionGame: Flashback, SPS 1163.
Slave: v3.2 (http://www.whdload.de/games/Flashback.html)
WHDLoad 17.1.5175

I got an "Exception "Privilege Violation" ($20) at $9128F6 (ExpMem $8F6) occured." error when I accepted the final mission, where I have to hunt down and kill the mutants in "Restricted Area 3"

Complete .whdl dump here:
http://www.mediafire.com/?si5eq0zwym9h5xs
Steps To ReproduceAccept the final mission with the work permit.
TagsNo tags attached.
MachineA1200
CPU68EC020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 3.1
KickROM39 - Kick 3.0
KickSoftNone
WHDLoad17.1beta
imported
Attached Files

-Relationships
related to 0002094closedWepl WHDLoad "privilege violation" at expmem+$8f6 
+Relationships

-Notes

note ~0002654

Retroplay (reporter)

I installed the game using SPS 1885 images instead and the error doesn't occur anymore.
I do get flickering graphics occasionally though.

note ~0003455

Psygore (developer)

Attached the lastest slave.
Pls try it and let me know if there is a prob.
It supports CD32 joypad buttons, see:
http://eab.abime.net/project-whdload/67693-request-flashback-cd32-pad-support.html

note ~0003456

Retroplay (reporter)

Ok I tried SPS 1163 again, the version I got a crash in earlier and this time there's no problems at all.

I don't have a CD32 controller, so unfortunately I can't test that, but everything else seems to work fine.

note ~0003459

Retroplay (reporter)

The Italian version does not work anymore with the new slave.

See here:
http://eab.abime.net/911118-post20.html

note ~0003462

Psygore (developer)

Thanks for testing.
For Italian version, the 'flashback' main executable must be depacked (packed with Imploder).
I tried the polish version again, it works for me (at least level 1 & 2).

note ~0003463

Retroplay (reporter)

Thanks Italian version works.

The Polish version still gives me a damaged/unsupported files error after depacking main 'flashback' executable.

File sizes:
'flashback' packed: 83420
'flashback' depacked: 190628

I have attached a full core dump just in case.

note ~0003464

Retroplay (reporter)

Here's the Polish translated version I have :
http://www.mediafire.com/download/351z9mkypxnvdrx/Flashback_Polish.zip

Oh the Czech translated version works great btw.

note ~0003465

Psygore (developer)

I thought you meant the cz version doesn't work.
Attached slave beta3, it supports the polish version.
I added custom4=1 option to slowdown the anim sequence.

note ~0003468

Retroplay (reporter)

Thank you, everything is working now.

Oh and thanks for auto-skipping the code screen.

note ~0003517

Psygore (developer)

New install available.

note ~0003520

Retroplay (reporter)

Merci.
+Notes

-Issue History
Date Modified Username Field Change
2012-04-05 21:42 Retroplay New Issue
2012-04-07 11:34 Wepl Project WHDLoad Installs Games => Flashback
2012-04-07 18:37 Retroplay Note Added: 0002654
2013-09-15 15:19 Psygore Assigned To => Psygore
2013-09-15 15:19 Psygore Status new => assigned
2013-09-15 15:20 Psygore File Added: Flashback33b2.lha
2013-09-15 15:24 Psygore Note Added: 0003455
2013-09-15 17:57 Retroplay Note Added: 0003456
2013-09-15 23:01 Retroplay Note Added: 0003459
2013-09-16 21:19 Psygore Note Added: 0003462
2013-09-16 22:07 Retroplay File Added: Flashback_Polish_whdl_dump.rar
2013-09-16 22:10 Retroplay Note Added: 0003463
2013-09-16 22:40 Retroplay Note Added: 0003464
2013-09-17 16:10 Psygore File Added: Flashback33b3.lha
2013-09-17 16:15 Psygore Note Added: 0003465
2013-09-17 16:41 Retroplay Note Added: 0003468
2013-10-26 22:18 Psygore Note Added: 0003517
2013-10-26 22:18 Psygore Status assigned => resolved
2013-10-26 22:18 Psygore Resolution open => fixed
2013-10-27 00:33 Retroplay Note Added: 0003520
2013-12-19 00:15 Psygore Status resolved => closed
2013-12-23 16:48 Wepl Relationship added related to 0002094
+Issue History