2024-02-26 05:43 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002568TeamYankee[All Projects] Generalpublic2015-07-14 11:20
ReporterTony Burnell 
Assigned ToStingRayProject InfoTeam Yankee (Empire)
http://www.whdload.de/games/TeamYankee.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
Summary0002568: Team Yankee V1.0 02/02/12 Problem: Erratic mouse problem on language selection
DescriptionGameVersion: english,pal,1 disks
SlaveVersion: v1.0 from 02.02.2012


Team Yankee V1.0 02/02/12
Problem:
Erratic mouse problem on language selection screen. Can be corrected by using nocache tooltype.
When you go to play the game by clicking on the crossed swords and selecting play, the game starts but after about 10 seconds it crashes with the following error message:
Exception “Privilege Violation” ($20)
at $1BE8F6 (Task `input.device`, ExpMem $8F6) occured.
I have tried all tooltype mentioned in the ReadMe.
Please could you help.
Regards Tony.
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.5
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad17
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0002722

StingRay (developer)

What is your config? Real Amiga or UAE? If you're using UAE make sure JIT is disabled.

note ~0002723

Tony Burnell (reporter)

Hi StingRay,

What is your config? Real Amiga or UAE? If you're using UAE make sure JIT is
disabled.

My Configuration is:

Real Amiga 1200 2MB.

Blizzard 1230 IV Accelerator 32MB Ram.

Kickstart 3.1 ROMs.

Workbench OS 3.5.

Joypad CD32 Competition Pro By Honeybee.

I have the Team Yankee game Disks.

I noted in the readme that you said there was a problem with the slave with 68040 and 68060 processors.

So perhaps it is something to do with the 68030 processor.

One other point is I downloaded Pacific Island installed whdload to try and this has exactly the same problem.

Regards

Tony

note ~0002736

StingRay (developer)

Hi Tony,

I'm not surprised that Pacific Islands has the same problem, the code is almost 100% identical to Team Yankee. Didn't have time to check yet but I'll try to reproduce and fix the problem on my machine. Might take a while though as I'm currently busy with other things.

Regards,
Sting

note ~0003522

who (reporter)

Same problem here on winuae. 020 config, JIT disabled, cycle-exact enabled.

As soon as you fire a couple of shots:
Privilege Violation ($20)
at $17FB58F6 (Task `file.system`, ExpMem $8F6)

note ~0004600

StingRay (developer)

This was a problem with KickEmu slaves+WHDLoad which has been fixed in the latest WHDLoad version. The crashes should be fixed, at least I couldn't reproduce them when using the latest WHDLoad version. If there still are problems just reopen this ticket.
+Notes

-Issue History
Date Modified Username Field Change
2012-03-26 21:32 administrator New Issue
2012-03-26 21:32 administrator Status new => assigned
2012-03-26 21:32 administrator Assigned To => StingRay
2012-04-28 13:49 StingRay Note Added: 0002722
2012-04-28 20:07 Tony Burnell Note Added: 0002723
2012-05-16 08:16 StingRay Note Added: 0002736
2013-11-11 10:16 who Note Added: 0003522
2015-07-14 11:20 StingRay Note Added: 0004600
2015-07-14 11:20 StingRay Status assigned => resolved
2015-07-14 11:20 StingRay Resolution open => no change required
+Issue History