2019-12-08 03:35 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002299OilImperium[All Projects] Generalpublic2014-06-15 16:17
Reporter1time 
Assigned ToWeplProject InfoOil Imperium (reLINE)
http://www.whdload.de/games/OilImperium.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0002299: After i have been playing for 20 minutes i ALWAYS crash our to my workbench. I
DescriptionGameVersion: Using version 1.1 from KillerGorillas pack.
SlaveVersion: Using version 1.1 from KillerGorillas pack.

After i have been playing for 20 minutes i ALWAYS crash our to my workbench. I have tried different accelerators and removed all my hardware addons, nothing works.
I have made a post on English Amiga Board with some links to the logfiles.
http://eab.abime.net/showthread.php?t=53253
Please help me. I love this game =)
Regards
Robert Sjunnesson
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem42 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad16.9
importedyes
Attached Files
  • ? file icon oil.whdl_register (5,692 bytes) 2014-01-04 12:19 -
    ************************* 10-Oct-10 11:19:05 ************************16.9.4672***
    Slave='OilImperium.slave' (5532 bytes)
    ShadowMem 164D6A08 - 1653FA08 ( 430080) AbsolutMem    69000 -    90000 ( 159744)
    Resload   17FA0000 - 17FA8CFC (  36092) at 17FA0000  GL=$17FF3000
    Slave     17FFC000 - 17FFD578 (   5496) at 17FFC000  BaseMemSize=$90000
    ExpMem    17FAA000 - 17FF2000 ( 294912) at 17FAA000
    attn=7(30) fc=4 kn=21679 cs=92B9 rw=0 zpt=-1 ep=0 ei=0
    setcpu=3B3D(SS,BC,SB,DC,IC,SCB,ECB,BNC)
    
    Exception "Privilege Violation" ($20) at $17FAA8F6 (ExpMem $8F6) occured.
    
    $17faa8ea pea          ($17faa8f4)
    $17faa8f0 move         sr,-(a7)                       ;$17fed72a
    $17faa8f2 jmp          (a5)                           ;$17fea240
    $17faa8f4 rts
    $17faa8f6 ori          #$2000,sr
    $17faa8fa subq.l       #8,a7
    $17faa8fc move         sr,(a7)                        ;$17fed72a
    $17faa8fe move.l       #$17faa8f4,(2,a7)              ;$17fed72c
    $17faa906 move.w       #$20,(6,a7)                    ;$17fed730
    
    exception stackframe:
    $17FF1FF8 001017FA A8F60020
    regular stack:
    $17FED72A 17FABF4C 17FCFF3C 17FABD28 17FEC68C 17FEA276 17FEDED6 00000000 17FEDA4A
    $17FED74A 00000000 00000000 00000400 00000000 001E17FE C6E217FE D7640000 000017FE
    $17FED76A D7600000 00000000 06000000 00000000 00003DA5 6216000D 79F617FE E8C617FE
    $17FED78A C3660500 00000000 17FED74C 000017FE C2EE17FE C3660009 00000000 00000000
    $17FED7AA EA600000 00000200 00FF8000 FFF80000 3DA56216 000DC818 17FEC1B4 17FEC1B0
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx 17FEFA80         0  40000000  3DA56216     DC818         0  80000000  C0000000
    Ax 17FEC68C  17FEC6E2  17FC9F50  17FED7AC  17FEDA4A  17FEA240  17FEA276
    
                     TTSM III   XNZVC
    PC=17FAA8F6  SR %0000000000010000  USP=17FED72A  ISP=17FF1FF8  MSP=8F800
    VBR=17FF4000  SFC=4  DFC=4  CACR=2101  CAAR=0  TT0=00FF8540  TT1=00000000
    TC=80C07760  CRP=8000000217F9E000  SRP=8000000217F9E000  MMUSR=0000
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%0000000001101100 dmacon=%0000001111110000 adkcon=$1100
    intreq=%0000011110000000
    vposr....A300  vhposr...0278  joy0dat..312B  joy1dat..2058  clxdat...8133  
    pot0dat..4C00  pot1dat..0000  potinp...5500  serdatr..3800  dskbytr..A000  
    deniseid.00F8  hhposr...FF69  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=00000000  ta=21FF<21FF	   cra=00000001  ta= 4AE<3EE8
    	    AII ROPS			    AII ROPS
    	crb=00001000  tb=6FDC<6FDC	   crb=10000000  tb=FFFF<FFFF
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=11111100  prb=11111111      pra=11111111  prb=11111111
           ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
           event=003E88  icr=00  sdr=76    event=00013A  icr=05  sdr=00
    
    ************************* 10-Oct-10 11:19:10 ************************16.9.4672***
    Slave='OilImperium.slave' (5532 bytes)
    ShadowMem 164D6A08 - 1653FA08 ( 430080) AbsolutMem    69000 -    90000 ( 159744)
    Resload   17FA0000 - 17FA8CFC (  36092) at 17FA0000  GL=$17FF3000
    Slave     17FFC000 - 17FFD578 (   5496) at 17FFC000  BaseMemSize=$90000
    ExpMem    17FAA000 - 17FF2000 ( 294912) at 17FAA000
    attn=7(30) fc=4 kn=21679 cs=92B9 rw=0 zpt=-1 ep=0 ei=0
    setcpu=3B3D(SS,BC,SB,DC,IC,SCB,ECB,BNC)
    
    Exception "Privilege Violation" ($20) at $17FAA8F6 (ExpMem $8F6) occured.
    
    $17faa8ea pea          ($17faa8f4)
    $17faa8f0 move         sr,-(a7)                       ;$17fed72a
    $17faa8f2 jmp          (a5)                           ;$17fea240
    $17faa8f4 rts
    $17faa8f6 ori          #$2000,sr
    $17faa8fa subq.l       #8,a7
    $17faa8fc move         sr,(a7)                        ;$17fed72a
    $17faa8fe move.l       #$17faa8f4,(2,a7)              ;$17fed72c
    $17faa906 move.w       #$20,(6,a7)                    ;$17fed730
    
    exception stackframe:
    $17FF1FF8 001017FA A8F60020
    regular stack:
    $17FED72A 17FABF4C 17FCFF3C 17FABD28 17FEC68C 17FEA276 17FEDED6 00000000 17FEDA4A
    $17FED74A 00000000 00000000 00000400 00000000 001E17FE C6E217FE D7640000 000017FE
    $17FED76A D7600000 00000000 06000000 00000000 00003DA5 6216000D 79F617FE E8C617FE
    $17FED78A C3660500 00000000 17FED74C 000017FE C2EE17FE C3660009 00000000 00000000
    $17FED7AA EA600000 00000200 00FF8000 FFF80000 3DA56216 000DC818 17FEC1B4 17FEC1B0
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx 17FEFA80         0  40000000  3DA56216     DC818         0  80000000  C0000000
    Ax 17FEC68C  17FEC6E2  17FC9F50  17FED7AC  17FEDA4A  17FEA240  17FEA276
    
                     TTSM III   XNZVC
    PC=17FAA8F6  SR %0000000000010000  USP=17FED72A  ISP=17FF1FF8  MSP=8F800
    VBR=17FF4000  SFC=4  DFC=4  CACR=2101  CAAR=0  TT0=00FF8540  TT1=00000000
    TC=80C07760  CRP=8000000217F9E000  SRP=8000000217F9E000  MMUSR=0000
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%0000000001101100 dmacon=%0000001111110000 adkcon=$1100
    intreq=%0000011110000000
    vposr....A300  vhposr...0278  joy0dat..312B  joy1dat..2058  clxdat...8133  
    pot0dat..4C00  pot1dat..0000  potinp...5500  serdatr..3800  dskbytr..A000  
    deniseid.00F8  hhposr...FF69  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=00000000  ta=21FF<21FF	   cra=00000001  ta= 4AE<3EE8
    	    AII ROPS			    AII ROPS
    	crb=00001000  tb=6FDC<6FDC	   crb=10000000  tb=FFFF<FFFF
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=11111100  prb=11111111      pra=11111111  prb=11111111
           ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
           event=003E88  icr=00  sdr=76    event=00013A  icr=05  sdr=00
    
    ? file icon oil.whdl_register (5,692 bytes) 2014-01-04 12:19 +
  • ? file icon OilImperium.Slave (5,656 bytes) 2014-01-14 23:50

-Relationships
duplicate of 0002728closedWepl OilImperium Hello, when I let the intro run for serveral minutes, between 30 and 60, system 
related to 0002094closedWepl WHDLoad "privilege violation" at expmem+$8f6 
has duplicate 0002914closedWepl OilImperium Hi, the game crashes every time after 20 minutes of playing when i finished 
+Relationships

-Notes

note ~0001847

Wepl (manager)

I will try to check this.
In the meantime could you try if http://whdload.de/whdload/whd170.lha makes any difference?

note ~0001848

1time (reporter)

Last edited: 2010-07-01 18:45

View 2 revisions

I have now tried the game with the 1.70 and exactly the same error occurs after about 20 min.

Any thing else i can do to help?

note ~0001853

1time (reporter)

When could i expect an update case?

I understand that you all have busy life's, just curious how often i should check this thread.

note ~0001854

Wepl (manager)

you will get an email if a note will be added to this issue.
afaiu a deep look into kickemu is required to clear this problem, so it may take some time

note ~0001867

1time (reporter)

I have tried the new beta release of WHDLoad 17.0.4874.

The same error appears after 20-30min of game play.

note ~0003089

Wepl (manager)

please test attached slave with whdload 17.1 or 17.2 beta
I cannot reproduce this behavior

note ~0003673

Wepl (manager)

please try the whdload attached to 0002094 together with the here attached new slave, this should fix all the problems, please report back afterwards

note ~0003679

1time (reporter)

I have tried the attached slave and the game did not crash.

I do get some weird graphic glitches when different scenes are loaded, the screen flashes and the sound stops for 0.5 sec and then it works.

BUT, it is impossible to play since the drilling is going in SUPER MEGA FAST and not to mention the pipeline part which is unplayable in this speed. The computer will finish in a couple of sec.

I have tried the latest 17.2 and 17.3. Tried NOCACHE and many more, without success.

note ~0003734

Wepl (manager)

slave updated to version 1.2
crash due memory leak should be fixed
some timing issues may still exists but I won't spend more time on this
on my csppc60/50 drilling and selling works ok, so it should on most setups
+Notes

-Issue History
Date Modified Username Field Change
2010-06-21 19:05 administrator New Issue
2010-06-21 19:05 administrator Status new => assigned
2010-06-21 19:05 administrator Assigned To => Wepl
2010-07-01 15:09 Wepl Description Updated View Revisions
2010-07-01 15:18 Wepl Note Added: 0001847
2010-07-01 18:44 1time Note Added: 0001848
2010-07-01 18:45 1time Note Edited: 0001848 View Revisions
2010-07-05 19:28 1time Note Added: 0001853
2010-07-06 23:50 Wepl Note Added: 0001854
2010-07-25 16:39 1time Note Added: 0001867
2013-05-01 21:46 Wepl Relationship added duplicate of 0002728
2013-05-01 21:46 Wepl File Added: OilImperium.Slave
2013-05-01 21:47 Wepl Note Added: 0003089
2014-01-04 12:19 Wepl File Added: oil.whdl_register
2014-01-04 12:35 Wepl Relationship added related to 0002094
2014-01-14 23:44 Wepl Relationship added has duplicate 0002914
2014-01-14 23:50 Wepl File Deleted: OilImperium.Slave
2014-01-14 23:50 Wepl File Added: OilImperium.Slave
2014-01-14 23:52 Wepl Note Added: 0003673
2014-01-19 17:55 1time Note Added: 0003679
2014-02-16 22:35 Wepl Note Added: 0003734
2014-02-16 22:35 Wepl Status assigned => resolved
2014-02-16 22:35 Wepl Resolution open => fixed
2014-06-15 16:17 Wepl Status resolved => closed
+Issue History