2019-12-09 22:05 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001945DungeonMaster[All Projects] Generalpublic2013-08-06 21:12
ReporterRixa 
Assigned ToJOTDProject InfoDungeon Master (FTL/Software Heaven)
http://www.whdload.de/games/DungeonMaster.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0001945: Dungeon Master: I reported earlier that I thought I had a slightly different
DescriptionInstall: Dungeon Master (FTL/Software Heaven) http://whdload.de/games/DungeonMaster.html
GameVersion: V3.6 from Psygnosis
SlaveVersion: from 18.12.2001

I reported earlier that I thought I had a slightly different "V3.6" version and wondered if it could be supported. I had failed to realize that the game saves the language selection on the main disk, and no longer believe that the version is any different. I just finished this game.
The real problem appears to be that sometimes the game crashes during a disk operation. If this is a write it leaves the disk image corrupt. I started taking regular backups of my save after losing it once and having to restart the entire game. Only lost it once after that, but occasionally the game dies while loading itself or the save.
I could have misinterpreted the symptoms before and concluded that the main disk image was corrupt simply because it did not work and had been modified, but wouldn't be surprised if this couldn't happen when saving the language selection. If the save disk is corrupt, the game will not start either.
The error displayed is always a Privilege Violation at ExpMem $8F6.
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem64 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad16.8
importedyes
Attached Files

-Relationships
related to 0002094closedWepl WHDLoad "privilege violation" at expmem+$8f6 
related to 0001943closedJOTD DungeonMaster Dungeon Master: I thought this would work with the install, since its V3.6 as 
+Relationships

-Notes

note ~0000893

Rixa (reporter)

Referring to bug #1943, which was a false conclusion.

note ~0000896

Mailman (reporter)

Last edited: 2009-06-16 20:18

I can confirm this behaviour. I also backuped my saves.

note ~0002457

Wepl (manager)

this should be solved with whdload v17.0, a cache flush in the mmu setup has been added
+Notes

-Issue History
Date Modified Username Field Change
2009-04-10 01:25 administrator New Issue
2009-04-10 01:25 administrator Status new => assigned
2009-04-10 01:25 administrator Assigned To => JOTD
2009-04-10 01:25 administrator Machine => A1200
2009-04-10 01:25 administrator CPU => 68030
2009-04-10 01:25 administrator CPUSpeed => 50
2009-04-10 01:25 administrator ChipSet => AGA
2009-04-10 01:25 administrator GFXCard => None
2009-04-10 01:25 administrator ChipMem => 2 MB
2009-04-10 01:25 administrator FastMem => 64 MB
2009-04-10 01:25 administrator Workbench => OS 3.9
2009-04-10 01:25 administrator KickROM => 40 - Kick 3.1
2009-04-10 01:25 administrator KickSoft => None
2009-04-10 01:25 administrator WHDLoad => 16.8
2009-04-10 01:25 administrator imported => yes
2009-04-30 20:14 Wepl Relationship added related to 0001943
2009-05-01 09:17 Rixa Note Added: 0000893
2009-05-01 09:21 Mailman Note Added: 0000896
2009-05-12 21:54 JOTD Status assigned => confirmed
2009-06-15 21:28 Wepl Relationship added related to 0002054
2009-06-15 21:28 Wepl Relationship deleted related to 0002054
2009-06-15 21:29 Wepl Relationship added related to 0002094
2009-06-16 20:18 Mailman Note Edited: 0000896
2011-08-11 09:12 Wepl Note Added: 0002457
2011-08-11 09:13 Wepl Status confirmed => resolved
2011-08-11 09:13 Wepl Resolution open => fixed
2013-08-06 21:12 Wepl Status resolved => closed
+Issue History