2021-11-27 20:45 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001831KingsQuestEnhanced[All Projects] Generalpublic2014-01-01 22:43
ReporterMikael Arling 
Assigned ToJOTDProject InfoKing's Quest Enhanced (Sierra)
http://www.whdload.de/games/KingsQuestEnhanced.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0001831: King's Quest Enhanced: The Installer works fine, so no problems here. But the
DescriptionInstall: King's Quest Enhanced (Sierra) http://whdload.de/games/KingsQuestEnhanced.html
GameVersion: english,4 disks, (Don't know if it is a PAL or NTSC version)
SlaveVersion: 1.0 from 26.07.03

The Installer works fine, so no problems here. But the game quits after 2 seconds with a requester that says: "Exception "Access Fault" ($7008). PC = $FFFFFF2E. Word Read from $13F14824 (Resload $7824)." Please note: At the moment my only "working Amiga" is WinUAE. Please also note: I AM using the ORIGINAL disks in form of IPF files. I can send you MY version of this game so you can see it for yourself.
TagsNo tags attached.
MachineA1200
CPU68060
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem64 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad16.9beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0001262

Wepl (manager)

Kings Quest Enhanced: v1.0 (26.07.03)

The Installer works fine, so no problems here. But the game quits after 2 – 5 seconds with a requester that says:

>>Exception “Access Fault” ($7008).
    PC= $FFFFFF2E.
    Word Read from $13F14824 (Resload $7824).<<

Please note: At the moment my only “Working Amiga” is WinUAE due to an IDE-Fix Controller that suddenly stopped working, so I have no way of knowing if it works on a real Amiga 1200.

Please also note: I AM using ORIGINAL disks in form of IPF-files.

I am always using the latest version of both WinUAE and WHDLoad.

MY Amiga 1200 consists of:

Standart Amiga 1200 from 1993.
Blizzard 1260 with 64 MB of RAM (Not overclocked).
Elbox Mediator 1200LT4 (Drivers not installed anymore).
IDE-Fix Controller (Not working anymore).

Mikael Arling

Please note on your part of the WHDLoad Support Page that you got this version of this game from me.

note ~0001263

Wepl (manager)

I have the images from Mikael...

note ~0001635

Mikael Arling (reporter)

The Version I have reported is SPS 1436

note ~0003621

JOTD (developer)

same here. Updating...

note ~0003624

JOTD (developer)

A timing problem/CPU dependent loop in the exe was the reason on fast machines. now fixed.

Update due soon on whdload site.
+Notes

-Issue History
Date Modified Username Field Change
2009-04-10 01:19 administrator New Issue
2009-04-10 01:19 administrator Status new => assigned
2009-04-10 01:19 administrator Assigned To => JOTD
2009-04-10 01:19 administrator Machine => A1200
2009-04-10 01:19 administrator CPU => 68060
2009-04-10 01:19 administrator CPUSpeed => 50
2009-04-10 01:19 administrator ChipSet => AGA
2009-04-10 01:19 administrator GFXCard => None
2009-04-10 01:19 administrator ChipMem => 2 MB
2009-04-10 01:19 administrator FastMem => 64 MB
2009-04-10 01:19 administrator Workbench => OS 3.9
2009-04-10 01:19 administrator KickROM => 40 - Kick 3.1
2009-04-10 01:19 administrator KickSoft => None
2009-04-10 01:19 administrator WHDLoad => 16.9beta
2009-04-10 01:19 administrator imported => yes
2009-06-22 23:27 Wepl Note Added: 0001262
2009-06-22 23:27 Wepl Note Added: 0001263
2010-01-16 15:59 Mikael Arling Note Added: 0001635
2013-12-30 18:59 JOTD Note Added: 0003621
2013-12-30 18:59 JOTD Status assigned => confirmed
2014-01-01 22:43 JOTD Note Added: 0003624
2014-01-01 22:43 JOTD Status confirmed => closed
2014-01-01 22:43 JOTD Resolution open => fixed
+Issue History