2019-07-20 19:45 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001783TorvakTheWarrior[All Projects] Generalpublic2012-01-23 18:06
ReporterVille Haapanen 
Assigned ToCFOUProject InfoTorvak the Warrior (Core Design)
http://www.whdload.de/games/TorvakTheWarrior.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0001783: Torvak the Warrior: When you defeat the first world boss and the map shows the
DescriptionInstall: Torvak the Warrior (Core Design) http://whdload.de/games/TorvakTheWarrior.html
GameVersion: english
SlaveVersion: 1.2 from 26.05.06

When you defeat the first world boss and the map shows the next world, the game hangs there. It doesn't load the next world at all.
TagsNo tags attached.
MachineA1200
CPU68060 + PPC
CPUSpeed50
ChipSetAGA
GFXCardVoodoo3/Mediator
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoft40 - Kick 3.1
WHDLoad16.7
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0000508

CFOU (developer)

have somebody same pb?

note ~0000742

Irek (reporter)

I can confirm this bug
The game freezes after the first boss in the map...
My system configuration: A-1200/40/64 MB

note ~0000744

CFOU (developer)

Last edited: 2009-04-25 22:16

arp!

no time to test (long play for this

freeze bug is bad new because i prefer a friendly crash ;)(more easy to fix)

when game freezes can you enter in a monitor (as Hrtmon)?

if yes, i need adress of the freeze stats (perhaps a 'fake' blitter delay.... Indeed if i patch a code which look like a bliter delay but which is not this... game can freeze

ps:

or is a loading problem (missing swap disk and no insert disk requester)

note ~0000762

CFOU (developer)

confirmed it's seems to be a swap disk emulation problem

loop at adress:

 $9770: Cmp.b #$32,$1758d

note ~0000763

Irek (reporter)

Is this good or bad?;)

I will test the game in the next days on my another machine (020/6MB) to see if the game does the same problems as with 040 CPU...

note ~0000764

CFOU (developer)

it's good because, it'l be easy to fix (i think ;)

note ~0000770

Irek (reporter)

Okay, thank you :)

I have tried the game on my 020 CPU, and the game freezes at exactly the same place as with 040 CPU.

note ~0000778

CFOU (developer)

curiously

there are a stupid bug...

Rob Northen protection are badly removed at $8d4C

so it's perhaps the reason of the bug

if will fix it quickly ;)

note ~0001429

Ville Haapanen (reporter)

Any success with this one yet CFOU? :)

note ~0001956

CFOU (developer)

Fixed with version 1.3

note ~0002582

Ville Haapanen (reporter)

thanks! works good!
+Notes

-Issue History
Date Modified Username Field Change
2009-04-10 01:17 administrator New Issue
2009-04-10 01:17 administrator Status new => assigned
2009-04-10 01:17 administrator Assigned To => CFOU
2009-04-10 01:17 administrator Machine => A1200
2009-04-10 01:17 administrator CPU => 68060 + PPC
2009-04-10 01:17 administrator CPUSpeed => 50
2009-04-10 01:17 administrator ChipSet => AGA
2009-04-10 01:17 administrator GFXCard => Voodoo3/Mediator
2009-04-10 01:17 administrator ChipMem => 2 MB
2009-04-10 01:17 administrator FastMem => 128 MB
2009-04-10 01:17 administrator Workbench => OS 3.9
2009-04-10 01:17 administrator KickROM => 40 - Kick 3.1
2009-04-10 01:17 administrator KickSoft => 40 - Kick 3.1
2009-04-10 01:17 administrator WHDLoad => 16.7
2009-04-10 01:17 administrator imported => yes
2009-04-23 13:30 CFOU Note Added: 0000508
2009-04-23 13:30 CFOU Status assigned => feedback
2009-04-25 22:03 Irek Note Added: 0000742
2009-04-25 22:14 CFOU Note Added: 0000744
2009-04-25 22:16 CFOU Note Edited: 0000744
2009-04-25 23:00 CFOU Note Added: 0000762
2009-04-25 23:00 CFOU Status feedback => confirmed
2009-04-25 23:27 Irek Note Added: 0000763
2009-04-26 01:51 CFOU Note Added: 0000764
2009-04-26 15:19 Irek Note Added: 0000770
2009-04-26 20:44 CFOU Note Added: 0000778
2009-09-08 00:08 Ville Haapanen Note Added: 0001429
2010-10-15 15:19 CFOU Note Added: 0001956
2010-10-15 15:19 CFOU Status confirmed => resolved
2010-10-15 15:19 CFOU Fixed in Version => none
2010-10-15 15:19 CFOU Resolution open => fixed
2012-01-22 23:06 Ville Haapanen Note Added: 0002582
2012-01-23 18:06 Wepl Status resolved => closed
+Issue History