2020-09-26 07:29 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001382Turrican2[All Projects] Generalpublic2009-07-15 22:35
ReporterPatrik Axelsson 
Assigned ToWeplProject InfoTurrican 2 (Factor 5/Rainbow Arts)
http://www.whdload.de/games/Turrican2.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Summary0001382: Turrican 2: If I start the game without the preload argument/tooltype the
DescriptionInstall: Turrican 2 (Factor 5/Rainbow Arts) http://whdload.de/games/Turrican2.html
GameVersion: english,pal,1 disk
SlaveVersion: 1.2 from 26.2.1999

If I start the game without the preload argument/tooltype the screen goes to black for say half a second and then I am thrown back to WB/Cli and shown a WHDLoad requester saying "Exception "Illegal instruction" ($E010) at $60000 occured."
I get the exact same error for the same instruction and at the same address disregarding if I run it from WB or boot with no startup-sequence with the stock 2.04 kick.
Also, I have a complaint - during the intro of the game, if you don't press any button, the Turrican bloke will start jumping around, shooting and during that, the background music will make small chops every now and then. In the standard disc version, the music plays back perfectly. I don't mean to nag, but it hurts in my heart every time I hear a chop in that tune.
This is a stock A500+ as it comes from factory and the only expansion added is a GVP HD+8 with 8MB fastmem and harddrive. WHDLoad is also the default 16.6 version, no settings altered.
Btw, I get the _exact_ same error, when I try loading it without the preload option/tooltype on my A4000.
TagsNo tags attached.
MachineA500
CPU68000
CPUSpeed7
ChipSetECS
GFXCardNone
ChipMem1 MB
FastMem8 MB
WorkbenchOS 3.1
KickROM37 - Kick 2.0
KickSoft40 - Kick 3.1
WHDLoad16.6
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0000194

Wepl (manager)

it should be retried with the actual version
the 'illegal instruction' could be caused by a crack version
sound chops without using PreLoad option could be normal

note ~0000208

Wepl (manager)

From: Patrik Axelsson
To: wepl
Subject: Issue 0001382

Hi, just want to comment on your closing of issue 0001382 without reopening it.

First of all, the intro sound chop issue was with Preload. I could not get the game running
without Preload as the report says.

Regarding data file quality, I was using killergorillas package of the v1.2 slave
(Turrican2WHD12.lzx), extract from that Turrican2.slave: $VER: Turrican2 Slave 1.2 by Wepl
(21-Feb-99 00:50:44). I do think that datafile should be ok, but ofcourse I cannot guarantee it.
Disk.1 in that package has md5sum "685b21ac192c296200e9c3aad6ec0f22".

Since this in a rather old report, I can test again with new version of the slave and other data
files when I rig up my A500 again.

note ~0000209

Wepl (manager)

please retry it with the actual slave.
the image can be used from killergorillas package there were no change on this

note ~0000658

Wepl (manager)

The problem with the exception when PreLoad is not active was a bug in WHDLoad 16.6 which has been fixed in 16.7. You also see this in the Change History of WHDLoad.

For the sound problem: does this only happen on the A500 or also on your faster A4000?

note ~0001168

Wepl (manager)

I can't reproduce the sound problem. Also there is no code in the slave which changes anything regarding the TFMX-7V replay. The replayer has problems with caches. Therefore caches are not enabled. So at least on a 68000 the sound should not make a difference to running it from the original floppy.

note ~0001310

Patrik Axelsson (reporter)

Tried it with the most recent slave on the A500 and the sound chops in the intro when the turrican dude jumps around and shoots have disappeared.
+Notes

-Issue History
Date Modified Username Field Change
2009-04-10 00:58 administrator New Issue
2009-04-10 00:58 administrator Status new => assigned
2009-04-10 00:58 administrator Assigned To => Kyzer
2009-04-10 00:58 administrator Machine => A500
2009-04-10 00:58 administrator CPU => 68000
2009-04-10 00:58 administrator CPUSpeed => 7
2009-04-10 00:58 administrator ChipSet => ECS
2009-04-10 00:58 administrator GFXCard => None
2009-04-10 00:58 administrator ChipMem => 1 MB
2009-04-10 00:58 administrator FastMem => 8 MB
2009-04-10 00:58 administrator Workbench => OS 3.1
2009-04-10 00:58 administrator KickROM => 37 - Kick 2.0
2009-04-10 00:58 administrator KickSoft => 40 - Kick 3.1
2009-04-10 00:58 administrator WHDLoad => 16.6
2009-04-10 00:58 administrator imported => yes
2009-04-20 00:23 Wepl Assigned To Kyzer => Wepl
2009-04-20 00:45 Wepl Note Added: 0000194
2009-04-20 00:45 Wepl Status assigned => resolved
2009-04-20 00:45 Wepl Resolution open => fixed
2009-04-20 19:49 Wepl Note Added: 0000208
2009-04-20 19:49 Wepl Status resolved => feedback
2009-04-20 19:49 Wepl Resolution fixed => reopened
2009-04-20 19:54 Wepl Note Added: 0000209
2009-04-24 22:34 Wepl Note Added: 0000658
2009-06-02 23:37 Wepl Note Added: 0001168
2009-06-02 23:37 Wepl Status feedback => resolved
2009-06-02 23:37 Wepl Resolution reopened => unable to reproduce
2009-07-11 03:50 Patrik Axelsson Note Added: 0001310
2009-07-15 22:35 Wepl Status resolved => closed
+Issue History