2022-08-11 11:23 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005745PrinceOfPersia[All Projects] Generalpublic2022-08-05 12:23
ReporterHexaae 
Assigned ToJOTDProject InfoPrince of Persia (Jordan Mechner/Brøderbund)
http://www.whdload.de/games/PrinceOfPersia.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
Summary0005745: fix display for NTSC in PAL version
DescriptionMade a small video showing USA/NTSC, EU/PAL, EU/NTSC.
https://www.youtube.com/watch?v=hGRfz-ytczk

USA/NTSC=slowest
EU/PAL=a little bit faster than USA/NTSC (at 50Hz??)
EU/NTSC (forced to NTSC 60Hz)=WOW! Nice framerate! :)

Since forcing EU->NTSC has the fastes framerate (!) it would be great an extra fix to promote EU versions to NTSC correctly, without cropping at the bottom of the screnen and vertical screen positioning correction. That would be killer version with the highest (30fps?) framerate.
TagsNo tags attached.
MachineA1200
CPU68060
CPUSpeed105
ChipSetAGA
GFXCardOther
ChipMem2 MB
FastMem256 MB
WorkbenchOS 3.9
KickROM39 - Kick 3.0
KickSoft39 - Kick 3.0
WHDLoad
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0011639

Hexaae (reporter)

If I play a Euro version of the game it runs visibly faster now with the fastram patch, when I run a USA/NTSC version I see slow animation (falling, turning around etc.) as the pre-4.0 patch, what's wrong then?

note ~0011642

JOTD (developer)

note: fastram version has no noticeable speed effect on winuae, only on real amiga.

The current improvement proposal is to change display so status bar is visible in NTSC for PAL version

note ~0011643

Hexaae (reporter)

it would be great, thank you

note ~0011644

Hexaae (reporter)

Oh, just saved the game with CTRL+G, quitted the whole WHD game and relaunched.
After reloading a saved game with CTRL+L though the copy protection level was presented :( Can you check this?

note ~0011645

Hexaae (reporter)

Uhm, another bug I've noticed: can't hear the music in the cutscenes of the princess waiting (SHIFT-L to quick skip to lev 2 or 4...).
Noticed it because I restored your old JST 1.1e version for testing and noticed there was some music indeed ;)

note ~0011649

JOTD (developer)

Last edited: 2022-08-04 18:32

View 2 revisions

yes, all your reports (music, save...) are confirmed and reproduced here (and will be fixed). Thanks

About UP = jump only, I'm really on the fence.

First this is non-trivial as it needs a lot of reverse engineering.
Second what about clinging on a ledge and climbing up? if up is disabled that seems not natural. But button is used for jump so... Same about sword parry.

I could leave that as an option. Personally I would not use that option.

note ~0011650

Hexaae (reporter)

Well, the optimal solution would probably be UP = no jump, but usable for anything else (sword parry, climb up). I understand this can be complicated to do though...
As far as I can understand just disable whole up input would be simpler, maybe on a separate cfg option.

IMHO about the clinging + climb up I see nothing wrong in using 2nd button to jump, then fire to cling, and again jump button to climb up, once user has a dedicated 2nd button as usual on consoles... I tried playing like this without UP + 2nd button only, and was just the usual 5mins adjustment to new commands. One thing I've found sword parry to be harder with 2nd button only (especially for the parry+hit master trick you have to learn to finish the game).
+Notes

-Issue History
Date Modified Username Field Change
2022-07-31 00:18 administrator New Issue
2022-07-31 00:18 administrator Status new => assigned
2022-07-31 00:18 administrator Assigned To => JOTD
2022-08-02 23:56 JOTD Status assigned => closed
2022-08-02 23:56 JOTD Resolution open => fixed
2022-08-03 01:52 Hexaae Status closed => feedback
2022-08-03 01:52 Hexaae Resolution fixed => reopened
2022-08-03 01:52 Hexaae Status feedback => assigned
2022-08-03 09:41 JOTD Status assigned => closed
2022-08-03 11:51 Hexaae Status closed => feedback
2022-08-03 11:51 Hexaae Note Added: 0011639
2022-08-03 14:23 Hexaae Status feedback => assigned
2022-08-03 15:05 JOTD Summary NON-SUPPORTED IPF I've found some IPF not working with the recent patches for => fix display for NTSC in PAL version
2022-08-03 15:05 JOTD Description Updated View Revisions
2022-08-03 15:05 JOTD WHDLoad 18.8 =>
2022-08-03 15:07 JOTD Note Added: 0011642
2022-08-03 15:07 JOTD Status assigned => acknowledged
2022-08-03 15:37 Hexaae Note Added: 0011643
2022-08-03 16:13 Hexaae Note Added: 0011644
2022-08-03 16:37 Hexaae Note Added: 0011645
2022-08-04 18:32 JOTD Note Added: 0011649
2022-08-04 18:32 JOTD Note Edited: 0011649 View Revisions
2022-08-04 20:44 Hexaae Note Added: 0011650
2022-08-05 12:23 JOTD Status acknowledged => closed
+Issue History