2022-08-17 05:58 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005724JimPower[All Projects] Generalpublic2022-07-31 22:34
ReporterHexaae 
Assigned ToJOTDProject InfoJim Power (Loriciel)
http://www.whdload.de/games/JimPower.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
Summary0005724: Still some problems with the intro of the game (Loriciel logo and then main
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 3.0

Still some problems with the intro of the game (Loriciel logo and then main menu with parallax) on WinUAE: there's no sweet spot to hear perfect music without crackles and first parallax scrolling (bottom) without jumps. Also Game Over sequence can be affected depending on WinUAE settings...
Tried also "cycle exact" but nothing works to fix intro/menu part to be perfectly in sync between video/audio without sound crackles and with smooth parallax scrolling.
In-game instead it runs perfectly fine including parallax and giant bosses multi-sprite. Is just a timing problem with intro/menu part.
WinUAE 4.9.1
TagsNo tags attached.
MachineUAE
CPU68060
CPUSpeed75
ChipSetAGA
GFXCardOther
ChipMem2 MB
FastMem256MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoft40 - Kick 3.1
WHDLoad18.6
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0011548

Hexaae (reporter)

Tested QuickStart A500 in WinUAE and game and intro/menu run perfectly fine without jumping parallax or sound crackling...
Maybe am added blitterwaits issue on 060? I see no option to force disable it anymore like in slave 2.2.

note ~0011555

JOTD (developer)

the only problem I remember is that the music is too fast in the first 2 intro screens (like if NTSC was activated), then it's okay.

note ~0011564

JOTD (developer)

the TFMX music replay is notoriously buggy on fast machines. Can you try that version?

note ~0011615

Hexaae (reporter)

Sorry for being late but I got no notification from Mantis recenly... :-?

This beta slave works perfectly fine finally! Intro without slowdowns or crackles and game loads blazingly fast with 060 (emu)!

BUG: after I pause the game with P I can't resume game.

note ~0011622

Hexaae (reporter)

"P" to pause the game, will freeze it (can't resume pressing P again), also in the public 3.1 slave.

note ~0011624

MrV2K (reporter)

If you hold up and right on a controller, the character moonwalks left across the screen. This happens in WinUAE and Amiberry on the A500 Mini.

note ~0011625

MrV2K (reporter)

Also the title screen sound on the A500 mini is really crackly and broken up. I can only assume it's due to the terribly old version of Amiberry used and its bad copper emulation.

note ~0011627

Hexaae (reporter)

@MrV2K
If you disable music patch too?

note ~0011628

Hexaae (reporter)

@MrV2K
Can't reproduce moonwalk on my WinUAE 4.9.1 setup. Tested with arcade joystick (Hori Fighting Stcik Mini) and XBox One BT controller...

note ~0011630

JOTD (developer)

closed. I'll check the pause issue, but issues with old or non accurate emulators aren't my problems.
+Notes

-Issue History
Date Modified Username Field Change
2022-07-11 21:23 administrator New Issue
2022-07-11 21:23 administrator Status new => assigned
2022-07-11 21:23 administrator Assigned To => JOTD
2022-07-12 00:47 Hexaae Note Added: 0011548
2022-07-12 22:39 JOTD Note Added: 0011555
2022-07-15 23:57 JOTD File Added: JimPower.zip
2022-07-15 23:58 JOTD Note Added: 0011564
2022-07-25 17:56 JOTD Status assigned => feedback
2022-07-30 10:14 Hexaae Note Added: 0011615
2022-07-30 10:14 Hexaae Status feedback => assigned
2022-07-30 17:22 JOTD Status assigned => confirmed
2022-07-30 22:46 JOTD Status confirmed => closed
2022-07-30 22:46 JOTD Resolution open => fixed
2022-07-31 01:33 Hexaae Status closed => feedback
2022-07-31 01:33 Hexaae Resolution fixed => reopened
2022-07-31 01:33 Hexaae Note Added: 0011622
2022-07-31 21:14 MrV2K Note Added: 0011624
2022-07-31 21:17 MrV2K Note Added: 0011625
2022-07-31 21:56 Hexaae Note Added: 0011627
2022-07-31 21:56 Hexaae Status feedback => assigned
2022-07-31 21:59 Hexaae Note Added: 0011628
2022-07-31 22:34 JOTD Status assigned => closed
2022-07-31 22:34 JOTD Note Added: 0011630
+Issue History