2022-10-02 06:10 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004709Goblins3[All Projects] Generalpublic2020-06-05 23:41
ReporterPascal De Maeseneire 
Assigned ToJOTDProject InfoGoblins 3 (Coktel Vision)
http://www.whdload.de/games/Goblins3.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0004709: Hi, I made a complete new installation from WHDLoad package with Slave v3.0 The
DescriptionGameVersion: 6 IPF Files disks From SPS 2292 (french version)
SlaveVersion: version 3.0 (28.05.2020)

Hi,
I made a complete new installation from WHDLoad package with Slave v3.0
The installation was made under WINUAE (OS 3.5) 6 IPF Files disks From SPS 2292 (french version) and transfert on my both real Amiga
On My A500 ECS ACA500PLUS 68000 @14MHZ (OS 3.1.4.1)
Just after the copy protection screen When I select number key for example 2..
This message come SYSTEM ERR -6 RAM:0 and after that when I press spaceBar on my keyboard I Have this message "Software Failure. Press left button to continue. Guru Meditation #00000025.CCCCCCCC"
When I Press left button on my mouse whdload seems reboot and I return to the pretection screen .... If a press for example Digit Key 2 I have this message "GOB ERROR" and the protection screen let's me try again ... I Press again with the same key (2) and the game exit to return to workbench...
!!!!!ATTENTION on MY ACA500PLUS WITH Old SLAVE 2.0 the game works correctly !!!!!
I Have the same issue under WINUAE 4.3.0 (OS 3.5 KS v3.1 REV 40.68)
WITH CPU 68020 (WITH OR WITHOUT 24-BIT addressing, MMU NONE, FPU NONE)
same Issue with same problems
WITH CPU 68030 (WITH OR WITHOUT 24-BIT addressing, MMU NONE, FPU NONE)
same Issue as my ACA500Plus with same problems and messages.
!!!BUT !!! On my Real A1200 PAL (OS 3.1.4.1) WITH GVP A1230Turbo+II 68030 @40 MHZ +FPU WITH 32 MB.
The game works perfectly (SLAVE 3.0) without any problems and I can play with the game.
Best regards,
Pascal
TagsNo tags attached.
MachineA500
CPU68000
CPUSpeed14
ChipSetECS
GFXCardNone
ChipMem1 MB
FastMem7MB
WorkbenchOS 3.1.4
KickROM45 - Kick 3.1.4
KickSoftNone
WHDLoad18.5
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0008864

Pascal De Maeseneire (reporter)

Hi,
To resume it :
On my A500ACA500Plus WITH CPU 68000, I can't use ToolType EXPCHIP, EXP24...

I Tried too ExpLocal but with the same issue...
On my A500ACA500Plus I Retried older Slaves v2.1 till v3.0... it doesn't works But v2.0 works directly and correctly without add any ToolType.

Under WINUAE add ToolType EXPCHIP works correctly with ToolType EXPCHIP.

ON my A1200 GVP A1230TURBO+II 68030 @40... slave 3.0 works directly without any ToolType.

Best Regards,
Pascal

note ~0008877

Superman (reporter)

Not working on my A600 with furia either. Can’t get past the protection check and eventually gives a system -6 ram 0 error then crashes out with exception Line 1111 Emulator ($2c) at $ffffff3a occurred

note ~0008878

Superman (reporter)

Also tested on A1200 and skips protection check fine and loads ok.

note ~0008886

haynor666 (reporter)

It's fine on A1200 with EC030

note ~0008887

Sina (reporter)

I confirm the error "SYSTEM ERR -6 RAM:0" after the title screen in WinUAE. EXPCHIP fixes it.

note ~0008894

JOTD (developer)

Last edited: 2020-06-03 00:23

View 2 revisions

hi, can you try the v3.1 beta?

I noticed that on fast machines there's a problem if startup is not slightly delayed. With the delay, it works properly, and without it doesn't.

note: this 2291 version only works for french anyway. It's buggy as hell, version 370 at least works for german & english (but not for italian & french).

The fact that it works only for some languages is independent from the startup bug.

Damn this game is buggy... and most Coktel games have the same bugs.

note ~0008895

Pascal De Maeseneire (reporter)

Hi,
I just try Your latest slave v3.1 on my different systems

On my A500ACA500PLUS => Sorry it doesn't work (same message SYSTEM ERR -6 RAM:0)

Under WinUAE => same issue (same message SYSTEM ERR -6 RAM:0) BUT EXPCHIP FIX IT

On My A1200 GVPA1230Turbo+II @40Mhz 32 MB => it works without any ToolTypes.

Best regards,
Pascal

note ~0008896

Superman (reporter)

Still Crashes with the same error on A600 with furia also
+Notes

-Issue History
Date Modified Username Field Change
2020-05-29 09:42 administrator New Issue
2020-05-29 09:42 administrator Status new => assigned
2020-05-29 09:42 administrator Assigned To => JOTD
2020-05-29 10:03 Pascal De Maeseneire Note Added: 0008864
2020-05-30 15:43 Superman Note Added: 0008877
2020-05-30 15:56 Superman Note Added: 0008878
2020-06-01 19:59 haynor666 Note Added: 0008886
2020-06-01 20:44 Sina Note Added: 0008887
2020-06-03 00:21 JOTD File Added: Goblins3.zip
2020-06-03 00:23 JOTD Note Added: 0008894
2020-06-03 00:23 JOTD Note Edited: 0008894 View Revisions
2020-06-03 00:54 Pascal De Maeseneire Note Added: 0008895
2020-06-03 12:12 Superman Note Added: 0008896
2020-06-05 23:41 JOTD Status assigned => closed
2020-06-05 23:41 JOTD Resolution open => fixed
+Issue History