2020-05-30 12:53 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004093Virocop[All Projects] Generalpublic2019-08-02 22:35
ReporterHexaae 
Assigned ToJOTDProject InfoVirocop (Graftgold)
http://www.whdload.de/games/Virocop.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0004093: Virocop AGA Mouse/Joystick not working with WinUAE 4.2.0? Can't pass through
DescriptionGameVersion: english,pal
SlaveVersion: 1.3 (05-mai-14 18:41:13)

Virocop AGA
Mouse/Joystick not working with WinUAE 4.2.0? Can't pass through intro screen as no input device is detected.
TagsNo tags attached.
MachineUAE
CPU68060
CPUSpeed75
ChipSetAGA
GFXCardPicasso IV
ChipMem2 MB
FastMem256MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftOther
WHDLoad18.4
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0006784

JOTD (developer)

Last edited: 2019-04-24 02:43

View 2 revisions

I can start the game using WinUAE and joystick fire button. From that it works, in CD32 mode or default mode.

Starting game with left mouse button doesn't work and never did.

note ~0006788

Hexaae (reporter)

Slave 1.1??? The problem is with last official slave 1.3 and AGA version.
When I use previous salve 1.2 I can't reproduce it.
Here is my game with both OLD and NEW slaves (see tooltypes): https://ufile.io/g5itfp43

note ~0006789

Hexaae (reporter)

Forgot a REQUEST: 2nd joy button to act as SPACEBAR to exchange weapon?

note ~0006794

Solo Kazuki (reporter)

There is 2nd button support originally. As in some Graftgold games on F-keys you have options. On title screen press F2 to change for joypad and You have already exchange weapons on 2nd button.

note ~0006795

Hexaae (reporter)

Slave 1.2: 2nd joy button doesn't work even when I select joypad button :(

Slave 1.3: 1st joy button and 2nd joy button do not work at all.

It's the only game I have giving me these troubles. EVERY other WHDLoad game with 1-2 button(s) work just fine. I'm using WinUAE 4.2.0 + Speedlink USB joystick ProCompetition.

note ~0006801

Hexaae (reporter)

Tested with WinUAE + original IPF disks and had the same issues BTW...

note ~0006803

JOTD (developer)

I see. Tested wrong package
+Notes

-Issue History
Date Modified Username Field Change
2019-03-18 14:17 administrator New Issue
2019-03-18 14:17 administrator Status new => assigned
2019-03-18 14:17 administrator Assigned To => JOTD
2019-04-24 02:40 JOTD Note Added: 0006784
2019-04-24 02:43 JOTD Note Edited: 0006784 View Revisions
2019-04-24 02:45 JOTD Status assigned => closed
2019-04-24 02:45 JOTD Resolution open => unable to reproduce
2019-04-24 13:21 Hexaae Status closed => feedback
2019-04-24 13:21 Hexaae Resolution unable to reproduce => reopened
2019-04-24 13:21 Hexaae Note Added: 0006788
2019-04-24 13:30 Hexaae Note Added: 0006789
2019-04-24 13:30 Hexaae Status feedback => assigned
2019-04-25 15:52 Solo Kazuki Note Added: 0006794
2019-04-25 17:28 Hexaae Note Added: 0006795
2019-04-26 00:32 Hexaae Note Added: 0006801
2019-04-26 04:18 JOTD Note Added: 0006803
2019-04-26 04:18 JOTD Status assigned => acknowledged
2019-08-02 22:35 JOTD Status acknowledged => resolved
2019-08-02 22:35 JOTD Resolution reopened => fixed
2019-08-02 22:35 JOTD Status resolved => closed
+Issue History