2018-10-15 15:26 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003807Leander[WHDLoad Installs Games] slavepublic2018-05-27 23:07
ReporterHexaae 
Assigned ToJOTDProject InfoLeander (Psygnosis)
http://www.whdload.de/games/Leander.html
 
PrioritynormalSeveritytweakReproducibilityN/A
StatusclosedResolutionreopened 
Summary0003807: fix corrupt sounds after intro and the dragon picture
DescriptionImprovements for the Leander slave:
1) extra memory (not sure what it does but it does support expansion mem)
3) fix corrupt sounds after intro and the dragon picture, 'till the other music starts there is a an audio glitch
TagsNo tags attached.
MachineUAE
CPU68040
CPUSpeed50
ChipSetAGA
GFXCardOther
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftOther
WHDLoad18.4beta
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0006017

JOTD (developer)

Last edited: 2018-02-25 16:41

View 2 revisions

1) extra memory (not sure what it does but it does support expansion mem)

ok, found why it uses expmem: 512k expansion to 1MB removes the mid level shop loading. so from WHDLoad I hardly see the point of using 1MB. I prefer leaving a single 512K slave for low memory configs. high memory configs will use files loaded in RAM.

2) CUSTOM option to skip intro entirely, like Beast slave that starts at main menu

ok, why not

3) fix corrupt sounds after intro and the dragon picture, 'till the other music starts there is a an audio glitch

didn't witness that (on winuae...). Have to check on real miggy

note ~0006018

Hexaae (reporter)

1) ...just because I noticed this on YT: https://www.youtube.com/watch?v=JtU07IM4M8g with Extra Memory Detected logo/animation

3) I can reproduce it on 3 different PCs with different HW and UAE settings (020, 040, Direct Sound, WASAPI etc.)... strange... 1/2 there is a high tone sound when you press fire at dragon picture before the other main menu short-intro starts.

note ~0006019

JOTD (developer)

ok, leaving it open. But part 2 is already covered by your other 2202 issue

note ~0006070

JOTD (developer)

after having found why 1) and deciding NOT to implement it, it leaves point 3 open.

note ~0006071

JOTD (developer)

and I cannot reproduce point 3 on winuae 68040 changing speed turning on/off JIT... please prove your point with a video (ensure you're using latest WinUAE, 3.6 at the time)

note ~0006072

Hexaae (reporter)

https://www.youtube.com/watch?v=lywTMXIjzhk&feature=youtu.be
Don't know your audio settings and if you have a good soundcard hiding the audio glitch but I can reproduce it on every PC I've tested it...
In the video description you can also download WinUAE 3.6.0 cfg used.

note ~0006080

JOTD (developer)

thanks for posting the video. Actually I could hear it with headphones. I've tried to fix it, please check attached slave. Will release it officially if you confirm.

note ~0006081

Hexaae (reporter)

can't find the beta salve

BTW, just to be perfectionists ;-) is it possible to skip the "Press fire now to skip intro music" part entirely, starting the slave directly from Psygnosis logo?

note ~0006082

JOTD (developer)

sorry, it didn't work. Attached. Yes, removing this message is possible.

note ~0006083

Hexaae (reporter)

Unfortunately I can still hear the glitch
+Notes

-Issue History
Date Modified Username Field Change
2018-01-26 09:50 Hexaae New Issue
2018-01-28 23:58 StingRay Assigned To => JOTD
2018-01-28 23:58 StingRay Status new => assigned
2018-02-04 16:39 JOTD Note Added: 0006017
2018-02-04 21:33 Hexaae Note Added: 0006018
2018-02-04 22:06 JOTD Note Added: 0006019
2018-02-25 16:41 JOTD Note Edited: 0006017 View Revisions
2018-02-25 16:43 JOTD Note Added: 0006070
2018-02-25 16:51 JOTD Summary Improvements for Leander => fix corrupt sounds after intro and the dragon picture
2018-02-25 16:51 JOTD Description Updated View Revisions
2018-02-26 12:40 JOTD Note Added: 0006071
2018-02-26 17:27 JOTD Status assigned => closed
2018-02-26 17:27 JOTD Resolution open => unable to reproduce
2018-02-26 19:14 Hexaae Status closed => feedback
2018-02-26 19:14 Hexaae Resolution unable to reproduce => reopened
2018-02-26 19:14 Hexaae Note Added: 0006072
2018-03-01 15:31 JOTD Note Added: 0006080
2018-03-01 16:27 Hexaae Note Added: 0006081
2018-03-01 16:27 Hexaae Status feedback => assigned
2018-03-01 16:51 JOTD File Added: Leander.slave
2018-03-01 16:52 JOTD Note Added: 0006082
2018-03-01 18:02 Hexaae Note Added: 0006083
2018-04-24 23:45 JOTD Status assigned => confirmed
2018-05-27 23:07 JOTD Status confirmed => closed
+Issue History