2022-11-29 21:18 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005543Harricana[All Projects] Generalpublic2022-10-04 16:33
ReporterIrek 
Assigned ToCFOUProject InfoHarricana (Loriciel)
http://www.whdload.de/games/Harricana.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
Summary0005543: Hi, The game "Harricana" crashes on 040 CPU with an error.(see below)The error
DescriptionGameVersion: fr,pal,1 disks
SlaveVersion: 1.0 from 06.03.2022

Hi,
The game "Harricana" crashes on 040 CPU with an error.(see below)The error happens immediately after starting the game.
Can you please take a look at it, thanks in advance!
************************* 13-Mär-22 14:00:19 ************************18.6.6128***
Slave='HarricanaFr.Slave' (896 bytes)
Resload   5BF6A000 - 5BF71CF8 (  31992) at 5BF6A000  GL=$5BF73000
Slave     5BFFE000 - 5BFFE35C (    860) at 5BFFE000  BaseMemSize=$80000
attn=7F(40,82) fc=-1 kn=10371 cs=DC00 rw=0 zpt=-1 ep=0 ei=0
setcpu=33D(DC,IC,SCB,ECB,BNC)
Exception "Access Fault" ($7008) PC = $8116 Byte Read from $BFFE01
$000080e0 bsr.w        $6e36
$000080e4 moveq        #5,d0
$000080e6 bsr.w        $24e4
$000080ea tst.w        d0
$000080ec bne.w        $e920
$000080f0 move.l       a6,($890a)
$000080f6 move.l       d4,($890e)
$000080fc add.l        a6,d4
$000080fe addq.l       #1,d4
$00008100 bclr         #0,d4
$00008104 move.l       d4,a6
$00008106 move.l       a6,($406)
$0000810c lea          ($85f8),a0
$00008112 bsr.w        $85de
$00008116 bset         #1,($bffe01)
$0000811e move.l       ($8902),a6
$00008124 move.l       ($8906),d6
$0000812a bsr.w        $6e62
$0000812e bsr.w        $82c0
$00008132 bne.w        $82a4
$00008136 bsr.w        $6fa6
$0000813a bpl.b        $812e
$0000813c move.l       ($88fa),a6
$00008142 move.l       ($88fe),d6
$00008148 bsr.w        $6e62
$0000814c move.l       ($88f2),a6
$00008152 moveq        #5,d6
$00008154 bsr.w        $84a6
$00008158 tst.w        d0
exception stackframe:
$000678C0 20040000 81167008 000678B8 05250005 00250005 00BFFE01 00006D32 00000000
$000678E0 0007FA00 A3A3A3A3 A4A4A4A4 00006B42 00000770 000085E6 00008116
regular stack:
$000678FC 0000E8C2 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006791C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006793C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006795C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006797C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx        0      FFFF   FFF0FFF   FFF0FFF     604BC      1000   FFF0FFF   FFF0FFF
Ax     85F8     7FB1C     7FA00      6D36  A4A4A4A4  A5A5A5A5     604BC
                 TTSM III   XNZVC
PC=    8116  SR %0010000000000100  USP=7FC00  ISP=678C0  MSP=7F800
VBR=5BF74000  SFC=5  DFC=5  CACR=80008000  MMUSR=0
TC=8000  URP=5BF68E00  SRP=5BF68E00  DTT0=0  DTT1=0  ITT0=0  ITT1=0
         MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
intena=%0100000000001001 dmacon=%0010001111010000 adkcon=$1100
intreq=%0000000000100000
vposr....A300  vhposr...0294  joy0dat..0303  joy1dat..0000  clxdat...8001  
pot0dat..2639  pot1dat..0D0D  potinp...5500  serdatr..3BFF  dskbytr..8000  
deniseid.00F8  hhposr...FFDE  
   ciaa:     PI ROPS		   ciab:     PI ROPS
    cra=00000000  ta=21FF<21FF	   cra=00000000  ta=FFFF<FFFF
        AII ROPS			    AII ROPS
    crb=00000000  tb=21FF<21FF	   crb=00000000  tb=FFFF<FFFF
        10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    pra=11111110  prb=11111111      pra=11111111  prb=11111111
       ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
       event=0000F4  icr=00  sdr=00    event=012A54  icr=00  sdr=00
************************* 20-Mär-22 18:05:51 ************************18.6.6128***
Slave='Harricana.Slave' (896 bytes)
Resload   5BF6A000 - 5BF71CF8 (  31992) at 5BF6A000  GL=$5BF73000
Slave     5BFFE000 - 5BFFE35C (    860) at 5BFFE000  BaseMemSize=$80000
attn=7F(40,82) fc=-1 kn=10371 cs=DC00 rw=0 zpt=-1 ep=0 ei=0
setcpu=0(SNCS,ENCS,BNCS)
Exception "Access Fault" ($7008) PC = $8116 Byte Read from $BFFE01
$000080e0 bsr.w        $6e36
$000080e4 moveq        #5,d0
$000080e6 bsr.w        $24e4
$000080ea tst.w        d0
$000080ec bne.w        $e920
$000080f0 move.l       a6,($890a)
$000080f6 move.l       d4,($890e)
$000080fc add.l        a6,d4
$000080fe addq.l       #1,d4
$00008100 bclr         #0,d4
$00008104 move.l       d4,a6
$00008106 move.l       a6,($406)
$0000810c lea          ($85f8),a0
$00008112 bsr.w        $85de
$00008116 bset         #1,($bffe01)
$0000811e move.l       ($8902),a6
$00008124 move.l       ($8906),d6
$0000812a bsr.w        $6e62
$0000812e bsr.w        $82c0
$00008132 bne.w        $82a4
$00008136 bsr.w        $6fa6
$0000813a bpl.b        $812e
$0000813c move.l       ($88fa),a6
$00008142 move.l       ($88fe),d6
$00008148 bsr.w        $6e62
$0000814c move.l       ($88f2),a6
$00008152 moveq        #5,d6
$00008154 bsr.w        $84a6
$00008158 tst.w        d0
exception stackframe:
$000678C0 20040000 81167008 000678B8 05250005 00250005 00BFFE01 00006D32 00000000
$000678E0 0007FA00 A3A3A3A3 A4A4A4A4 00006B42 00000770 000085E6 00008116
regular stack:
$000678FC 0000E8C2 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006791C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006793C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006795C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$0006797C 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx        0      FFFF   FFF0FFF   FFF0FFF     604BC      1000   FFF0FFF   FFF0FFF
Ax     85F8     7FB1C     7FA00      6D36  A4A4A4A4  A5A5A5A5     604BC
                 TTSM III   XNZVC
PC=    8116  SR %0010000000000100  USP=7FC00  ISP=678C0  MSP=7F800
VBR=5BF74000  SFC=5  DFC=5  CACR=0  MMUSR=0
TC=8000  URP=5BF68E00  SRP=5BF68E00  DTT0=0  DTT1=0  ITT0=0  ITT1=0
         MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
intena=%0100000000001001 dmacon=%0000001111010000 adkcon=$1100
intreq=%0000000000100000
vposr....A300  vhposr...030D  joy0dat..0003  joy1dat..0000  clxdat...8001  
pot0dat..C739  pot1dat..0E08  potinp...5500  serdatr..3BFF  dskbytr..8000  
deniseid.00F8  hhposr...FFC0  
   ciaa:     PI ROPS		   ciab:     PI ROPS
    cra=00000000  ta=21FF<21FF	   cra=00000000  ta=FFFF<FFFF
        AII ROPS			    AII ROPS
    crb=00000000  tb=21FF<21FF	   crb=00000000  tb=FFFF<FFFF
        10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    pra=11111110  prb=11111111      pra=11111111  prb=11111111
       ddra=00000011 ddrb=00000000     ddra=11000000 ddrb=11111111
       event=000112  icr=00  sdr=00    event=014F02  icr=00  sdr=00
TagsNo tags attached.
MachineA1200
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.6
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0011742

CFOU (developer)

fixed vith v1.1

note ~0011797

Irek (reporter)

The game crashes with a different error just after the intro(see below)


************************* 30-Sep-22 20:21:19 ************************18.6.6128***
Slave='Harricana.Slave' (904 bytes)
Resload 5BF6A000 - 5BF71CF8 ( 31992) at 5BF6A000 GL=$5BF73000
Slave 5BFFE000 - 5BFFE364 ( 868) at 5BFFE000 BaseMemSize=$80000
attn=7F(40,82) fc=-1 kn=10371 cs=DC00 rw=0 zpt=-1 ep=0 ei=0
setcpu=33D(DC,IC,SCB,ECB,BNC)

Exception "Access Fault" ($7008) PC = $7B3C Byte Read from $180018

$00007b0a move.w #$ff80,(a1) ;$000124f2
$00007b0e cmp.b (4,a2),d0 ;$0018001c
$00007b12 bne.w $7b20
$00007b16 cmp.b (7,a2),d3 ;$0018001f
$00007b1a bne.b $7b20
$00007b1c bsr.w $798a
$00007b20 subq.w #1,($73c0)
$00007b26 bra.b $7ae6
$00007b28 addq.w #1,d3
$00007b2a cmp.w ($73be),d3
$00007b30 bls.w $7a82
$00007b34 lea ($735e,pc),a6
$00007b38 moveq #0,d4
$00007b3a move.l (a6)+,a2 ;$000073be
$00007b3c tst.b (a2) ;$00180018
$00007b3e beq.w $7b46
$00007b42 move.l (8,a2),a3 ;$00180020
$00007b46 addq.w #1,d4
$00007b48 cmp.w ($73ba),d4
$00007b4e bcs.b $7b3a
$00007b50 move.w #1,($73c4)
$00007b58 movem.l (a7)+,d0-d7/a0-a6 ;$0006787c
$00007b5c bset #0,($bfdf00)
$00007b64 rte
$00007b66 jmp (0)
$00007b6c movem.l d0-d7/a0-a6,-(a7) ;$0006787c
$00007b70 move.l #$dff0a0,a0
$00007b76 lea ($7db2),a3
$00007b7c moveq #0,d0

exception stackframe:
$0006787C 26090000 7B3C7008 00067874 05250005 00250005 00180018 0000743A 000138F4
$0006789C 000075DC 0000740A 00012B0A 00007F13 0000738A 00007988 00007AE0
regular stack:
$000678B8 00007FFE 00000004 00000001 056D999F 00020000 00025920 00025920 0000800A
$000678D8 00007B66 0003DB9C 00036B50 00008708 00038D34 A5A5A5A5 000124BC 20000000
$000678F8 82300078 0000E8C2 00000000 00000000 00000000 00000000 00000000 00000000
$00067918 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
$00067938 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

  ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
Dx 1218 18 0 7 17 20002 25901 0
Ax 12B0A 124F2 180018 FE4E75 12B0A 7F13 73BE

                 TTSM III XNZVC
PC= 7B3C SR %0010011000001001 USP=7FC00 ISP=6787C MSP=7F800
VBR=5BF74000 SFC=5 DFC=5 CACR=80008000 MMUSR=0
TC=8000 URP=5BF68E00 SRP=5BF68E00 DTT0=0 DTT1=0 ITT0=0 ITT1=0

         MEDRAAAABVCPSDT YZ PMRCBSDAAAA
intena=%0110000000001001 dmacon=%0000001111010011 adkcon=$1100
intreq=%0010000111100000
vposr....A300 vhposr...0294 joy0dat..0301 joy1dat..0000 clxdat...8001
pot0dat..D239 pot1dat..F34A potinp...5500 serdatr..3BFF dskbytr..8000
deniseid.00F8 hhposr...FFDD
   ciaa: PI ROPS ciab: PI ROPS
    cra=00000000 ta=21FF<21FF cra=00000000 ta=FFFF<FFFF
        AII ROPS AII ROPS
    crb=00000000 tb=21FF<21FF crb=00000001 tb= E70<166B
        10RTWCLO parallel DRCCDSOY M3210HDS
    pra=11111110 prb=11111111 pra=11111111 prb=11111111
       ddra=00000011 ddrb=00000000 ddra=11000000 ddrb=11111111
       event=000433 icr=00 sdr=00 event=05225B icr=82 sdr=00

note ~0011798

CFOU (developer)

confirmed, it's a stupid bug in original music player code...

can your test attached beta slave? (tested with success on Winaue+a40+mmu)

note ~0011799

Irek (reporter)

It seems to be working with the new update now. Thanks!:)

A few months ago I made some icons for the game. Feel free to use it if you like them.

note ~0011800

CFOU (developer)

access fault in music player code fixed with v1.2
+Notes

-Issue History
Date Modified Username Field Change
2022-03-25 00:25 administrator New Issue
2022-03-25 00:25 administrator Status new => assigned
2022-03-25 00:25 administrator Assigned To => CFOU
2022-09-17 11:49 CFOU Status assigned => closed
2022-09-17 11:49 CFOU Resolution open => fixed
2022-09-17 11:49 CFOU Note Added: 0011742
2022-10-03 18:18 Irek Status closed => feedback
2022-10-03 18:18 Irek Resolution fixed => reopened
2022-10-03 18:18 Irek Note Added: 0011797
2022-10-03 19:33 CFOU File Added: Harricana-beta.lha
2022-10-03 19:33 CFOU Note Added: 0011798
2022-10-04 15:59 Irek Note Added: 0011799
2022-10-04 15:59 Irek Status feedback => assigned
2022-10-04 16:00 Irek File Added: HarricanaIcons.lha
2022-10-04 16:33 CFOU Status assigned => closed
2022-10-04 16:33 CFOU Note Added: 0011800
+Issue History