WHDLoad MantisBT - FantasticDizzy
View Issue Details
0004060FantasticDizzy[All Projects] Generalpublic2019-01-28 23:162019-04-06 20:21
ReporterRetroplay 
Assigned ToJOTD 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
MachineUAE
CPU68030
CPUSpeed33
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftSelfmade
WHDLoad18.4beta
importedyes
Summary0004060: AGA version crash to a black screen with white garbled text when trying to save
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 2.0 from 13.01.2019

AGA version crash to a black screen with white garbled text when trying to save game.
I uploaded a video that shows what happens.
https://streamable.com/0go0s
WHDLoad doesn't crash and I can quit game.
No crash dumps are produced.
TagsNo tags attached.
has duplicate 0004095new  Fantastic Dizzy AGA. If I press ESC in game and select Load or Save game it 
Attached Files

Notes
(0006684)
JOTD   
2019-01-28 23:28   
it's not a crash it's a display problem. Got it working on WinUAE by setting FMODE register to 0. Apparently it doesn't work for you...
(0006687)
Retroplay   
2019-01-31 11:13   
No it doesn't, unfortunately I can't test on either of my real A1200s as I usually do.
Both are in need of service and needs to be repaired.
(0006731)
JOTD   
2019-03-02 16:23   
What is your UAE version? On WinUAE it works fine.
(0006732)
Retroplay   
2019-03-02 16:52   
Latest WinUAE 4.2.0 public beta 2, 2019-02-16 64-bit.
(0006755)
Hexaae   
2019-03-18 15:53   
I've just discovered AGA version does not crash: if you press 7,8... you can actually (but can't read because of garbled gfx) save and load position.
Tried to press 7 + savegame-name + return + return and it actually saved the position. Then to Load I selected 7 + return.
So… it looks like a trashed gfx issue only after all...
(0006762)
Solo Kazuki   
2019-04-06 17:37   
I see that both Retroplay and Hexaae are using custom kickstart. Maybe it's fault of this bug? Is this occurs also on normal kickstart?
(0006763)
Retroplay   
2019-04-06 19:13   
Yes, it also happens for me with normal 3.1 rom.
(0006764)
Hexaae   
2019-04-06 20:21   
Yeah, ESC menu > Load game is just trashed, but actually still working.
In this video I press 7-8 to select two different savegames, and finally press RETURN to load, and it works:

https://www.youtube.com/watch?v=SEDA4Xj9o4A

The reason for trashed in-game Load/Save menu is unknown ATM.

Issue History
2019-01-28 23:16administratorNew Issue
2019-01-28 23:26JOTDAssigned To => JOTD
2019-01-28 23:26JOTDStatusnew => acknowledged
2019-01-28 23:28JOTDNote Added: 0006684
2019-01-31 11:13RetroplayNote Added: 0006687
2019-03-02 16:23JOTDNote Added: 0006731
2019-03-02 16:52RetroplayNote Added: 0006732
2019-03-18 14:50WeplRelationship addedhas duplicate 0004095
2019-03-18 15:53HexaaeNote Added: 0006755
2019-04-06 17:37Solo KazukiNote Added: 0006762
2019-04-06 19:13RetroplayNote Added: 0006763
2019-04-06 20:21HexaaeNote Added: 0006764